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About this manual 

Typographical conventions 

This manual distinguishes between different types of information using the following conventions: 

• Terms taken from the interface itself, such as commands, appear in bold. 

• Key names appear in all caps. For example: ''Press the SHIFT key''. 

• Numbered lists indicate that there is a procedure to follow. 

• When the conjunction -or- appears next to a paragraph, it means there is the choice of another 

procedure for carrying out a given task. 

• When a menu command contains submenus, the menu name followed by the command to select 

appears in bold. Thus, ''Go to File > Open'' means choose the File menu then the Open command. 

About your product 

Some of the functions described in this manual may not be available in your product. 

For the complete list of specific features available in your software, refer to the specification sheet provided 

with the product. 
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Introduction 

Welcome! 

Congratulations, you have just acquired the world’s leading automatic identification software package! 

 

Presentation 

This label design software allows you to quickly create and edit complex labels and allows you to integrate all of 

the electronic data from across your company, guaranteeing the full integrity of all your systems. 

The application meets all your automatic identification needs, and fits seamlessly into your production process. 

In today’s market, it is quite simply the most user-friendly and intuitive solution for any company involved in 

complex barcode data entry, collection and editing in real time. 

Product description 

Your product includes the following components: 

• A CD for the installation. 

• Complete electronic documentation. 

• A license agreement and registration card. 

• A protection key: either electronic (software key) or hard key (dongle). 

Note: The Release.txt file contains the latest information on the software. This information supersedes that 

contained in this manual. 

System requirements 

The basic software and hardware requirements needed to run the application are similar to those of most 

applications running on Windows™: 

• One of the 32 or 64 bit Windows operating system: 7, XP, Server 2003 or 2008 or Vista. 

• Computer with 1 GB of free RAM (depending on the system). 

• A hard drive with at least 500 MB free disk space (depending on the installation options). 

• CPU: 2 Ghz minimum. 

• Video card : DirectX 9 minimum. 

• Administrator rights to the computer during installation. 

Note: To eliminate the possibility of compatibility issues, please remove all previous versions of this labeling 

software that may be installed on your system. 

Installation 



User Guide 

2 

 

Note: Before installing this software please save your work and close all other programs. 

Before running the installation program, check the configuration of your PC. 

1. Place the CD for the installation in the correct drive. The Installation window appears. 

If this CD does not start up automatically: 

2. Go to Start > Run and then type the letter of the CD-ROM drive followed by the filename index.hta 

(for example D:\index.hta). 

  

3. Select the product you wish to install, then click on the Install button and follow the instructions 

displayed on your screen. 

Installing the software 

Select the program feature you want to install, then click Next. 

 

Before running the installation process, check that you have local administrative rights. 
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License activation 

Your software can be activated using a software key (an activation code) or a hardware key (a dongle). 

The dongle is a small electronic device that you plug into your PC’s parallel or USB port before launching the 

software. Without the hardware protection key, the program will run in ’evaluation’ mode. You will not be able 

to save your labels, 'e' will be replaced with 'x', '0' will be replaced with '5' and images will be crossed when 

printing. 

The software key is an activation code that is requested by the Activation Wizard when you launch the software 

for the first time or for as long as you are running a trial version. If you are using a trial software key, you will 

be given 100 runs or 30 days to try the product with all of the product’s functionality available to you. 

Note: When you launch the application, if the protection key does not correspond to your product version, a 

dialog box will appear providing the necessary instructions. 

You must first run your labeling software installation and then activate or connect the protection key to your 

computer. 

Hardware key protection 

If you have purchased the software with a dongle, you may choose between a USB or parallel port dongle. 

Connecting the parallel key: 

 

If you need to use a printer on the same parallel port, simply plug it into the software protection key. It may be 

necessary to turn the printer on in order for the software protection key to be recognized. 

Connecting the USB key: 

 

When you use a USB key and have multiple USB ports, it does not matter which port you use. If you do not 

have an available USB port, you can use a USB expander hub. USB devices are hot-swappable, meaning you 

can plug and unplug them into the bus any time, without restarting the PC.  

Note: Drivers can be installed while the application is running. However you must restart your labeling 
software for the changes to take effect. 
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USB hardware keys are not supported using Windows 95 and Windows NT4 operating systems. 

Error messages when launching the software 

If you are prompted with an error message when launching the software, please check the following items: 

• Administrative rights. You must have local administrative rights on your PC so that the key 

installation works properly. If you do not have them, you will receive an error message when launching 

the software. You will have to manually install the drivers. 

• Drivers installation. If you had trouble during installation or if you receive an error message when 

launching the software, you will have to manually install the drivers. 

• The key: Check that the connected key works with your labeling software. 

• Driver update: Your driver may not be updated. To update it, you have to download it from 

http://www.aladdin.com/support/hasp/enduser.aspx 

Software key protection 

Once you have installed the labeling software, the Activation Wizard will be launched, taking you through the 

software key protection process. 

To activate the software key: 

In the Activation wizard, select Activate and click Next. There are three possible activation methods: 

Automatic (Internet), Telephone/Website, and Fax. 

• Automatic activation method (recommanded) 

1. Select Automatic from the list of activation modes. This option allows the activation of the software 

key via a secure Internet connection. This is the quickest and easiest option available. 

2. Input your information in the User Registration form. Remember that all fields marked by an asterisk 

(*) are required. Click OK. 

3. Enter the activation code provided with the product and click Next. 

4. Click Finish if your activation results are successful. If any problems were encountered, a message will 

inform you that the activation has failed and an error will be displayed. 

• Telephone/Website activation method 

1. Select the Telephone activation method. 

2. Enter the activation code provided with the product and click Next. 

3. Call your reseller.  

 

Note: You will be required to fill out a User Registration via the phone. Please have your company 

information on hand. 

  

4. Enter the Response Code provided to you by your reseller and click Next. 

5. Click Finish if your activation results are successful. If any problems were encountered, a message will 

inform you that the activation has failed and an error will be displayed. 
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• Fax activation method 

1. Select the Fax activation method. 

2. Input your information in the User Registration form. Remember that all fields marked by an asterisk 

(*) are required. Click Next. 

3. Enter the activation code provided with the product and click OK. 

4. Click the Create Form... button. An Activation Request Form will be created with all the required 

user information. This form must be sent by fax or email in order to receive the response code. Please 

use the contact info on your screen. Click Next. 

5. While waiting for a Response Code, you may choose to launch your software and begin using it, or 

close it and return to the activation process once you have received your response code. 

 

Once you have received your Response Code, you can return to the activation process by restarting 

the wizard. Select Fax activation method. Click Next until you reach the screen from step 5. Choose 

the option Enter the Response Code. All the options you had previously selected in the wizard are 

retained. 

6. Enter the Response Code provided to you and click Next. 

7. Click Finish if your activation results are successful. If any problems were encountered, a message will 

inform you that the activation has failed and an error will be displayed. 

  

Installing the driver key manually 

If you want to install your key driver manually, do the following: 

• Click Start, then Run. 

• Enter C:\program files\TKI\9\Common\Tools\Dongle\ file path then type the following command: 

\HaspDinst.exe -i 

Note: It is recommended that you close your labeling software and other applications before installing your 

driver. 

Launching the program 

1. Go to Start > Programs. 

2. Select the name you gave to the program group when you installed it (by default, it is the name of the 

application). 

The main window appears on the screen. 
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Discovering the interface 

Description of the main window 

This section presents a general overview of the main interface elements as they appear in the main window at 

the beginning of a work session.  

The Menu Bar 

The Menu bar contains the following options: File, Edit, View, Object, Data Sources, Tools, Window, and Help. 

To open a menu 

1. Select the menu. 

2. Choose the command of your choice. 

Note: To access a command using the keyboard, use the hot keys. Press ALT plus the letter underlined in the 

menu name or the command name. 

The Workspace 

The workspace is the central part of the window, situated between the graduated rulers and the scroll bars. It 

contains a frame that sets the physical limits of the document and contains the objects to be printed, as well as 

a non-printable area for inserting comments and objects you do not want to print.  

The Document 

When you open a new session, the program displays a frame in the top left corner of the window. This frame 

represents the physical limits of the document to be printed.  

Place objects inside this frame to create your document.  

The Status Bar 

Located at the bottom of the window, the Status bar displays the name of the selected printer, the port it is 

connected to, the x and y coordinates of the mouse pointer, and the cx and cy dimensions of the selected 

object.  

 

The Toolbars 

These tools allow you to execute routine tasks more quickly than using the menus. 

 

To select a tool 

Click the button corresponding to the tool.  
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The Title Bar 

The Title bar displays the name of the software and the name of the current document, or "documentno" if a 

new document is created. It allows the workspace window to be moved using the mouse.  

Text formatting toolbar 

These tools allow you to modify text and/or paragraph formatting; that is, change the font, character size, style 

options, text wrap, and so on. 

 

To change the formatting: 

1. Select an object in your document. 

2. Click on the required options. 

Note: All these options can also be accessed in the Text properties dialog box. 

Object toolbar 

The Object toolbar displays the name of the selected object and allows you to access its properties. 

 

View toolbar 

The View toolbar offers you a number of display options. 

To change the view mode click on the required view mode: 

  

Button Name of tool Use 

 
Name Displays variable names. 

 
Size Displays variable size maximum. 

 
Contents Displays variable values. 

 
Form Displays the Form. 

 
Views Displays the Data sources and Objects view. 

 
Zoom Allows you to increase or decrease object detail. 

Note: All these options can also be accessed via the View menu. 
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Design toolbar 

The Design toolbar comprises a number of buttons, each one representing a tool for creating and manipulating 

objects. 

Button Name of tool Use 

 
Selection tool Selects and manipulates objects of all types. 

 
Text generation Creates fixed and variable text. 

 Barcode generation Creates fixed and variable barcodes. 

 Image import Inserts images. 

 External object insertion Inserts objects external to the application. 

 Line drawing Draws horizontal or vertical lines. 

 Rectangle drawing Draws rectangles or squares. 

 Circle or ellipse drawing Draws circular shapes. 

 Polygon drawing Draws free shapes composed of lines. 

 Oblique line drawing Draws diagonals. 

 
Rounded rectangle drawing Draws rectangles with rounded corners. 

 
Shapes Gallery tool Imports ready-to-use shapes into the document. 

 
UCC/EAN 128, HIBC and Maxicode 

wizards 

Creates barcodes with the UCC/EAN 128, HIBC, and Maxicode 

wizards. 

 
Plug-ins Creates TextArt, ListFields, OCXFields, and RichText Fields. 

Data Sources and Objects Views 

The Data Sources view displays the data sources and the number of variables associated. You can insert 

variable objects simply by dragging and dropping them into your document. You can also add, delete, and 

modify variable properties using the context menu. 

The Objects view displays the number of objects created according to type and their properties, such as 

position, height, and width. You can also use this tab to select an object and change its position. 
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The up arrow and down arrow keys on your keyboard allow you to move up and down the object tree. The + 

and - symbols allow you to expand or shrink the list and display the list of variables associated with each data 

source or the objects available for each category. 

About data sources 

A data source contains a list of variables fed by data from the same source. 

When you select a data source, you are indicating where the required data is located, and what type of data it 

is. The data can be of internal origin (Date, Counter) or external to the application (Database, direct data 

entry using the Form). 

The different data sources available in the Data Sources view are the following: Database, Date, Form, 

Formula, Table Lookup, Counter and Free. 

Graduated rulers 

Graduated rulers are used to view the position of the mouse and accurately place the various objects in the 

document. They can be set in either inches or millimeters using the Tools > Options command. 

The rulers allow you to pinpoint the position of the mouse pointer and place the various objects you include in 

your document with total precision. They may be configured in inches or millimeters using the Tools > 

Options > Display command. 

• Double-clicking on the left half of the horizontal ruler reduces the display scale. 

• Double-clicking on the right half of the horizontal ruler increases the display scale. 

• You can display the Zoom factor context menu by right-clicking on the horizontal ruler, or the 

Orientation context menu by right-clicking on the vertical ruler. 

Rotation button 

Clicking on   located in the top-left corner of your documents allows you to rotate the document on the 

screen 90°, 180°, 270° or 360°. Screen rotation is merely a display feature, and has no effect on printing. 

To rotate the document: 
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• Click on the rotation button with the left mouse button to rotate the document 90° to the left. 

• Click on the rotation button with the right mouse button to rotate the document 90° to the right. 

Note: You can obtain the same document rotation effect by using the View > Orientation command, or by 

clicking on the vertical ruler with the right mouse button to display the context menu. 

Color palette 

The color palette is displayed at the bottom of the workspace and allows you to modify the color of any object 

in your document (text, barcodes, shapes, etc.). 

 

To change the color of an object: 

1. Select the required object. 

2. Click on a color in the palette with the left mouse button to apply text, line or outline color. 

3. Click on a color in the palette with the right mouse button to apply background color. 

Note: This button X removes the background color from an object. 

You can also change the color by using the Properties dialog box. 

1. Double click on an object. The Properties dialog box appears on the screen. 

2. Select a color (foreground and background) on the Character tab 
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Setting up the work environment 

Choice of printer 

Before starting to create a document, you first need to set up your work environment. 

The first step consists of selecting the printer on which you wish to print your labels. Not all printers share the 

same characteristics and, as a result, different options are available according to the model of printer chosen.  

The second step involves choosing your work environment options; for example, interface language, unit of 

measurement, and so on. We will review all the options available later in this chapter. 

The final step consists of the document page setup; for example, defining the dimensions of the document, 

orientation, margins, and so on. 

Your label design software allows you to print on a wide range of printers, the drivers for which are supplied 

with the software. You can also print on any Windows printer installed locally on your machine or on your 

company’s network. 

You must select the printer before you begin creating your document as the choice of printer will determine 

page setup options, the use of different character fonts, and so on. 

Selecting a printer 

The Printer selection dialog box can be accessed using: 

Command: File > Select printer 

-or- 

Click the  button  

- or -  

Press the F5 key. 

It can also be accessed by clicking the Printer button in the Print dialog box (F6). 

A printer must be selected before your document is created. The choice of printer affects page setup options, 

use of various fonts, etc. 

Windows printers and native printers 

As we have already seen, your label design software is capable of printing on a wide range of Windows and 

native printers, both direct native and native transfer. 

The term Windows printer refers to any printer installed on your operating system; generally office printers, 

laser printers, and so on. Print jobs are sent to the Windows spooler (job queue). 



User Guide 

14 

 

The drivers for native and native transfer printers are supplied with the label design software. Printing on these 

printers is managed directly by the software. 

To select a printer 

1. Choose File > Select printer... 

You can also click the  button or press F5. 

2. Select the printer from the list. 

3. Click OK. 

Note: The drivers provided by the application are identified by an icon. 

Adding a printer 

You can access the Add a printer dialog box through the File > Select printer command, and by clicking 

Add. 

This dialog box allows you to add the printer drivers supplied with the software. 

Note: To add a Windows printer, you must use the operating system’s control panel. 

To add a printer: 

1. Click File > Select printer. 

You can also click the   button or press F5. 

2. Click Add. 

3. In the Model list, select a manufacturer family, and then a model of printer. 

4. Select the port (serial, parallel or file), then click OK. 

Note: Click the plus sign (+) next to the printer manufacturer family to display the different models. 

The different ports 

Port 

name 

Use 

COMx Designates the serial communications ports. Select the number of the serial port to which your 

printer is connected. 

LPTx Designates the parallel communications ports. Select the number of the parallel port to which your 

printer is connected. 

File Select File if you wish to print to a file. 
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Demonstration 

 

Adding a Zebra 140 on LPT1 

 

1. Choose File > Select printer. 

2. Click Add. 

3. In the Model list, select the Zebra group, then the model. 

4. Select the LPT1 port, clear the Direct access box, and click OK. 

Customizing the work environment 

Your software offers a number of options for customizing your work environment. 

Options include the choice of interface language, unit of measurement, dialog box display font, working folders, 

and currency conversion rate. 

Changing the interface language 

The user interface is available in various languages and can be changed easily.  

To change the interface language: 

1. Choose Tools > Options. 

2. Click the Display tab. 

3. Select the language. 

4. Click OK. 

Note: Once you click OK, all the menus, commands and screen messages will be displayed in the selected 

language (except the online Help and the Windows dialog boxes, such as Open and Save as).   

Modifying display options and the work environment 

You can modify the interface language, units of measurement, and the display font for dialog boxes. These 

choices are made, using the Display tab. 

To access the Display tab, choose Tools > Options.  

Choosing a unit of measurement 

The unit of measurement may be in millimeters or inches. The choice of the unit of measurement changes the 

graduated rulers.  

To choose a unit of measurement: 

1. Choose Tools > Options. 

2. Select the Display tab. 

3. Select the unit. 

4. Click OK.  
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To change the dialog box display font 

1. Choose Tools > Options. 

2. Click the Display tab. 

3. In the Display font field, click . 

4. Select the font. 

5. Click OK.  

To modify the grid scale 

The grid scale, which is used to align objects, can be modified or disabled.   

1. Choose Tools > Options. 

2. Click the Grid tab. 

- or - 

Double-click on the vertical ruler to access the Grid tab directly. 

3. Select the required grid scale. 

4. Select the Display option. 

5. Click OK. 

Note: The unit of measurement used for the grid scale is defined in the Display tab.  

To define a conversion rate  

The conversion rate defined in the box is used in the eurotocurrency and currencytoeuro formulas. 

1. Choose Tools > Options.  

2. Click the Others tab. 

3. Enter the conversion rate in the box. 

Note: The default conversion rate is between the French Franc and the Euro.  

Defining the working folder 

The first time you open the Open and Save as dialog boxes after starting the software, the My Documents 

folder is selected as the default working folder. 

1. Choose Tools > Options, then the Default folders tab. 

2. Click the Path column to change the default working folder. 

- or -  

Click the  button and select the new default working folder. The path changes in the Directory 

column. 
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3. Click OK. 

Document page setup  

Formatting a document 

Document templates are created and modified in the Page setup dialog box. 

Formatting a document consists of setting the page size, its orientation, the number of labels per row and per 

column, document size, margins, and distance between labels. You can create your own document templates 

and save them for future use. 

Note: Before creating a document stock, you must first choose the model of printer that will be used to produce 

the document. Choose File > Select printer. 

Page format is defined using the Page setup dialog box. It updates the printer settings. The software does not 

use the page settings defined in the Printer settings dialog box. 

To access the Page setup dialog box: 

1. Choose File > Page setup. 

- or - 

Click the    button.  

2. Click the Label tab and enter the size and number of labels. 

3. Click the Page tab and select the page size and its orientation. 

4. Type the desired values in the Margins tab. 

The Stock tab allows you to save customized stocks. 

5. Click OK. 

Note: When the parameters entered are incompatible with the size of the stock, an error message is displayed. 

Demonstration 

Creating and defining the page setup for a customized stock 

1. Create a new document. 

2. Select the generic Windows printer. 

3. Choose File > Page setup. 

- or - 

Click the  button. 

4. Click the Label tab and enter the following values: 

• Width and Height: 30/30, 

• Number of labels: 

•  Per row: 2, 

•  Per column: 3, 
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•  Corner roundness: 0. 

5. Click the Page tab and select the following values: 

•  Page sizing: Automatic, 

6. Click on the Margins tab and enter the following values: 

• Margins: 

•  Left: 10, 

•  Top: 10, 

• Gap: 

•  Between rows: 5, 

•  Between columns: 5. 

7. Click the Stock tab and enter the following values: 

• Type: Family, 

• Name: Layout1. 

8. Click OK then save the label as C:\CSL1\WORK\TEST1.LAB. 

Designing a CD sleeve: page setup and creating a customized stock 

1. Create a new document and call it FRONT. 

2. Select the printer. 

3. Go to Tools > Options, click the Display tab and select Millimeters as the unit of measurement. 

Click OK. 

4. Go to File > Page setup... 

-or- 

Click the . 

5. Click on the Label tab and enter the following values: 

• Width and Height: 120, 

• Corner roundness: 100, 

• Number of labels: 

• Per row: 1, 

• Per column: 2. 

6. Click on the Page tab and select the following values: 

• Page size: A4, 

• Portrait. 

7. Click on the Margins tab and enter the following values: 

• Margins: 

• Left: 40, 
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• Top: 10, 

• Gap: 

• Between rows: 15. 

8. Click on the Stock tab and enter the following values: 

• Type: Jaquette, 

• Name: CDx2. 

9. Click OK. 

Note: The printer used in this example is a Windows™ printer. If you wish to use a native printer, it is possible 

for error messages to appear during page setup. You will therefore need to modify the values suggested in the 

example because as we have already seen, the choice of printer affects certain settings. 

Deleting a customized stock 

When a stock you have created is no longer needed, you can remove it. 

To remove a customized stock: 

1. Choose File > Page setup. 

- or - 

Click the    button. 

2. In the Stock tab, select a stock from the Type and Name lists. 

3. Click the Remove button. 
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Creating a document using fixed object 

Creating and manipulating objects 

Creating fixed objects involves inserting objects such as text, barcodes, images, lines, rectangles, and circles 

into your document. 

Creating objects 

You can quickly and simply create an object in your document (bar code, image, text, drawing, etc.) using: 

• The Creation toolbar, 

- or - 

• The Object menu. 

Note: Each object created is automatically given a name by the application. When the object is selected, its 

name appears in the Objects view and in the Object toolbar. 

You can create an object using one of the following options: 

• Direct mode creation: 

1. Click directly on the object or icon you want to insert into your document. 

2. Click the location where you want to place the label. 

       - or - 

• Guided mode creation (according to your requirements): 

1. Click the menu button for your object. A submenu appears with the list of actions you can assign to it 

(Fixed object, Wizard, New data source, Use an existing data source). 

2. Select the action you need. 

3. Click the location where you want to place the label. 

Modifying an object 

You can change an object using: 

• Buttons on the toolbar, formatting toolbar, alignment toolbar, etc. 

• Double-clicking the object 

• Document Explorer Objects view > Properties... 

The Drag and Drop (To drag and drop, click on the item and, holding the left mouse button down, drag the 

item to the desired location.) function is used to perform current tasks (Current task include creating text or 

image objects by dragging and dropping text and graphic files supported by the application in Windows Explorer 

or creating variable objects by dragging and dropping data sources in the Data Sources view.). 
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To create a text object 

A Text object can be one character, one word or an entire paragraph. 

Character style and paragraph format can be defined using the Text formatting toolbar or the Text dialog 

box. 

To create a Text object: 

1. On the Creation toolbar, click the Writing tool. 

- or - 

Choose Object > Text. 

2. Click inside the workspace or on the text to be modified. 

- or - 

Click and drag out a frame in the workspace. 

3. Enter your text. 

The style of the text can be defined using the Text dialog box. 

To open the Text dialog box: 

 

Choose Object > Text. 

- or - 

Press the F7 key. 

Demonstration: Creating a CD sleeve: inserting text 

1. Click on the Text generation tool. 

2. Click inside the workspace and type ''Volume:''. 

3. Select the text then double click on it. 

4. Enter the following values 

• Font: Arial, 

• Height: 10 points. 

5. Click OK. 

6. Repeat the above procedure to insert the text ''conducted by:''. 

To position the ''Volume:'' and ''Conducted by:'' objects: 

1. Select one of the Text objects in the document. 

2. Click the Objects view. 

3. Using the mouse, open the branch of the tree marked with a  (pointing to the object selected in the 

document). 

For the Text object... Select Press the F2 key, then enter... 

''Volume:'' the x coordinate: 

the y coordinate: 

''10'' 

''40'' 
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''Conducted by:'' the x coordinate: 

the y coordinate: 

''10'' 

''40'' 

4. Select the two text objects and click on the Lock button. 

Unicode can be used to create labels using a variety of linguistic characters. To use Unicode, just select a 

Unicode font for your text by going to the Character tab available in the Properties of your text object. 

To create a barcode object 

Your software offers a wide range of symbologies adapted to the requirements of the industry, as well as the 

option of creating 2D barcodes. 

Selecting the symbology, defining its attributes and entering the message to be encoded are carried out using 

the Barcode dialog box. 

To create a Barcode object: 

1. In the Creation toolbar, click on the Barcode generation tool . 

- or - 

Choose Object > Barcodes 

2. Click inside the workspace. 

The Barcode dialog box is displayed.  

3. From the Code tab, select the barcode of your choice. You have the choice between Printer and 

Graphic. 

4. Click Printer to display the list of barcodes resident on the printer. 

- or - 

Click Graphic to display the list of barcodes generated by the software. 

5. If necessary, specify the characteristics of the barcode (height, narrow bar width, ratio, check 

character). 

6. Enter the data to be coded in the Data box. 

7. Click OK. 

Note: Certain printers do not have resident barcodes. The Graphic option allows barcodes to be printed despite 

this. This has the disadvantage of slowing printing down as barcodes are sent to the printer in the form of 

graphics. 

Demonstration: Creating a Barcode object 

1. Open the C:\CSL1\WORK\RECTODISK1_00.LAB LABEL. 

2. Click the Barcode generation tool. 

3. Click inside the workspace. 

4. Select CODE 39 in the Graphic Symbology list. 

5. Enter the following data: 

• Height: 8, 

• Narrow bar: 2, 

• Select 1 digit in the Check character list, 

• Select 270° in the Rotation box, 



User Guide 

24 

 

• Enter 1234 in the Data box. 

6. Click OK. 

Creating a shape object Example: Drawing a line 

Your software comes complete with a range of tools to help you design perfect labels. 

You can draw a line, a circle, a rectangle, etc. using the same process described below. 

To draw a line: 

1. Click the Line drawing    tool. 

- or - 

Choose Object > Shape > Line. 

2. Click inside the workspace. 

3. Move the mouse while holding the left button down. 

Demonstration: Creating a CD sleeve: drawing a circle 

1. Click the Circle or ellipse drawing tool. 

2. Click inside the workspace. 

3. Holding the left mouse button down and pressing the SHIFT key, move the mouse horizontally to 

create the required shape. 

4. Select the circle and choose Properties in the context menu. 

5. Click on Position/Size and enter the following values:  

• Width and Height: 20.  

• Click OK. 

6. Go to Object > Layout > Horizontally centered in document then Vertically Centered in 

Document to align the circle with the center of the sleeve. 

7. Select the circle then click on the Lock button. 

To import an image 

Your software allows you to insert images and company logos to help you perfect your label. 

A number of formats can be imported: bmp, dib, dxf, emf, fmf, eps, fpx, img, gif, jpg, pcd, pcx, dcx, png, rle, 

tga, tif, wmf and wpg. 

1. In the Creation toolbar, click the Import Image tool. 

- or - 

Choose Object > Image.  

2. Click inside the workspace. 

The Image selection dialog box is displayed. 

3. In the Browse for a file tab, select the image to be imported.  



Creating a document using fixed object 

25 

4. Select the image filename. 

5. Click OK. 

Note: To display a preview of the image, click the Preview button. 
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Creating a document using variable objects 

About data sources 

A data source contains a list of variables fed by data of the same origin. 

When you select a data source, you are indicating where the data you are interested in is found and what type 

of data you require. The data can be of internal origin (formula, date, counter) or external to the application 

(database, direct entry, ActiveX). 

The different data sources available in the Data Sources view or menu are the following: 

• The Database data source: Allows you to connect a database. 

• The Date data source: Allows you to insert date or time. 

• The Formula data source: Allows you to create formulas within your document. 

• The Form data source: Allows the data to be entered when printing. 

• The Table lookup data source: Allows you to add the result of searches carried out in databases. 

• The Counter data source: Allows you to insert a self-incrementing value. 

• The Free data source: These data sources are populated by data that is not specified when they are 

created. A Free data source can be used to create intermediate data sources. 

Creating a data source 

Data sources allow you to use data external to the application, for example, calculated data, your computer's 

date system, etc. The values associated with these variables are supplied by different data sources.  

You can create a data source from: 

The Data sources view  

1. In the Data sources view, right-click one of the data sources.  

2. Select Add from the pop-up menu. 

The Data source menu  

1. Click the Data source menu. 

2. Select one of the data sources. 

3. Click Add. 

The Toolbar 

1. Click    in the toolbar. 

2. Select the data source you want. 

3. In the submenu, select Add. 

For each of these creation modes: 
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• The data source created is displayed automatically under the selected data source. 

• The application gives the data source a default name.  

Note: Brackets {} cannot be used in a variable name.  

This procedure applies to all data sources, except variables from the Database data source. To create a 

database variable, you need to create a query.  

The Database data source 

Command: Data source > Database > Create/Modify query. 

The Database data source contains a list of variables created as and when you need them. These variables are 

populated by data from queries or ASCII tables. 

Note: When they are created, data sources keep the names of the fields that populated them. 

Note: Database variables cannot be renamed as linked to the database fields names. 

Creating a query 

Command: Data source > Database > Create/Modify query 

1. Select the data source from the Select data source list. 

Note: For a new data source, click the New data source button. This gives you the option of using the Wizard 

or choosing between an ODBC or OLEDB data source. 

By default, Standard creation mode is activated. However, to produce your query, you can use Advanced 

SQL creation mode. 

 

Standard creation mode  

2. In the Select table list, select the table where the search is to be carried out.  

The Include table names option, allows you to display the table names in the list of fields.  

3. In the Elements list, select the elements you want to display.  

4. In the Select fields list, select the fields for the table selected. 

Note: Click   to select all the fields. 

Hint: We recommend that you only select the fields to be used in the label. This reduces the amount of 

exchange with the database, thus increasing processing speed. 

5. Click   to view the result. 

SQL advanced creation mode 

2. Select SQL mode.  
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3. Enter your query in SQL format in the edit field, 

- or -  

Click SQL Query Builder to access the Query Builder. This provides an easy-to-use interface for 

building SQL database queries. You can create new requests graphically or represent existing requests 

graphically in your applications.  

 

4. Click  to view the result. 

The data sources created carry the field names of the database. 

The navigation bar is displayed in your workspace. 

Click OK when you have finished. 

The Table lookup data source 

Command: Data source > Table lookup > Add 

The Table lookup data source contains a list of data sources you have created. The data source values are the 

result of searches carried out in databases other than those linked to the current document. 

Searches are carried out in one or more database fields. Data is extracted from one of the record fields found 

(called the "result field"). 

Command: Data source > Table lookup > Properties. 

1. Select the data source from the Select data source list. 
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Note: To create a new data source, click the New data source button. This gives you the option of 

using the Wizard or choosing between an ODBC or OLEDB data source. 

2. By default, Standard creation mode is activated. However, to carry out a table lookup, you can use 

Advanced creation mode: SQL. 

Standard creation mode 

3. In the Select table list, select a table where the search is to be carried out. 

4. In the Select result field list, select the field whose value is to be transferred into your variable.  

5. Click    to add a row.  

6. Select the field in the external table on which the search is to be carried out.  

7. Select the current document variable containing the search value.  

8. Click the Test button to display the result. 

SQL advanced creation mode 

3. Click SQL format creation mode.  

4. Enter your query in SQL format.  

- or -  

Click SQL Query Builder to access Query Builder. This provides an easy-to-use interface for building 

SQL database queries. You can create new requests or represent existing requests graphically in your 

applications.  



Creating a document using variable objects 

31 

 

5. Click the Test button to display the result in the Query dialog box. 

The Date data source 

Command: Data source > Date > Add 

The Date data source contains a list of data sources created. These data sources are fed by the computer's 

date system or by the printer. It allows you to display the date and time in the format previously defined. The 

values are updated automatically at the start of each print session. 

You can insert the current date and/or time into a document. You can also add a fixed value to the current date 

or time. 

Defining the properties of a Date data source 

1. In the Date tab, select the desired format for the date and time. 

2. The date format is displayed in the Preview zone. 

3. Click OK. 

Demonstration: Inserting a date 

 

1. Open a label. 

2. Add a Date data source and name it datefab. 

3. Compose the date in the Date dialog box. It must be in the dd/mm/yy format. To add separators, enter the 

''/'' character in the text box in the lower left of the dialog box, then click Add. 
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3. Click OK. 

4. Select the Date (datefab) then drag and drop it into the workspace. 

5. Choose Text in the context menu. 

The Counter data source 

Command: Data source > Counter > Add 

The Counter data source contains a list of data sources you have created. These data sources are populated by 

data calculated either by the computer, or by your printer. 

The content of the data source changes as printing advances, according to an initial value and an increment 

value. 

Defining the properties of a Counter data source 

1. Select the type of counter. 

If you want to use a type of counter other than those displayed in the list, choose the Custom option 

and enter a customized sequence. 

2. Enter a value in the Increment box. By default, the increment is +1. 

3. Enter a start value in the Current value box. By default, the value is 0. 

4. Click OK. 

 

Demonstration: Creating the counter 

 

1. Open a label. 

2. Create a counter and name it namcd. 

3. Select it, then choose Properties in the context menu. 

4. Select Decimal as the type of counter. 

5. Enter ''1'' in the Increment box. 

6. Enter ''1'' in the Initial value box. 

7. Click OK. 

8. Select the counter then drag and drop it into the workspace. Select Text in the context menu. 

9. Right-click on it and choose Properties in the context menu. 

10. Select the following text characteristics:  

 Font: Arial,  

 Height: 3.20 mm. 

The Formula data source 

Command: Data source > Formula > Add 

The Formula data source contains a list of data sources you have created. These data sources are populated 

by combinations of operators, constants, data sources, control variables, formulas, and functions. Data can be 

numeric or alphanumeric. 
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In order to carry out a calculation within a document, you must first create a Formula data source. 

This data source has a specific dialog box allowing you to define the required function(s) for a given formula. 

Defining the properties of a Formula data source 

Command: Data source > Formula > Properties. 

1. Enter the formula directly in the Edit box. 

- or - 

Select the elements of your choice, then click Insert. 

2. Click Test to verify that the syntax is correct. If an error occurs, follow the instructions displayed on 

the screen and carry out any necessary changes. 

  

3. Click OK. 

Hint: You can insert an element by double-clicking on it. 

Note: If a variable used in the formula has a name containing one of the following characters &+-

*/<>=^%,!\", it must be enclosed in brackets {}. 

Note: You can check your formula by clicking Test. If the message displays the formula value, it means that 

your formula is correct. If the value is not correct, follow the instructions displayed on the screen to carry out 

the necessary modifications. 

If the value obtained is truncated, you must modify the maximum length specified in the Output tab. 

Demonstration: Creating a simple formula 

 

Displaying the price of a product 

 

The production label must show the price of the product as a function of its weight and the price per kilogram. 

 

1. Open a label. Two variables have to created: WEIGHT and PRICEPERKG. 

2. For the WEIGHT variable: Enter 788 (the weight of the product being 788 g) as the Local value, and enter 

''Please enter the weight in g'' in the Prefix box, then click OK. 

3. For the PRICEPERKG variable: enter 15.70 (the price/kg being FF15.70) as the Local value of the variable, 

and enter ''Please enter the price per kg'' in the Prefix box, then click OK. 

4. Add a formula and name it price. 

5. Enter the formula WEIGHT*PRICEPERKG/1000, then click OK. 

6. Save your document. 

Demonstration: Adding the "Warning" Formula variable for displaying a warning message 

 

In the following sequence, we will create a formula to display a warning message telling the user that the value 

of the Total_Weight shared variable exceeds 1,000kg. 

 

If the weight value exceeds 1,000kg, the message ''Attention! Error! Total Weight exceeds maximum!'' will 



User Guide 

34 

 

appear. 

 

1. Open the label. 

2. Create a formula and name it ''Warning''. 

3. In the Formula dialog box, enter the following expression:  

  if(Total_Weight>1000, ''Attention\n!Error!\n Total Weight exceeds maximum!'', ''''). 

4. In the Output tab, enter 50 in Maximum length and click OK. 

5. Position the variable as text within the label. 

6. In the Text dialog box, select Scalable as the font and set its Height to 12.70 mm. 

7. In the Paragraph tab, check the Wordwrap option then check Centered in Alignment. 

Information on the IF function 

Returns one value if the condition you specify is TRUE, and another value if it is FALSE. 

Use the IF function to carry out conditional tests on values and formulas. 

Syntax 

if("expr","val_if_true","val_if_false”) ”expr" represents any value or expression, the result of which can be TRUE 

or FALSE. 

val_if_true is the value returned if "expr" is TRUE. The val_if_true argument can be another formula. 

val_if_false is the value returned if "expr" is FALSE. The val_if_false argument can be another formula. 

 

 

The Form data source 

Command: Data source > Form > Add 

The Form data source contains a list of variables you have created. These data sources are populated by 

entering data directly into the Form using the keyboard. 

To display the form 

The Form lets you enter data during design or, most commonly, before printing. 

To display the form: 

1. Open a label containing a Form variable. 

2. Click the   button in the toolbar. 

By default, the workspace lets you view the label and its form separately. 

To display the label and form together: 
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1. Select the tab for your form. 

2. Drag everything to the right of your workspace. Both views are now visible.  

Any changes to the label or form will automatically update the data in the other. 

Customizing the Form  

You can customize the appearance of your form by changing the color, font, etc. in the Form customization 

dialog box. 

To access the Form customization dialog box: 

• Choose View > Form customization. 

- or -  

• Select the form with the mouse, right-click, and select Customize form. 

- or - 

• Double-click the background of the window represented in the form view. 

Modify the order in which data is entered into the form 

You can change the order in which data is entered into the form. 

Proceed as follows: 

1. Select the form using the mouse. 

2. Right-click. 

3. Select Start tab ordering. The default numbering appears. 

4. Click the number of the field you want to appear first in the form.  The number changes to green when 

validated. 

5. Repeat step 4 to continue ordering. 

6. To confirm your selection, right-click and select Validate tab ordering.  The order of the fields will be 

automatically validated when the first field is validated.  The numbering then disappears from the form. 

Note: You can also cancel any changes. Right-click the form and select Abort tab ordering. 

Defining the properties of a Form data source 

1. Click the Form tab. 

2. Enter the prompt you want to display in the form. 

3. If you wish, you can define an input format and a minimum length. 

4. You can create values that will be proposed in the Form by selecting <Local> from the Pick list. Next 

click on  to access the Pick list dialog box. 
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5. In the Output tab, you can define an output format, maximum length, suffix and prefix. 

6. Click OK. 

Note: If you define an empty local value and check the Restore after printing box, the value of the variable will 

set to empty after each print job. 

Demonstration Creating a Form data source 

 

1. Open a label. 

2. Add a Form data source and name it productname. 

3. Enter ''Cheese'' as the Local value.  

4. In the Form tab, enter ''1'' as the Minimum length. 

5. Click the Output tab and enter ''20'' as the Maximum length. 

6. Select the Form data source, then drag and drop it into the workspace.  

7. Select Text in the context menu. 

The Free data source 

Command: Data source > Free > Add 

The Free data source contains a list of data sources you have created. These data sources are populated by 

data that is not specified when they are created. A Free data source can be used to create intermediate data 

sources. 

Defining the properties of a Free data source 

1. In the Input tab, select one of the following options:Local or Shared or From a file. 

If you have chosen the Local option, enter the variable value in the box. This is the initial value of the 

variable, the one that will be printed first. 

- or - 

If you have chosen the Shared option, enter the variable value in the box. Click OK.  

- or - 

If you have chosen the From a file option, select the required file. 

2. In the Output tab, you can define an output format, maximum length, suffix and prefix. 

3. Click OK. 

Demonstration: Creating a Free data source 

 

1. Open label. 

2. Create a Free data source and name it ''ref''. 

3. Insert the data source into the label in text format. 

4. In order that this data source does not appear when printing, select it and click on  in the Object toolbar. 

Variable object creation 

The concept of fixed objects is linked to that of objects that are variable. 
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A variable object is a text, barcode, or image type object, composed of elements whose the value is not defined 

at the moment of creation. Several objects can be associated with a single variable. 

The value of these elements is supplied by different data sources at the time of printing: 

• Direct keyboard entry in the Form (Form data source) 

• Imported from an external file or database (Table lookup or Database data sources) 

• Field calculated by the computer (Formula, Counter and Date data sources) 

Note: In the Data Sources view, a red arrow  indicates the variable associated with the selected object. 

Creating a variable object linked to an existing data source 

You can quickly and simply create a variable object in your document (bar code, image, text, drawing, etc.) 

using: 

• The Create toolbar, 

- or - 

• The Object menu. 

Using the clear guidance given, you can create an object using one of the following options: 

• Direct mode creation: 

1. Click directly on the object you want to insert into your document. 

2. Click the location where you want to place the label. 

 

The Creation Wizard will run by default. If not, double-click the object to open the Properties dialog 

box. 

3. Click the Data sources tab. 

4. Select Variable. 

5. Select the variable you want to assign to your object. 

 - or - 

• Guided mode creation (according to your requirements): 

1. Click the menu button for your object. A submenu is displayed showing the actions you can take. 

2. To create a variable object using an existing data source, you have the option of: 

 - Selecting Use an existing data source followed by the variable concerned 

    - or - 

 - Selecting Wizard: This will guide you step by step through the variable object creation process. 

3. Click on the location where you want to place the label. 

Note: The creation wizard is enabled by default. To disable it, select Tools > Options > Wizards. For more 

information: Enable Wizards 
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Creating a variable object linked to a new data source 

 

You can quickly and simply create a variable object in your document (bar code, image, text, drawing, etc.) 

using: 

• The Create toolbar. 

- or - 

• The Object menu. 

Using the clear guidance given, you can create an object using one of the following options: 

• Direct mode creation: 

1. Click directly on the object you want to insert into your document. 

2. Click the location where you want to place the label. 

 

The Creation Wizard will run by default. If not, double-click the object to bring up the Properties 

dialog box. 

3. Click the Data sources tab. 

4. Select Variable. 

5. Select the variable you want to assign to your object, right-click and select Add. 

- or - 

Click New, then select the variable you want to add. 

 - or - 

• Guided mode creation (according to your requirements): 

1. Click the menu button for your object. A submenu is displayed showing the actions you can take. 

2. To create a variable object using a new variable, you have the option of: 

- Select New data source. 

- or - 

- Select Wizard: This will guide you step-by-step through the variable object creation process. 

3. Click the location where you want to place the label. 

Note: The creation wizard is enabled by default. To disable it, select Tools > Options > Wizards.  
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Printing 

A powerful print engine 

Your software is both a powerful, user-friendly creation tool and a print engine, bringing together the widest 

possible range of printers (native, thermal transfer and inkjet) which were never before available on the 

automatic identification market. 

Whether printing a single label, a series of labels, or multiple copies of the same label, all print commands are 

grouped together in one place: the Print dialog box. 

Furthermore, labeling software allows you to install and control printers located anywhere on your network. 

In this section, we will look at various possible network configurations and the associated installation 

procedures for optimized label printing.  

Printing a document 

To print a document: 

1. Choose File > Print to access the Print dialog box.  

You can also click the   button or press F6. 

2. In the Labels text box, enter the number of labels to be printed.  

3. Click OK. 

Practical Workshop 1 - Label Series and Label 

To start, let’s distinguish between Labels and Copies of each label. 

Note: If the label does not include a counter, the Print dialog box will not display the Copies of each label 

field, but only the Labels field, which in this case serves the same purpose. 

To highlight the difference between Labels and Copies of each label, we will consider a label containing two 

types of counters and configure the Print dialog box in different ways. 

• Open a label. 

Create two different counters: 

• A classical counter that counts all labels, and resets when its value reaches 10: 

• Type 

• Increment +1 

• Min value 0 

• Max value 10 

• An ISO counter that allows each label copy to be individually and exhaustively numbered. It also 

resets when its value reaches 10: 
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• Type 

• Increment +1 

• Min value 0 

The first counter, called NumLabel, identifies a particular label, whereas the ISO counter counts the total 

number of labels printed. 

Labels in the series 

In this example, we are going to print a series of 10 labels: 

1. Enter the following values in the Print dialog box: 

• Labels : 10. 

This means that there are 10 different labels in the series. 

2. Click Print. 

The printed output is as expected: 10 labels have been printed and the two counters read the same value. 

Copies of each label 

Here we will print a series of five labels, but this time we want two copies of each one. 

1. Enter the following values in the Print dialog box: 

• Labels: 5 

• Copies of each label : 2. 

2. Click Print. 

10 labels have been printed: however, the result is totally different from the one obtained in the last example. 

Copies of each page 

As we have just seen, it is possible to print multiple copies of the same label. In the next example, we will see 

that it is also possible to print multiple copies of the same page. We therefore need to know exactly what the 

printer understands as being a page. 

The page is determined by the parameters specified when the printer driver is configured. The results obtained 

may be completely different depending on whether you print on an office printer or a native printer. It can be 

quite difficult to visualize a page on continuous paper, which is used mainly by native printers. 

Moreover, according to the dimension of the print media and the size of the label, the page dimensions may 

correspond to those of the label, and thus, by extension, the page copy may be the same as the label copy. 

The page format and label size are defined in the Page setup dialog box. 

1. Open a label that contains a counter. 

2. Go to File > Select printer. 

3. Select a Windows office printer. 



Printing 

41 

4. Make sure that the paper format is A4, then click OK. 

5. Go to File > Page setup or click . 

The Page setup dialog box appears. 

The preview gives you an idea of how the page will look when it is printed. 

6. Close the dialog box. 

7. Click . 

8. Enter the following values: 

• Labels: 8 

• Copies of each page: 2 

9. Click Print. The result will be: 

 

Practical Workshop 2 - Print Merge 

Print Merge is only available if your label is linked to a database (ASCII or ODBC). 

The Merge function prints all the records contained in the database. 

To launch a print merge 

1. Choose File > Print to access the Print dialog box.  

- or - 

Click the   button.  

2. In the Labels text box, enter the number of labels to be printed.  

3. In the Records field, select All records  

4. Click OK. 

Practical Workshop 3 - Printing using the form 

It is often the case that variable data needs to be entered by an operator just prior to printing. Your application 

offers a quick and simple method of data entry: the Form. 
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Printing using the form 

1. Go to File > Print... or click or press the F6 key. 

2. Enter ''2'' in the Labels field.  

3. Launch printing. 

The form is displayed, and you are invited to enter the data to be printed. 

4. Enter ''Smith'' and ''51'', for example, then click OK. 

Once the first label is printed, the form is displayed again. 

5. Enter ''Mullang'' and ''52'', for example, then click OK. 

Note: The Form is displayed for each label contained in the series. If you choose the For each series option, 

the Form will only be displayed once, when printing of the label series is launched. 

To sum up... 

The Print dialog box contains 

differences... 

When the label contains a counter: Labels allows you to specify the number 

of different labels in a series; 

Copies of each label allows you to determine the number of copies of the 

same label to be printed. 

When the label does not include a counter, this option serves the same 

purpose as the Labels field. 

Copies of each page A page copy can only be carried out if the label does not include an ISO 

counter and if the page contains more than one label. 

Print Merge This option prints all the records in a database, and is only available when 

the label is connected to a database. 

Printing using the Form The Form allows an operator to enter data by keyboard just prior to 

printing. 

Optimizing printing 

An increasing number of printers come equipped with a parallel, USB or TCPIP port, and we would recommend 

using this rather than the serial port. If you want to print bitmap images, graphics, or Windows TrueType fonts, 

using the parallel port will greatly enhance your system’s performance in terms of data transfer capacity. 

Moreover, there is only one type of cable for all parallel links, whereas there is no standard for serial cables. 

You thus avoid any problems with printer cable requirements. 

That said, given that many printers are still supplied with a serial link only, this section also covers most of the 

problems you are likely to encounter with serial communications, and explains how to configure Windows for 

trouble-free printer communications. 

Furthermore, it is important to bear in mind that Windows printer drivers and the program you use for printing 

do not control serial communications between your computer and the printer. The communication mode is 

controlled by: 

• Your printer’s settings 
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• The type of serial cable used 

• The serial communication settings used in the Windows control panel. 

Optimizing printing speed 

As we have already seen in the introduction, there is no universal configuration for optimizing printing speed, 

but rather a range of different settings that come into play. In the next example we will look at each of these in 

turn, hopefully giving you a better understanding of your own configuration, and thus enabling you to find the 

best settings for optimized printing. 

For improving printing speed, there are four basic principles we need to bear in mind: 

• Use the parallel port wherever possible. 

• Use printer objects (fonts, barcodes, and so on) wherever possible. 

• In the case of a serial link, and if the printer offers the option, make use of the Windows Font 

Downloader. This plug-in tool allows you to download any Windows font into the printer’s memory 

quickly and easily thus turning it into a printer resource. For more information on this plug-in 

(provided with your application), refer to the documentation available on the application CD-ROM. 

• Use the Send modified data only command, which is available for the vast majority of printers and 

available in the Printer settings dialog box. 

The Direct access option is offered when configuring the printer driver and selecting the port. The table below 

lists when this option may be used: 

Port Direct access Non-direct access 

Serial Yes Yes 

Parallel Yes Yes 

Network No Yes 

Using this option will depend on your particular requirements : 

• In direct access, the printer driver communicates directly with the printer. The user has no control 

over events until printing is completed (possibly involving something of a delay). 

• Without the direct access option, the printer driver transfers data to a print queue, which manages 

communication. The user regains control once all data has been transferred to the print manager 

(involving much less of a delay). 

Parallel link and serial communication 

Given the many advantages of using images, such as the wide variety of Windows graphics, you will get 

significantly better results by using a printer equipped with a parallel communications port. The majority of 

standard native printers are equipped with a serial link only (RS 232), with the parallel port as an optional 

feature. 

Serial communication works fine, as long as you are only intending to print printer objects (barcodes, fonts, and 

so on). If you wish to print bitmap images, printing speed will be greatly reduced. 
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Note: For printing images, use the parallel link wherever possible. 

 

For printing images 

For example, your company logo, not a printer object, must be transferred to the printer. The more images you 

send to the printer, the slower printing becomes, especially if you are using a serial connection. The solution is 

to send the image in question just once, when printing of the label series is first launched. 

The majority of printers allow this operation. 

When you use the Send modified data only option, the image is sent to the printer only once when printing 

starts, which can take a little time. However, once the first label is printed, the data transfer process runs much 

faster, improving performance for printing a number of label series. 

Note: The label background is stored in the printer’s memory. As a result, the fixed image does not need to be 

transferred via the cable once the first label is printed. 

Substituting TrueType fonts 

The TrueType font substitution will be used at the time of printing to dynamically change a TrueType font to a 

printer font. The purpose of this feature is to allow the user to design a single label that can be printed on 

different kinds of printers. Using the TrueType font substitution option, the same TrueType font at design time 

will be redefined with the best possible printer font at the time of printing to optimize the print speed. 

Troubleshooting 

The table below lists the problems most frequently encountered during printing, and offers some solutions to 

help you resolve them. 

Problem Cause Solution 

Nothing is printed The printer is not plugged in. Plug the printer in. 

 For a parallel link: 

- The printer is not configured for a 

parallel link. 

Make sure that this setting has been configured 

in the printer control panel (refer to the 

manufacturer’s handbook). 

 For a serial link: The serial 

communication settings are 

incorrect. 

Make sure that the communication settings 

between the PC and the printer are the same 

(for the serial communication settings required 

by the printer, refer to the manufacturer’s 

handbook). 

 The serial cable is not suitable. Make sure that the cable matches the 

specifications of your printer (refer to the 

manufacturer’s handbook). 

 In both cases (serial or parallel): 

- The cable is connected to the 

wrong port. 

Check the connection. 
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 In both cases (serial or parallel): 

- The cable is connected to the 

wrong port. 

Check the connection. 

   

A page is not printed For direct thermal printing: the 

print media has been inserted the 

wrong way (the print head is 

heating the wrong side of the 

paper). 

Reinsert the media the right way. 

 For thermal transfer printing: The 

ribbon has not been inserted, or 

was inserted incorrectly. 

Check the ribbon and refit if necessary (refer to 

the manufacturer’s handbook). 

 The required print mode has not 

been selected on the printer. 

Check that the print mode (native or thermal 

transfer) has been correctly selected on the 

printer (refer to the manufacturer’s handbook) 

or in the Printer setup dialog box. 

A graphic object 

(image, Windows 

font, graphic barcode, 

etc.) has not been 

printed. 

The printer is out of memory. Check the Clear memory at next print time 

only option; If the problem persists, check the 

amount of memory space allocated to images 

(on the Images tab of your printer driver). 

 The printer does not have enough 

memory. 

Increase the amount of printer memory either 

by adding an extra memory card, or by 

increasing the RAM (refer to the manufacturer’s 

manual or check with the dealer from which you 

purchased the printer). 

 Some printers will not recognize an 

object if it overlaps the edge of the 

printable area, even by only a few 

millimeters. 

Adjust the position of the object on the label. 

The thermal printer is 

jammed 

The print media used is not the 

same as the one defined in the 

Page setup dialog box (continuous 

paper or with gap). 

Check that the right print media was selected 

during page setup: Continuous, With gap. 
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