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1.0 What is Industrial Ethernet? 

Industrial Ethernet is a communication protocol for real-time control using Ethernet in 
an industrial environment. This function enables cyclic communication with PLCs 
(programmable logic controllers) compliant with the following standards to control the 
reader's operation: 

- EtherNet/IP * 

*EtherNet/IP is a registered trademark of ODVA (Open DeviceNet Vendor Association Inc). 

2.0 Supported Models 

The following are the supported models: 
Fixed Barcode Readers: 
- V6180 – Firmware v1.6b 
- V7000 – Firmware v1.4b 

3.0 Supported PLC 

Rockwell Automation 

 

 

 

* ControlLogix Series is a registered trademark of Rockwell Automation. 
 

Series Connection type Models Note 

ControlLogix series * Controller 
ControlLogix series  

CompactLogix series  

PLC Switching HUB 
Code 

Reader 

Other 
equipment 
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4.0 Industrial Ethernet Configuration 

An example configuration for communication via Industrial Ethernet is shown below. 

4.1 Important Considerations for Configuration 

4.1.1 Communication Range 

• Devices must be within the same network address on the Ethernet. 
• The range beyond the router cannot be accessed. 

4.2 Switching Hub Requirements 

4.2.1 Hub specifications:  

▪ Compliant with the IEEE 802.3 (100BASE-TX) standard 
▪ Supports auto-negotiation 
▪ Includes Auto MDI/MDI-X functionality 
▪ Must be a Layer 2 switch (repeater hubs are not supported) 

5.0 Set up a V7000 or a V6180 scanner. 

Follow the quick start guides and user manuals to connect the scanner to a PC 
and configure its camera settings.  

6.0 Set up communication settings. 

6.1 PLC and PC Requirements: 

1. Have the V7000/V6180 IP address ready, if the IP address is unknown, use the 
default IP address: 192.168.209.10 
 

NOTE: If the default IP address does not work and no IP address is known, then 
follow instructions to reset the scanner to defaults using Teach button (section 7.0) 
 

2.  Set PC Ethernet adapter (IPv4) to 192.168.209.xxx – where ““xxx" is an 
arbitrary number between 1 and 255.” 
• Navigate to settings → Network & Internet → Ethernet. 
• Click Edit under IP assignment section. 
• Select Manual set up from the drop-down menu. 
• If required, select the IPv4 option, or turn it On by using the switch.  
• Add the IP address, subnet mask, Gateway, and Preferred DNS 
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6.2 V7000 FixedConfig connection  

FixedConfig – v1.3.2   can be downloaded here: Brady_ID.com/V7000 
 
1. Open FixedConfig7000 application, by default a device will be registered, 
double-click the registered device to open its settings. If no registered device is 
listed, then click the Register button on the top menu. The connection settings 
dialog box will appear. 

 

 

 

 

2. “Registered Name” and “Model Name” are set to V7000 by default, use 
existing names or set new names when registering if desired. 

3. Click on the LAN tab to set the IP address. If the IP address is unknown, click 
Search to scan for available devices. 
1. The available V7000 IP addresses will be displayed. Select the correct 

device. If that does not work, then use the default V7000 IP address 
(192.168.209.10) or use the reset V7000 to defaults in section 7.0. 

 
 
 
 

 

4. When the search is complete and the IP address and port number are found, 
click "OK” or double click on the correct V7000 

Settings Example Value 
IP Address 192.168.209.100 
Subnet Mask 255.255.255.0 
Default Gateway 192.168.209.1 
DNS Server 192.168.209.1 

http://www.brady_id.com/V7000
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5. Click Register. 
6. Before connecting, unplug the network cable and restart the V7000.    Wait 

for the boot process to be complete, then reconnect the network cable 
7. Click “Connect,” and if all settings are correct, the FixedConfig7000 will start 

right away. If it does not start right away, please click “Cancel” on the prompt, 
go back to step 3, and fix the IP address. 

 

 

 

 

 

 

6.2.1 Enable Ethernet/IP Communication  

Turn on Ethernet/IP protocol. 

NOTE: There are two ways to accomplish this using FixedConfig7000 App (1. 
Switch, 2. Terminal). 
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6.2.1.1 Using FixedConfig7000 switch 
1. Navigate to Operation Settings → Others. 
2. Turn ON the Ethernet/IP setting by toggling this switch. 

 

 

 

 

 

 

 

 

 

3. Click Write Settings and Save Settings. 
4. Reboot the V7000 to apply changes. 

6.2.1.2 Using Terminal window 
1. Open the terminal window and send command: IEMODE=1 

 

 

2. Verify if Ethernet/IP has been enabled by sending this command: ?IE 

 

 

 

 

 

NOTE: For additional terminal commands, refer to Appendix A. 
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6.2.2 Setup Ethernet Settings (Optional to change default values) 

6.2.2.1 LAN settings 

• Open FixedConfig7000. 
• Click on Reader Setting. 
• Navigate to Operation Settings → LAN. 
• Set up all Ethernet Settings 
• Click Write Settings to apply changes. 
• Save settings to V7000 

 
 
 
 

• Reboot V7000 – new settings will take effect after reboot 
 

 
 
  

 

 

 

 

 

 

Note: If the V7000 does not apply changes, verify the IP settings, and check network 
connectivity. 
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6.3 V6180 FixedConfig Connection  

FixedConfig – v2.1.13 can be downloaded here: Brady_ID.com/V6180 
 

1. Open FixedConfig6180 application, by default a device will be registered, 
double-click the registered device to open its settings. If no registered device 
is listed, then click the Register button on the top menu. The connection 
settings dialog box will appear. 

 

 

 

 

 

 

2. “Registered Name” and “Model Name” are set to V6180 by default, use 
existing names or set new names when registering if desired. 

3. Click on the LAN tab to set the IP address. If the IP address is unknown, click 
Search to scan for available devices. 

4. The available V6180 IP addresses will be displayed. Select the correct device. 
If that does not work, then use the default V6180 IP address (192.168.209.10) 
or use the reset to defaults in section 7.0. 
 
 
 

 

 

 

  

http://www.brady_id.com/V6180
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5. When the search is complete and the IP address and port number are found, 
click "OK” or double click on the correct V6180 

 

 

 

 

 

6. Click Setting, the V6180 will auto connect if not move to 7. 
7. Click “Connect,” and if all settings are correct, the FixedConfig6180 will start 

right away. If it does not start right away, please click “No” on the prompt, go 
back to step number 3, and fix the IP address. 
 
 

 

 

 

6.3.1 Enable Ethernet/IP Communication  

Turn on Ethernet/IP protocol. 

NOTE: There are two ways to accomplish this using FixedConfig6180 App (1. 
Radion button, 2. Terminal). 

6.3.1.1 Using FixedConfig6180 radio button 

1. Navigate to View → common View→ Ethernet/IP (or click the wrench 
icon) 



11 
 

2. Turn ON the Ethernet/IP protocol by selecting the “START” radio button 

 

 

 

 

 

 

 

 

 

3. Click Write Settings and Save Settings. 
4. Reboot the V6180 to apply changes. 

 

6.3.1.2 Using Terminal window 

1. Open the terminal window and send command: IEMODE=1 

 

2. Verify that Ethernet/IP has been enabled by sending this command: ?IE 
 
 
 

 

 

             NOTE: For additional terminal commands, refer to Appendix A. 
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6.3.2 Setup Ethernet Settings (Optional to change default values) 

6.3.2.1 LAN settings 

• Open FixedConfig6180 
• Navigate to View → Common View → LAN 
• Set up all Ethernet Settings 
• Click Write Settings to apply changes. 
• Save settings to V6180 

 

 

 

• Reboot V6180 – new settings will take effect after reboot 

 

 

 

 

 

 

 

 

 

 

7.0 Reset the IP address to defaults (Optional) 

1. Turn off V7000/V6180 by removing the power. 
2. Hold down the TEACH key (button) and turn On the V7000/V6180 without 

releasing the TEACH key. 
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3. The V7000/V6180 will begin its boot up process, release the TEACH key when 
the status LED-READY lights up. 

4. The IP address will be temporarily set to the default IP address: 192.168.209.10, 
but the Ethernet saved settings will not be overwritten. Connect to the 
V7000/V6180, and reset the Ethernet settings, then write the settings, and save 
the settings. 

NOTE: After rebooting, the V7000/V6180 will reload its saved Ethernet 
settings, not the temporary default settings. 
 
Default values: IP address: 192.168.209.10 
                                 Subnet mask: /24 or 255.255.255.0 
             Server Port number: 27110 
             Default gateway: 192.168.209.254 

 

8.0 PLC Rockwell connection Setup 

This section describes the configuration procedure using "Logix Designer", a 
 configuration tool for Rockwell Automation PLCs. 

8.1 EtherNet/IP 

 An EDS file is required when connecting to a code reader. 

8.1.1 Setting the IP address 

1. Open "Logix Designer". 
2. Navigate to Communications → Who Active. 
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3. Factory Talk Linx → Backplane, then select the PLC model name and click 

“Go Online.” 
4. If the PLC does not appear, connect using a USB cable to manually set the 

IP address. Go to step 7. for more information, then Go Online under 
Factory Talk Linx refer to step 2. 

 

 

 
 
 
 
 
 
 
 
 
 
 

5. When the following screen appears, click “Download.” 
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6. Click on “Download.” 

 

 

 

 

 

 

 

 

 

 

 

7. In the "Controller Organizer", select "I/O Configuration" → Right click on 
"Ethernet" → Click “Properties.” (If setting up IP using USB cable select: 
“USB” → Click “Properties” 

 

 

 

 

 

 

• Click on “Internet Protocol.” 
• Select on “Manually configure IP settings.” 
• Check “IP Address and Subnet Mask” 
• Make sure the settings on the IP addresses of the PLC and Barcode 

reader match up to the third octet, if not, make any changes. 
o NOTE: In the case of the following screen, set the IP address to 

"192.168.209.xxx" for both Barcode reader and PLC. “xxx" is 
an arbitrary number between 1 and 255. 
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• After changing the settings, click “OK.” 
 

 

 

 

 

 

 

 

 

8.2 Registration of EDS File 

NOTE: Brady_V6180.eds for V6180 --  Brady_V7000.eds for V7000 
1. Click on “Tools” →Device Description Installation Tool. 

 

 

 

 

 

 

2. When the "Device Description File Installation Tool" wizard opens, click 
“Next.” 
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3. Select “Register a device description file(s)” and click “Next.” 

 

 

 

 

 

 

 

 

4. Select “Register a single device description file” and click “Browse….” 

 

 

 

 

 

 

 

 

 

5. Select the EDS file and click “Open.” 
6. Click Next through the following prompts until you reach the Finish 

button. 
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8.3 Setup Module 

1. In the "Controller Organizer", select "I/O Configuration" → Right click on 
"Ethernet" → Click “New Module.” 

 

 

 

 

 

 

 

2. In the Catalog tab, use the Search field and type "V7000" for V7000 barcode 
reader and “V6180 for V6180 barcode reader to find the module. 

3. Select the appropriate code reader model and click Create. 

 

 

 

 

 

 

 

 

 

4. When the “New Module” appears, enter the IP address of the reader in the IP 
Address field under Ethernet Address. (default: 192.168.209.10) 

5. Add Name (e.g., V7000 or V6180) 
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6. Click on “OK.” 

 

 

 

 

 

 

 

 

7. Click on “Yes.” 
8. Registered code readers are displayed with a warning icon. 

 

   

 

 

 

NOTE: If an electric keying mismatch error appears, follow the instructions in 
section 10.0. 
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8.4 Transmission of settings 
NOTE: Complete the connection download transmission settings. 

1. Click on Communications → “Go Offline.” 
2. Click on Communications → “Download.” 
3. Click on “Download.” 

NOTE: When connection with the reader is established after the settings are 
applied, the warning icon will disappear. 
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9.0 Testing PLC communication  

9.1 Control tags 

NOTE: The following steps apply to V7000 and V6180.  
 
1. V7000/V6180 Input and V7000/V6180 Output tags will be displayed. 

 

 

2. Expand V7000:O > V7000:O.Data > V7000:O.Data[0] 
3. Set V7000:O.Data[0].6 to 1 → Permit transmission read data.  
4. Set V7000:O.Data[0].7 to 1 → Clear “Data transmission complete.” 
5. Trigger the scanner by setting V7000:O.Data[0].1 to 1 (single decode) 

Request start reading. 

 

 

 

 

 

 

 

 

 

6. Stop transmission by setting V7000:O.Data[0].1 to 0 and Set 
V7000:O.Data[0].4 to 1. 

7. To request a read again set V7000:O.Data[0].4 to 0, then V7000:O.Data[0].1 
to 1. If V7000:O.Data[0].4 is still 1 then the scanner will start continuous 
scanning without decoding. 
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9.2 V7000/V6180 reading results.  

NOTE: The following steps apply to V7000 and V6180. 
1. Expand V7000:I > V7000:I.Data 
2. Data results will be displayed after V7000:I.Data[10]   
3. Refer to Appendix B for more register information. 
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10.0 Electronic Keying Mismatch 

10.1 Electronic Keying 

1. Keying is a feature designed to minimize the risk of using an incorrect device in 
a control system. An incorrect device can be: 

• A replacement device for one that is already in use.  
• A device that is installed during the initial system installation. The 

wrong device does not support the same functionality as the device 
intended for use in the system. When the wrong device is used, 
unexpected system behavior can occur. 

2. Electronic Keying automatically compares the expected device, as defined in 
your RSLogix 5000™ or Logix Designer project, to the installed device. If keying 
fails, the controller does not establish a connection to the device and a fault 
occurs on the device. 

3. For each device in the project, the user-selected keying option determines if, 
and how, an Electronic Keying check is performed. Three options are available:  

 
 • Compatible Module  
 • Disable Keying  
 • Exact Match  

Click this link for more details:  
https://literature.rockwellautomation.com/idc/groups/literature/documents/
at/logix-at001_-en-p.pdf 
 

4. Carefully consider the benefits and implications of each keying option when 
selecting between them. For some device types, fewer options are available. 
 

10.2 Disable Keying – (use only for testing) 

1. Edit the created module and click under “Edit module definition.” 
2. Set electronic Keying to Disable. 
3. Click “Ok” 
4. Then try to go Online with the registered device V7000 
5. Communication → Go Online 

 
 
 
 

https://literature.rockwellautomation.com/idc/groups/literature/documents/at/logix-at001_-en-p.pdf
https://literature.rockwellautomation.com/idc/groups/literature/documents/at/logix-at001_-en-p.pdf
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Appendix A: Terminal Commands 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Appendix B: Registers Input/output 

 

Result Data (Input Assemblies) 

Address Bit Name Description 

0 0 Read success 
0→1: Code reader successfully reads barcode.  
1→0: - 

 

1 Read failed 
0→1: Code reader failed to read barcode.  
1→0: - 

 

2 
Data transmission 
complete 

0→1: Code reader transmitted read data. 
1→0 : - 
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3 
FTP communication 
complete 

0→1: Code reader has completed FTP 
communication. 
1→0 : - 

 

4 
Setup operation 
success 

0→1: Code reader succeeded in Setup operation.  
1→0: - 

 

5 
Setup operation 
failed 

0→1: Code reader failed in Setup operation.  
1→0: - 

 

6 

Automatic 
adjustment 

success 

0→1: Code reader succeeded in Automatic 
adjustment.  
1→0: - 

 

7 

Automatic 
adjustment 

failed 

0→1: Code reader failed in Automatic adjustment.  
1→0: - 

 

8 READY 

 
0→1: Code reader is in READY state. 
(Readings, setup, and auto-adjustment are ready 
to run) 
1→0: Code reader is in BUSY state. 
(Reading, setup, or auto-adjustment is in 
progress)   

 

9 BUSY(Reading) 
0→1: Code reader is in BUSY state. (Reading) 
1→0: Code reader is not in BUSY state. (Reading) 

 

10 
BUSY 

(Data transmission) 

0→1: Code reader is in BUSY state. (Transmitted 
read data) 
1→0: Code reader is not in BUSY state. 
(Transmitted read data) 

 

11 

BUSY 

(FTP 
communication) 

0→1: Code reader is in BUSY state. (FTP 
communication) 
1→0: Code reader is not in BUSY state. (FTP 
communication) 

 

12 
BUSY 

(Setup operation) 
0→1: Code reader is in BUSY state. (Setup 
operation) 
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1→0: Code reader is not in BUSY state. (Setup 
operation) 

 

13 

BUSY 

(Automatic 
adjustment) 

0→1: Code reader is in BUSY state. (Automatic 
adjustment) 
1→0: Code reader is not in BUSY state. (Automatic 
adjustment) 

 
14 Reserved - 

 
15 Reserved - 

1 0to15 Data length Length of read data 

2 0to15 
Read data 
Transmission 
number 

Number of the data currently being transmitted. If 
it does not split, it is fixed at 1. 

3 0to15 
Read data. 

number of divisions 

Number of divisions of read data. If it does not 
split, it is fixed at 1. 

4 0to15 Symbol grade 
Overall grade of ISO/IEC 15415 or ISO/IEC TR 
29158. (0 to 4) If Symbol grade is disabled, fixed at 
255. 

5to128 0to15 Read data Read data (max. 248 bytes) 

 
 

Control Data (Output Assembly) 

Address Bit Name Description 

0 0 Request Start Reading 
0→1: Code reader starts reading. 
1→0 : - 

 

1 Request Setup Load 
0→1: Code reader starts loading setup. Target is 
specified by the “Setting number.” 
1→0: - 

 

2 Request Setup Save 
0→1: Code reader starts saving setup. Target is 
specified by the “Setting number.” 
1→0: - 
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3 
Request  

Automatic adjustment 

0→1: Code reader starts automatic adjustment. 
    Table number where the adjustment 
results are saved is specified by "Setting 
number". 
1→0: - 

 

4 Clear “Read success” 
0→1: Set "Read success" to 0. 
1→0 : - 

 

5 Clear “Read failed” 
0→1: Set "Read failed" to 0. 
1→0 : - 

 

6 
Permit transmission 
read data 

0→1: Permit code reader to transmission read 
data. 
1→0 : Do not permit code reader to 
transmission read data. 

 

7 
Clear “Data 
transmission 
complete” 

0→1: Set "Data transmission complete" to 0. 
1→0 : - 

 

8 

Clear  

“Setup operation 
success” 

0→1: Set "Setup operation success" to 0. 
1→0 : - 

 

9 

Clear  

“Setup operation 
failed” 

0→1: Set "Setup operation failed" to 0. 
1→0 : - 

 

10 
Clear “Automatic 
Adjustment success” 

0→1: Set "Automatic adjustment success" to 0. 
1→0 : - 

 

11 
Clear “Automatic 
Adjustment failed” 

0→1: Set "Automatic adjustment failed" to 0. 
1→0 : - 

 

12 
Clear “FTP 
communication 
complete” 

0→1: Set "FTP communication complete" to 0. 
1→0 : - 

 
13 Reserved - 

 
14 Reserved - 



28 
 

 
15 Reserved - 

1 0to15 Setting number 

Used for “Setup operation” or “Automatic 
adjustment.” 

Setup operation: 

Number of the setup to be load or save. (1to20) 
Automatic adjustment:  

Table number where the adjustment results are 
saved. (1to16) 
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