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Software Copyright Information
YOU SHOULD CAREFULLY READ THE FOLLOWING TERMS AND CONDITIONS 
OF THIS LICENSE AGREEMENT BEFORE OPENING THIS PACKAGE. IF YOU DO 
NOT AGREE WITH THESE TERMS AND CONDITIONS, PLEASE PROMPTLY 
RETURN THIS PACKAGE FOR A FULL REFUND.

LICENSE AGREEMENT

Brady Worldwide, Inc. (hereafter "Brady") hereby grants you a non-exclusive, 
nontransferable license to use this software and the accompanying documentation 
according to the following terms:

1. LICENSE GRANT: You may 1) install the software on only one computer at a time, 
and 2) make one (1) copy of the software in machine readable form solely for 
backup purposes.

2. LICENSE RESTRICTIONS: You may not: 1) transmit the software over a network 
without an additional license; 2) modify, adapt, translate, reverse engineer, 
decompile, disassemble, create derivative works based on, or copy (except for 
the backup copy) this software or the accompanying documentation; 3) rent, 
transfer or grant any rights in the software or accompanying documentation 
without the prior, express written consent of Brady; or 4) remove any proprietary 
notices, labels, or marks on the software and accompanying documentation.

3. NATURE OF THIS AGREEMENT: This license is not a sale.   License fees paid 
by you, if any, are in consideration of the licenses granted under this Agreement. 
Title and copyrights to the software, accompanying documentation, and any copy 
made by you, remain the property of Brady or its suppliers. Unauthorized copying 
of the software or the accompanying documentation, or failure to comply with the 
above restrictions, shall automatically terminate this license, without further 
notice, and terminate your rights to use the software, and Brady shall, in addition 
to its other legal remedies, be entitled to its reasonable attorney fees.

4. LIMITED WARRANTY: Brady warrants that, for a period of ninety (90) days from 
the date of delivery to you as evidenced by a copy of your receipt, the software, as 
furnished, under normal use, will perform without significant errors that make it 
unusable. Brady's entire liability and your exclusive remedy under this warranty 
(which is subject to you returning the software to Brady) will be, at the option of 
Brady, to attempt to correct or help you around errors, to replace the software with 
functionally equivalent software or diskettes, or to refund the license fee of the 
software and terminate this Agreement.

EXCEPT FOR THE ABOVE EXPRESS LIMITED WARRANTY, BRADY MAKES 
AND YOU RECEIVE NO WARRANTIES, EXPRESS, IMPLIED, STATUTORY OR 
IN ANY COMMUNICATION WITH YOU, AND BRADY SPECIFICALLY 
DISCLAIMS ANY IMPLIED WARRANTY OF MERCHANTABILITY OR FITNESS 
FOR A PARTICULAR PURPOSE. BRADY DOES NOT WARRANT THAT THE 
OPERATION OF THE PROGRAM WILL BE UNINTERRUPTED OR ERROR 
FREE.

Some states do not allow the exclusion of implied warranties so the above 
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exclusions may not apply to you. This warranty gives you specific legal rights. You 
may also have other rights which vary from state to state.

5. LIMITATION OF LIABILITY: IN NO EVENT WILL BRADY BE LIABLE FOR ANY 
DAMAGES, INCLUDING LOSS OF DATA, WHEN LOADING THIS SOFTWARE 
OR OTHERWISE, OR LOST PROFITS, COST OF COVER OR OTHER 
SPECIAL, INCIDENTAL, CONSEQUENTIAL OR INDIRECT DAMAGES 
ARISING FROM THE USE OF THE PROGRAM OR ACCOMPANYING 
DOCUMENTATION, HOWEVER CAUSED AND ON ANY THEORY OF 
LIABILITY. THIS LIMITATION WILL APPLY EVEN IF BRADY HAS BEEN 
ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. 

Some states do not allow the limitation or exclusion of liability for incidental, or 
consequential damages, so the above limitation may not apply to you.

6. GENERAL: This Agreement shall be governed by, and interpreted under, the laws 
of the State of Wisconsin, USA.   You acknowledge that U.S. law and regulations 
may restrict the export/re-export of the software. You agree not to export/re-export 
the software or portions thereof in any form without the appropriate U.S. and 
foreign government licenses. This obligation shall survive and continue after this 
Agreement terminates. This Agreement is the entire agreement between the 
parties and supersedes any other communications or advertising with respect to 
the software and accompanying documentation. If any provision of this 
Agreement is held invalid, the remainder of this Agreement shall continue in full 
force and effect.
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Technical Support

Technical Support Numbers/On-line Help
For repair or technical assistance, find your regional Brady Tech Support office by 
going to:

• In the Americas: www.bradyid.com

• In Europe: www.bradyeurope.com

• In Asia: www.bradycorp.com

www.bradyid.com
www.bradyeurope.com
www.bradycorp.com
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1 Introduction
LabelMark™ software is a label design and management package which enables you 
to design a label based on material selection. It is designed to be used in an industrial 
environment with more demands on speed, accuracy and reliability of output. 

LabelMark software is a multi-document application where you can open multiple 
label files. The number of files that can be opened at any one time is constrained by 
system memory and resources. 

Starting the Software
To start the software select Start > All Programs > Brady > LabelMark 6 > 
LabelMark.

For information about creating new labels or opening existing label files see: 

• Creating Labels on page 11

• Opening an Existing Label File on page 27
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Navigating the Software

Home Screen
Upon launch of LabelMark 6.0, the following screen displays. The first time you start 
the program, the blue panel on the left is blank except for any Brady smart printers 
that you have installed. A guided tour of the Home page runs the first time you start 
the program. To run the tour again, click the question mark in the upper right and 
select Show home page tour. 

From this screen you can start a new label file, or open or manage existing files. A 
label file can be one label or multiple labels saved together as one file. All labels in a 
file are associated with the same part (label stock).

The Home page displays the following items:

• The most recently used files or templates.

• The most recently used label parts.

• Brady smart printers that you have installed (IP and Touchcell printers, BMP71, 
BMP 51/53, BMP41, and BBP33 printers).

• Access to settings and help in the upper right. See Setting Options on page 9 and 
Help on page 10. 

To return to the Home page at any time, click the Home icon. 
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Main Window

Window Element Description

Document tabs Access open pages such as Options or label files. 
Files that have unsaved changes are marked with an 
asterisk (*). When more than one tab is open, the 
current tab (the one being worked on) is indicated by 
a blue bar across the top of the tab.

Menu Menus provide functions or commands available in 
the LabelMark program. The menu bar is only 
available on label file tabs.

Toolbar Collection of menu shortcuts displayed on buttons. 
The toolbar contains standard Windows® commands 
and commands specific to the LabelMark software. 
Buttons are available or unavailable depending on 
your current activity. 
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Toolbars
The label editing tab contains three toolbars:

• Standard

Properties panels Located on the left side of the workspace window, 
the properties panels contain format, style, and file 
settings for the label object on which you are 
working. The specific properties panels only display 
when you are working on labels or templates.

Status bar Located at the bottom of the workspace window, the 
status bar displays relevant information about the 
label and media on which you are working. The 
status bar contains the selected label part number 
and total number of labels in the current file as well 
as paging and zoom controls.

Display or hide 
properties panels

The properties panels can be displayed or hidden by 
clicking the arrow on the left side of the workspace 
pane. (The arrow changes direction depending on 
whether the properties panels are currently 
displayed or hidden.)

Errors & Information bar LabelMark automatically checks for formatting errors 
on label design, enabling you to edit the design 
before printing. These errors are displayed in the 
Errors & Information window, at the bottom of the 
workspace.

Zoom control Available for editing labels, templates, or custom 
parts, the Zoom feature enables you to zoom in or 
out on a label document by dragging the button left 
or right. The zoom percentages range from 25% to 
800%.

Workspace The main area of the screen that displays the label 
file on which you are working as well as other 
LabelMark functionality, such as managing custom 
parts, schemes, and favorites.

Label A label open for editing.

Window Element Description
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• Action

• Format

The buttons on the toolbar are context sensitive, meaning their availability depends 
on what you are doing in the program. 

Standard

The Standard toolbar consists of the following items:

Action

With the exception of the Selection tool, all other tools on the Action toolbar are only 
available when in Graphical Label Design mode.

Format
The Format toolbar consists of the following items:

Saves label files, templates, or 
jobs.

Sends a label file or template 
to the printer.

Previews a label file or 
template before it is printed.

Undo - Returns the label/
document to the state before 
the last action was taken.

Redo - Returns the label/
document to the state before 
the Undo action was taken.

Permanently removes objects 
from a label, or a label from a 
label file.

Selects objects on a label, 
placing handles around the 
object to indicate it is selected.

Used to enter text on a label.
The Text tool remains selected 
until some other action tool is 
selected.

Used to insert a graphic on a 
label.

Used to insert a barcode on a 
label.

Used to draw a horizontal, 
vertical, or diagonal line on the 
label.

Used to draw a square or 
rectangle on the label.

Used to view the first side, second side, or both sides of a 2-
sided label. Available only when using 2-sided labels.



Introduction
Navigating the Software

6

LabelMark 6.0 User’s Manual

Shortcut Keys
The following table lists shortcut keys available in LabelMark software. Some are key 
combinations. For example, Ctrl + C means press the c key while holding down the 
Ctrl (control) key. 

Duplicates data from one side of a 2-sided label to the other 
side.

Centers objects vertically or horizontally between the label 
boundaries.

Used to horizontally align objects on a label with each other (left, 
center, right). Only available when more than one object is 
selected.

Used to vertically align objects on a label with each other (top, 
middle, bottom). Only available when more than one object is 
selected.

Bring to front and Send to back rearrange overlapping objects 
to enable visibility of all layers.

Used to rotate objects on a label, left or right, 90 degrees at a 
time.

Function Key Description

First Home • Moves to the first label file tab when multiple 
files are open.

• When editing a text object, moves to the 
beginning of the line of text.

Last End • Moves to the last label file tab when multiple 
files are open.

• When editing a text object, moves to the end of 
the line of text.

Delete Delete Removes selected label objects from a label; label 
files from storage; or selected jobs from job files.

Go To Ctrl + G Invokes the GO TO Label dialog box, to go to a 
specific label.

Copy Ctrl + C Copies selected objects or labels and places the 
duplicates on the clipboard.
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Cut Ctrl + X Removes selected objects or labels from the Editor 
and places them on the clipboard. This action 
supports undo and redo.

Paste Ctrl + V Pastes the contents from the clipboard onto a 
selected label. This action supports undo and redo.

Undo Ctrl + Z Undo the last action. Puts the object or label back to 
the state it was in before the last action was taken.

Redo Ctrl + Y Redo the previous action that was “undone.” Puts the 
object or label back to the state it was in before Undo 
was enacted.

Find Ctrl + F Find text within a label file.

Replace Ctrl + H Replace text within a label file.

Command 
Multiplier

Ctrl + M Invokes the Command Multiplier dialog box. Copies 
objects or the contents of entire labels and pastes the 
items multiple times, according to your specifications. 
(See Linked Objects on page 77 for more 
information.)

Save Ctrl + S Saves a label file, template, or job file.

Print Ctrl + P Sends data to the printer identified with the label or 
job.

Print 
Preview

Ctrl + F2 Displays a label file as it will appear when printed.

Nudge Ctrl + up, 
down, 
left, or 
right 

arrow. 

Moves the selected object up, down, left, or right one 
pixel (very small distance). 

Function Key Description
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Mouse Navigation

Copy Label 
Objects

F12 Copies all objects on a label and pastes them on the 
next label. You do not have to select any object. They 
will all copy.

Errors and 
Information

F7 Maximizes and minimizes the Errors and Information 
pane, which checks whether everything on the label is 
within bounds. 

Function Key Description

Function Button 
Action Description

Select Left Click Selects a label object or the label itself. 

Context Menu Right Click Displays the applicable context menu for the 
selected object or label.

Extended 
Multi-Select 
Items

Ctrl + Left 
Click

Used to select one or more non-contiguous 
objects or labels. (Non-contiguous refers to 
objects or labels that are not next to each other.)

Multi-Select 
Contiguous 
Items

Shift + Left 
Click

Used to select a range of contiguous labels. 
(Contiguous refers to labels next to each other.) 
This function does not apply to objects.

Scroll Up/
Down

Scroll Wheel If vertical scrolling is enabled, scrolls the 
document up or down.

Zoom Ctrl + Scroll 
Wheel

Zooms a label up or down. To Zoom Out, hold 
the CTRL key while scrolling down. To Zoom IN, 
hold the CTRL key while scrolling up.

Drag and 
Drop/Move

Left Button 
Drag

Moves a selected label object within a label.
Resizes the object if the mouse is positioned on 
one of the handles of the selected object.

Select Multiple Left Button 
Drag

Selects multiple items if the mouse is NOT 
positioned on any selected item. (See Selecting 
Multiple Objects or Labels on page 33 for more 
information.)
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Setting Options
Settings on the Options tab provide default print settings and affect the way the 
LabelMark software behaves. Specifying default print settings enables you to bypass 
a number of formatting options whenever you create a label file. 

Use the Options tab to: 

• Set print defaults and control whether the software checks for updates. 

• Set viewing options for the editor (such as default zoom level).

• Set text formatting defaults (font, size, alignment, and so on).

• Set default paths for files (such as labels and images).

• Control the refresh of imported data and the date and time. 

• Enable connectivity to Microsoft® Excel®, Microsoft Visio®, or AutoCAD® 
software. (See Chapter 9 Microsoft Visio on page 129, Chapter 10 Microsoft Excel on 
page 137, and Chapter 11 AutoCAD on page 145.)

To change the default settings:

1. On the top, right-hand side of the LabelMark Desktop software, click the gear icon 
to open the Options tab. 

2. Along the left side of the Options tab, select the page of settings you want to 
change. 

3. Change the settings as desired. 

4. Click the Save button to save your changes.
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Help
The Help function of LabelMark 6.0 is an electronic reference manual that shows you 
how to work with many of the features of the LabelMark 6.0 software. You can access 
the Help files at any time while working with the LabelMark 6.0 software. 

To access Help:

1. Click the question mark icon and select User Guide. The left pane of the help 
contains navigation tools: Contents and Search tabs; the right pane contains the 
information. 

2. Navigate the help in the following ways:

• Use the Contents tab to explore the content of the help. Double-click to 
expand or collapse books in the contents to see what information they 
contain. Click on a topic title to display it in the right pane. 

• Use the Search tab to look for a specific word or phrase in the help. 
Capitalization does not matter (if you search for Utility, it will find utility), but 
exact spelling does matter. 

• Use the Back and Forward buttons in the Help window’s toolbar to go back to 
previously viewed topics and forward again.
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2 Creating Labels
The basic process for creating a label is to:

1. Create a label file and choose the label stock, or part, on which you want to print 
the labels. See Step 1: Create a Label File on page 11.

2. Design the label. See Step 2: Design the Label on page 14.

3. Save the label file. See Step 3: Save the Label File on page 20.

4. Print or add to job (collection of related label files). See Step 4: Print the Label File 
on page 20.

Step 1: Create a Label File
The Home page lists parts (label stock) that you have recently used. The Recent 
Parts section is blank the first time you open the LabelMark software and until you 
have created at least one label file. 

To create a new label file using a label part not listed on the Home page:

1. Click Create and select New Label. The Create New Label page opens.
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2. Click the part number to use. (For information about how to find a part in the list, 
see Finding a Part in the List on page 13.)

3. If you want to place graphics, lines, rectangles, or barcodes on the labels, select 
the Graphics Mode button. For text-only labels click the Line Mode button.

4. Click Create. A blank label file opens using the selected part.
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To create a label based on a recently used part: 

1. On the Home tab, under RECENT PARTS, click the part number to use. 
A box opens indicating the dimensions of the label part and enabling you to create 
a label or template based on that part. 

2. Click one of the following. A shaded background indicates the item is selected. 

• Line Mode. Choose this if you want to place only text on the label.

• Graphics Mode. Choose this if you want to place graphics, lines, rectangles, 
or barcodes on the label.

3. Click Create Label. A blank label file opens using the selected part. 

4. Go to Step 2: Design the Label on page 14.

Finding a Part in the List
When the parts list opens (for example, on the Create New Label tab) the LabelMark 
software tries to identify the label part in a connected printer and puts that part at the 
top of the list. The software also brings favorites and custom parts to the top of the list. 
(See Managing Custom Parts on page 109 and Managing Favorite Parts on page 115.) If 
the printer was turned off when the parts list opened, click Refresh printers to detect 
the label part and bring it to the top of the list. 

To quickly locate a part in the list, use the Search or Filter. Use search if you know all 
or part of the part name. Use Filter to narrow the list down by label size, assigned 
printer, or by label family (label type, such as die-cut or continuous). 

Search

To search for a part: 
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1. Click the Search button to select it. (A blue background means the button is 
selected.)

2. In the blank box with the binoculars next to it, type in all or part of the part name. 

3. Click the binoculars button. The parts list displays all parts that completely or 
partially match the text you entered.

Filter

To filter the parts list:

1. Click the Filter button. 

2. If you know the size of the label part you want, in the Size section fill in the Width 
and Length. If only one dimension matters to you, fill in just that one. Either type 
the value or use the up and down arrows to select a value. 

The list adjusts immediately to show labels that closely match your selections. 

To clear your selection, click and drag the pointer to select the value. Press the 
Delete key on your keyboard. 

3. If you know the printer associated with the label part, click in the Printer box and 
select the printer. The list adjusts immediately to show labels that match your 
selections. 

4. If you know the type of part you are looking for, click in the Label Family box and 
select the label type (for example, two-sided sleeve or continuous). The list 
adjusts immediately to show labels that match your selections.

If you select more than one filter, the results show items that match all filter criteria, 
not just one. Each selection further refines the results. 

To start over at any time, click the Reset filter button in the upper right. 

Step 2: Design the Label
Add text, graphics, lines, rectangles, and barcodes to the label. Read the following 
sections for information about editing the label. You may also wish to read Chapter 3 
Formatting a Label on page 31. 

Editor/Workspace
Edit the label in the Workspace area of the application window. The Label Editor has 
two types of views.
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• Single label view, where only one label is visible at a time.

• Multi-label view, where multiple labels are laid out in rows and columns, similar to 
the way they are laid out on the liner. The labels are numbered, left to right, top to 
bottom.

In multi-label view, the Editor displays the maximum number of labels that can fit in 
the Editor window, even though the labels are not yet created. 

View

If the selected part number contains more than one label, it displays the multiple 
labels on the screen with a circled number next to each label to indicate where that 
label is on the media liner. 

To view one label in a multi-label layout:

1. Click the label you want to view alone.

2. Choose View > Single Label Layout

That label displays by itself in the workspace.

To view all the labels in a multi-label layout:

1. Choose View > Multiple Label Layout.

Note: When applying serialization, adding date/time text, or using the Command 
Multiplier, you do not have to have all labels visible. 

Two-Sided Labels

Some label parts allow printing on both sides of the label. To view each side, 
separately or together:

1. Choose View > Two-Sided Sleeve > Side # (where # is the number of the side 
you want to view).

OR

Click one of the 2-sided buttons. 

You can set the preferred viewing option as a default in the Double sided view field in 
Editor Options (see page 9).
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Duplicate Data on Second Side

When working with 2-sided labels, you can duplicate all data (text, graphics, 
barcodes, etc.) placed on one side of the label onto the other side of the label. You do 
not have to select data to duplicate. If you want to duplicate only one or two elements 
on a label, use the Command Multiplier (see page page 40). 

To duplicate data onto the second side of a 2-sided label, once data has been placed 
on the first side:

1. Click Duplicate data on second side button. 

OR

Choose Edit > Duplicate data on second side.

Duplicated data on the second side can be moved independently from the data on the 
first side of the label. 

Duplicate Data on Other Side at Print Time

If the option Duplicate data on other side at print time has been selected in the 
General Options category of the Options function, data on the first side of a 2-sided 
label will automatically be duplicated on the second side when printed. (See Setting 
Options on page 9.) 

Duplicating data at print time is different than duplicating on the second side of a label 
in the editor. In the editor, after duplicating data on the second side, if you go back to 
the first side and make some changes, those changes will not automatically be 
reflected on the second side. When printed, the two sides of the label will be different. 
However, if you Duplicate data on the other side at print time, the changed data on the 
first side will replicate on the second side, overwriting what had previously been on 
the second side. Therefore, side 1 and side 2 will always print the same.

Label Copies

You can indicate the number of copies of a single label to print by using the Label 
Copies field. This field displays next to each label indicating that you can set a 
different number of copies for each label. 
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When using a Perma-sleeve label part, this setting applies not only to the individual 
label, but to the entire row of labels. To change this default behavior, in the File & Part 
properties panel clear the Use row copies check box. 

To display the Label Copies field:

1. Choose View > Label Copies.

To indicate the number of copies to print of that particular label:

2. Click the up or down button.

The Label Copies option can be removed from the Workspace by selecting View > 
Label Copies again to remove the checkmark.

Go To a Label
Regardless of which view you are in (single or multiple labels), you can move to 
different labels in the file using the Go To function. To go to a specific label, if the label 
is not visible on the screen:

1. Choose Edit > Go To Label… or press [Ctrl+G].

2. Enter the number of the label you want to access.

3. Click OK.

Label Navigation

If you are in Single label layout, the Label navigation buttons display on the right side 
of the Status Bar. 

To go to a specific label in the file:

1. Highlight the current number in the Label Navigation number field.

2. Enter the number of the label to which you want to go.

3. Press [Enter].

To move to the next label:

4. Click Next. 

To move to the previous label:

5. Click Previous. 
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To move to the last label in the file:

6. Click Last. 

To move to the first label in the file:

7. Click First. 

Zoom
The Editor supports zooming in all views. You can zoom from 25% to 800%. 

Fit to Width adjusts the first row of labels so that the entire width of the row fits the 
current width of the workspace.

Fit to Page shows all printable labels in the workspace.

The Editor supports horizontal and vertical scrolling when displayed elements do not 
fit the display area.

To zoom in or out of a label:

1. Choose View > Zoom....

2. Click the desired zoom option.

3. Click OK.

You can also specify an incremental zoom percentage.

1. Click Custom value radio button.

2. Enter the percentage desired.

3. Click OK.

You can set the default Zoom option or percentage in the Editor Options category of 
Settings. (See page page 9).
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Quick Zoom

A Zoom control scale displays in the lower right corner of the Status Bar. To quickly 
change the zoom percentage of the label file:

• Drag the zoom control slider to the right to increase the size or to the left to 
decrease the size.

• Click the plus or minus buttons to increase or decrease the zoom percentage by 
10% at a time. 

As you drag the zoom slider, the zoom percentage displays in the percentage box 
directly to the right of the slider.

You can also change the zoom to predefined percentages by working directly with the 
percentage box.

1. Click the down arrow in the percentage box.

2. Click the percentage or zoom option as desired.

Adding Text
Once a label or template file is created or opened, the label editor is activated for the 
chosen label part. If not using Graphical Label Design mode, you are automatically in 
text mode and only text can be added to the label. The cursor displays as an “I-beam” 
indicating that text can be entered.

To add text to a label:

1. Click on the label where text should be added. 

A blue dotted line displays around the label indicating that label is selected, i.e., 
the focus is directed to that label.

2. Type the text.

Graphical Label Design

If using Graphical Label Design mode, to add text:

1. Click on the label where text should be added.

2. On the Action toolbar, click the Text button. 

The mouse pointer becomes an I-beam, indicating that text can be entered.
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3. Click the mouse where the text should be placed.

4. Enter the text.

A border displays around the text as it is being entered. This border represents the 
text line.

5. When finished entering the text, click anywhere on the screen to remove the 
typing line borders.

When in Graphical Label Design mode, the Text tool, if selected, remains in use until 
some other tool is selected. This is known as a "sticky" tool.

Step 3: Save the Label File
Save the label file to store it for future use. Before you save the file, the tab is named 
Label File1 (or another number). After you save the file, the tab is named with the file 
name. 

To save the label file: 

1. Select File > Save. 

2. (Optional) By default files are saved in C:\ProgramData\Brady\LabelMark6\Label 
Files, but you can choose another folder if desired. 

3. Type a name for the file. File names can be up to 250 characters long and can 
include letters, numbers, spaces, and some special characters. Choose a name 
that will help you remember what labels it contains.

4. Click Save. File names must be unique. If another file of the same name exists in 
this folder, a message informs you of the situation. You can choose to replace the 
existing file or click No to cancel and then save the file with a different name. 

Once saved, the file remains open. Proceed to the next step, printing. (To close the 
file later, click the X on the tab next to the file name.)

Step 4: Print the Label File

Print Preview
While the Editor displays labels as they appear on the liner, to get a better view of how 
the data will register on the actual printed labels, use Print Preview.

To preview your label file, from the Editing screen:
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1. Choose File > Print Preview. Alternatively, click Print Preview. 

The label file displays, at 100%, as they will print on the selected printer. 

2. To view labels close up, click Zoom In. 

3. Click Zoom Out to lower the zoom percentage. 

4. Click Fit to Width to display labels across the width of the preview screen. 

5. To return to normal print preview, click Zoom 100%. 

6. To close the print preview window, click Close. 

If, after previewing the labels, you want to print, from the Print Preview window:

7. Click Print. 

This displays the Print dialog box, where you can change the printer, select specific 
labels to print, or indicate a number of copies to print. 
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Print Dialog Box

For each label file you want to print, you can do the following:

• Select the printer you want to use to print the label file, regardless of what you 
have set as the default printer.

• Set the number of labels to print. 

• Determine if you want to print the labels in reverse order (for example, Labels 1, 2, 
3 will print in reverse order as 3, 2, 1).

• For 2-sided sleeve material, select which side to print (side one, side two, or 
both).

• Select whether to print the second side as standard or reverse. (This field reflects 
the default setting selected under General Options. See page 9.)

Note: The Duplicate data to 2nd side field reflects the default setting you selected 
under General Options. To activate the Duplicate data to 2nd side field, in order to 
change the setting for this printing, under Side To Print select either Side 2 or Both. 
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The BBP72 printer has two printheads and can print both sides at once if you select 
Both.

• Test print your first row of labels and adjust horizontal and/or vertical print position 
offsets.

• Print in label saver mode. Use the Row and Column settings under Label Saver 
Option to choose a label to start printing with. This is useful if you want to print 
data from two separate label files onto one sheet of labels. For example, print the 
first 25 labels using data from Label File #1. Put the sheet of labels back into the 
printer and print the next 25 labels from Label File #2 starting at label #26 (specify 
the row and column that corresponds to label number 26). This results in 50 labels 
from two different files printed on one sheet.

Selecting a Printer

To print a label file, one label in a file, or a range of labels in a file, with the label file 
active:

1. Choose File > Print.

OR

Click the Print button (on the Standard toolbar or from Print Preview). 

In the Name: field of the print dialog box, the name of the current, or last used printer 
is displayed. (The name of this printer is also displayed in the status bar at the bottom 
of the screen.) You are presented with a list of installed printers from which to choose. 
To switch to a different printer:

2. Click the drop down arrow in the Name: field and select the printer you want to 
use.

When you create labels, the predesigned label templates are set up to print on a 
specific printer. If you change the printer, you may have to adjust the print position 
(registration) so the information prints correctly on the labels. 

3. Adjust the print position (if needed) by entering the horizontal and vertical position 
in the Print position adjustment section. 

Note: Use numbers to enter the Horizontal and Vertical position. The positioning 
is measured in inches or millimeters, depending on what you have set in the 
General Options. You can enter a fraction as a decimal (e.g., ¼ inch is entered as 
0.25).
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Copies

In the Copies section, File label copies is the default. This prints all labels in the label 
file that contain data. 

When you set the Label Copies field in the Workspace, the indicated number of 
copies automatically displays in the Total labels: field in the Print dialog box.

To print multiple copies of an entire set of labels, in the Copies section of the print 
dialog box:

1. Select Copies. 

2. Highlight the number in the field to the right and enter the number of copies 
desired. The Total labels field reflects the number of copies.

Printing Specific Labels

If you want to print only one label in a label file:

1. Select the label you want to print.

2. Choose File > Print. 

3. In the Labels to print section of the Print dialog box, click Selected labels only.

If you want to print a number of labels from a label file, but not the entire label file:

1. In the Labels to print section of the Print dialog box, click Range of labels. One 
row in the Print range definitions table opens for editing. 

2. Click the Start field and enter the first label number in the range to print.

3. Click the End field and enter the last label number in the range to print.

4. To print multiple copies of the specified range, click the Range Copies field and 
enter the number of copies to print. 

The Sub Total field reflects the number of labels in the specified range multiplied 
by the number of copies in the Range Copies field.

5. (Optional) In addition to the Range Copies, if you enter a number in the Label 
Copies field, the Sub Total field reflects the range of labels to print multiplied by 
the number in the Label Copies field.

Example: The range of labels to print starts with label #2 and ends 
with label #4. That is three labels to print (2, 3, and 4). If 
the Range Copies to print is 5, the subtotal would be 15 (3 
labels x 5 Range Copies= 15 labels). 

If you also enter a number in the Label Copies field, that 
number is added to the equation. If you set Label Copies to 



25Creating Labels
Step 4: Print the Label File

LabelMark 6.0 User’s Manual

3, the Sub Total would now be 45 labels. (3 labels x 5 
Range Copies x 3 Label Copies = 45.)

Range Copies vs. Label Copies

You can print copies of the range or copies of the label or both. The difference 
between the two copy options is how the labels print out - collated or non-collated.

Range Copies prints collated, meaning all labels in the range print once, then the 
entire range of labels sequence prints again, until all copies have been printed. That 
is, the labels or pages of labels are in order: 1, 2, 3, and so on. 

Figure 1 • Range Copies - three copies of five labels, collated

Label Copies are not collated, meaning all copies of the first label in the selected print 
range print out, then all second labels, and so on. 

Figure 2 • Label Copies - three copies of five labels, uncollated

Label Copies takes precedence over Range Copies if both are specified. That is, you 
get several sets of uncollated labels. Each label in the range prints the number of 
times specified by Label Copies. This set then prints again until you have the number 
of sets specified in Range Copies. 
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Test Print Labels
Before sending a label file to the printer, you may want to view some of the physical 
labels to determine the precise placement of data. While Print Preview shows 
placement of data on a virtual label part, due to minute discrepancies in label 
placement on the liner or feeding mechanisms of specific printers, the label alignment 
may need to be slightly adjusted. To view the actual placement of data on the label 
part, test print your labels. Test printing prints the first row of your data (not 
manufacturer’s pre-designed data) on the physical label part. Therefore, if the data 
placement needs some adjustment, that can be done before you waste an entire 
sheet or roll of labels.

To test print the first row of labels, with the label file active:

1. Click the Print button. 

In the Print dialog box:

2. Click the Print First Row button (located in the Printer Position Adjustment section 
of the Print dialog box).

3. If the data needs to be adjusted, click the up or down arrows in the Horizontal and 
Vertical fields.

(The adjustment numbers are measured in inches or millimeters, depending on which 
unit of measure you have chosen in Settings > General Options.)

Print the Labels
When ready to print your labels, from the Print Dialog box:

1. Click Print.

Depending on the printer being used, if the label part loaded in the printer is not 
the label part you used to create the label, an error message displays indicating 
the discrepancy. Click OK to continue to print or Cancel to cancel the print job. 

Closing the Label File
To close a label file, click the X next to the file name on the label tab. 

More About Working with Files
The following sections describe how to open an existing label file and how to use file 
properties. 
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Opening an Existing Label File
To open an existing label file: 

• If the file is in the RECENT FILES list in the blue pane on the Home page, click the 
file name. 

• If the file is not in the RECENT FILES list, click the Open tile in the white part of 
the Home page and select File. 

Files Using Discontinued Parts

When opening older files that were created using label parts (media) that Brady no 
longer makes, an error message displays. LabelMark suggests a newer label part that 
closely matches the discontinued part. To use the suggested new part:

1. Select Use New Part: (##-###-#-##-# - new part number). 

You can still open the file using the old part number, but the data may not print 
properly. 
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File and Part Properties
The File & Part properties panel includes information about the file and is saved along 
with the label and template files. If the panels are not visible to the left of the 
workspace with a label file open, click the arrow on the left side of the workspace. See 
page 4. 

The File properties information reflects the date and time the document was created, 
the last saved date, and the author of the file. 

The Description field of the File properties section is a convenient way of entering 
information about what the file contains, when to use the file, how to use it, what 
media should be installed in the printer, and so on. It can be used for any descriptive 
or instructive information about the file. The description field can hold up to 250 
characters.
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The File & Part properties panel also contains information about the particular label 
part used in the creation of the file. 

While you cannot edit the part properties, you can use the properties to create a 
custom part. (See Creating a Custom Part on page 109.)
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3 Formatting a Label
LabelMark software has two modes for working with labels, Line mode and Graphics 
mode. Line mode is for labels that only have text on them while Graphics mode is for 
labels that have images, barcodes, text, and other elements on them. These elements are 
called objects. 

The choice between Line and Graphics modes is made when first creating the label 
file. See Step 1: Create a Label File starting on page 11.

Figure 3 • Line mode (text only) and Graphics mode label design

Adding and Editing Objects
Most information in the following sections applies to Graphics mode. Portions that 
apply to Line mode are marked. 

The following types of objects can be placed on Graphics labels:

• Text

• Graphics (Pictures and symbols)

• Barcodes

• Lines

• Rectangles

To place an object on a label:

1. In the Action toolbar, click the button for the type of label object you want to place. 

Line Mode Graphics Mode
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2. With the object type selected, draw a frame on the label to contain the object. For 
a text object, click on the label where you want the text to begin. (The line length 
automatically increases as you enter text.)

Selecting an Object
(Graphics mode) In order to format, edit, size, or move an object, it must be selected. 
Selecting an object places the focus on the object, enabling formatting functions to be 
performed only on that item. To select an object:

1. Using the Selection tool, click the object.

A series of dots display around the object, one on each corner and 
one on each side. These dots are called handles. The presence of 
the handles indicates that the object is selected.

To remove the handles:

2. Click anywhere on the screen.

The handles on the objects may display in different colors, each color signifying a 
specific rule for resizing and moving the object. The following table describes these 
rules.

Handle Color Description

Clear (on text 
objects)

Clear (or solid white) handles indicate the object cannot be 
resized by dragging a handle. To resize the text, you must 
change the font size. While you cannot resize the text object 
by dragging a handle, you can still move the text object to 
different areas on the label.

Clear (on graphic 
objects)

Clear (or solid white) handles on a graphic object indicate that 
you cannot resize the object in the direction of that handle. 
Even though you may not be able to resize, you can still move 
the graphic to a different area on the label.

Green (on graphic 
objects)

Green handles indicate the graphic can be resized by 
dragging the handle in the direction of the handle (i.e., corner 
handles drag in a diagonal direction, side handles drag up or 
down, left or right).

Red (on graphic 
objects)

Red handles indicate that part of the object is outside the 
printable area.



33Formatting a Label
Adding and Editing Objects

LabelMark 6.0 User’s Manual

Selecting Multiple Objects or Labels

(Selecting multiple labels applies to Line mode as well as Graphics mode.) You can 
perform some functions (such as moving and copying) on multiple objects at one time 
provided those objects are all selected. The following table describes how to select 
multiple objects or labels. 

Green Locks Green, padlock-shaped handles indicate the object is locked 
and cannot be resized or moved to different areas on the 
label using the mouse. You can, however, adjust the size and 
position properties of the object using the Label & Object 
properties panel on the left.

Clear (White) 
Locks

The Clear (or solid white) padlock-shaped handles indicate 
the object cannot be sized or repositioned by any means 
(mouse or Properties box). The object is locked.

Selection Items Action Procedure

Objects Ctrl + Left Click Holding the CTRL key, click the left 
mouse button on the objects to be 
selected.

Objects 1. Position the pointer on a corner of 
the label just above, below, left or 
right of the objects you want to 
select. Do not place the pointer on 
an object.

2. Drag the mouse diagonally to “draw” 
a selection rectangle around the 
objects you want to select.

When you release the mouse, all 
objects inside the selection rectangle 
are selected.
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Locking Objects on a Label
(Graphics mode) Locking an object disables it, preventing it from being edited, sized, 
or moved. When locked, the selection handles change appearance, indicating the 
object is in a locked state.

To lock an object:

1. Click the object to display the handles.

2. Choose Edit > Lock/Unlock > Lock. (Alternatively, in the Label & Object 
properties panel click the Locked check box.)

To unlock an object, thereby freeing up an object for editing:

1. Click the locked object to display the handles.

2. Choose Edit > Lock/Unlock > Unlock. (Alternatively, in the Label & Object 
properties panel click the Locked check box to remove the checkmark.)

If you want to lock all objects on a label, choose Lock All under the Edit > Lock/Unlock 
menu. If locking everything, you do not have to select any particular object on the 
label. Likewise, if you are not sure which object is locked, choosing Unlock All from 
the Edit > Lock/Unlock menu unlocks everything without having to first select an 
object.

Move Object
(Graphics mode) To move an object to another location on the label:

1. Click the object to display the handles.

Labels (Non-
contiguous)

Ctrl + Left Click Holding the CTRL key, click the left 
mouse button on the labels to be 
selected. 
The labels DO NOT have to be next to 
each other.

Labels 
(Contiguous)

Shift + Left Click 1. Click the first label to be included in 
the selection.

2. Holding the Shift key, click the last 
label to be included in the selection.

The labels MUST BE next to each other, 
in a row or column.
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2. Place the pointer on the object itself (NOT on a handle). The pointer turns into a 
cross.

3. Drag the object to the desired location on the label.

4. When finished, click anywhere on the screen to remove the handles from the 
object.

Alignment
(Graphics mode) The Align function aligns objects on a label, horizontally or vertically 
to each other. Because you are aligning objects to each other, at least two objects 
must be selected in order to use the align function. 

Figure 4 • Example of vertical and horizontal alignment

Left, center, and right are used to align objects that are displayed vertically to each 
other. Top, middle, and bottom are used to align objects that are displayed horizontally 
to each other. If you apply horizontal alignment to items vertically aligned to each 
other (or apply vertical alignment to items horizontally aligned to each other), the 
objects will align on top of each other, creating a layered effect. (See Overlapping 
Objects on page 37 for more information.) 

Items centered vertically 
to each other

Items centered horizontally to each other
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Figure 5 • Example of vertical selection with horizontal alignment

To align objects:

1. Select the objects to align to each other. (See Selecting an Object on page 32.)

2. Choose Format > Align, and choose the alignment desired. Alternatively, click 
the desired alignment button in the toolbar.

 

Center on Label
(Graphics mode) To place an object directly in the middle of a label (vertically and 
horizontally), use the center objects command.

1. Click the object to display handles.

2. Choose Format > Align > Center objects vertically or Center objects 
horizontally. Alternatively, use the buttons on the Formatting toolbar to center 

objects vertically  or center objects horizontally .

You can center a number of objects vertically or horizontally on a label at one time. 
The objects, however, will retain their respective original distance from each other. In 
other words, if the objects have previously been aligned to each other, they will retain 
their alignment but be centered on the label as a group.

For information on centering text in Line mode see Horizontal Justification on page 52

Objects vertically (center) aligned to each 
other

Applying horizontal alignment (middle) to 
vertically aligned objects
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Overlapping Objects
(Graphics mode) Objects can be stacked one on top of the other, such as text over a 
graphic, to form what appears to be one object. When objects overlap, you may need 
to change the order of the objects, which is in front and which is behind. 

Figure 6 • Example of overlapping objects

To rearrange overlapping objects:

1. Click one of the objects in the stack to select it.

2. Depending on how you want to stack the objects, in the Formatting toolbar, click 

Bring to Front  or Send to Back . 

(Alternatively, choose Format > Order > Bring to Front or Send to Back.)

Repeat the above process as often as necessary to gain the desired effect.

Rotating Objects
(Line and Graphics modes) You can rotate objects and text clockwise or 
counterclockwise in 90 degree increments. When rotating an object on a label, the 
point of rotation is the center of the object.

Note: Be aware of the size of the object and where it is placed on the label. If the 
width of an object is larger than the length (height), when rotation is applied, it may 
appear to move off the label. 

To rotate an object in 90° increments (Graphics and Line modes):

1. Select the object (Graphics mode) or text (Line mode) to rotate.

Drawing 1 - Overlapping lines and image. Drawing 2 - The image is selected and 
“Bring to Front” applied, obscuring 
portions of the line.
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2. Choose Format > Rotate > Rotate clockwise or Rotate counter clockwise. 
(Alternatively, in the Formatting toolbar click the rotate counterclockwise or rotate 

clockwise button.)  Repeat to rotate an additional 90° (180°, 270°, 

and so on).

To rotate an object a specific number of degrees, use the Label & Object properties 
panel. (Graphics mode only)

1. Select the object to rotate.

2. In the Rotation field of the Label & Object properties panel, enter the degree to 
which you want to rotate the object or use the arrows to increase or decrease the 
rotation. 

Enter the degree as a whole number, not a fraction or decimal. Example: Forty-
five degrees is entered as 45.

Note: The Rotation field rotates objects in a clockwise direction only. However, 
you can achieve counterclockwise rotation by entering a minus sign (-) in front of 
the rotation number. Example: clockwise = 90°, counterclockwise = -90°.

Rotating the Label View
(Line and Graphics mode) Sometimes you may want to rotate the label view when 
editing. For example, if a horizontal label will be placed vertically on a pipe, you might 
rotate all text or objects on the label and prefer to edit while viewing the label 
vertically, as it will be placed in use. 

When you rotate the view, objects already placed on the label keep their orientation 
relative to the label. That is, if an object is placed on a label without any rotation and 
then the view is rotated 90°, the object rotates with the view of the label. Objects 
placed after the view is rotated, however, are oriented right-side up relative to the 
view. That is, they are rotated relative to the label’s actual orientation. 

Object added to a label. The object has 
not been rotated.

Object displayed on a label after the view 
has been rotated 180°.
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Figure 7 • Position of objects before and after label rotation

To rotate the label view:

1. Choose View > Rotate View.

2. From the displayed list, click the degree of label rotation desired. The view is 
rotated for all labels in the file regardless of whether you are in single or multiple 
label view.

 Delete an Object
To remove an object from a label (Graphics mode):

1. Click the object to be removed. (This selects the object.)

Print preview of the object on the label after the label is rotated 180°. Notice the label 
object retains its original position. 

Original object added before label view 
rotated 180 degrees.

New object (barcode) added after label 
view rotated 180 degrees.

Print preview. Notice the barcode added after the view was rotated looks upside-down. 
This is because it was placed that way on the label because the label was being viewed 
upside-down when the barcode was placed on it.
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2. Choose Edit > Delete or click Delete. 

The object is removed from the label.

Undo/Redo
(Line and Graphics modes) The Undo function “undoes” the last action taken, whether 
editing an object, adding information, or deleting data. It puts the object or label back 
to the state it was in before the last action was taken.

The Redo function “undoes” the Undo function. It places the object or label back to the 
state it was in before the last Undo was enacted.

To undo an action:

1. Choose Edit > Undo or click Undo.  

To redo an action that has been undone:

1. Choose Edit > Redo or click Redo. 

Command Multiplier
(Line and Graphics mode) Use the Command Multiplier to duplicate entire labels, or 
specific objects on a label, onto the other labels in a file. This saves time when you 
need to create a large amount of redundant labels. If an entire label has been copied 
through the Command Multiplier, you can edit the contents of just one of the labels 
and the editing occurs on all the copied labels concurrently. 

The specific commands available in the Command Multiplier are:

• Copy Label

• Copy Object(s) (applies to a line of text as well as an object on a graphic label)

Copy Label
To copy a label (and all objects on the label):

1. Click the label to copy.
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2. Choose Edit > Command Multiplier. 

3. Select Copy Label.

4. In the Apply to list, select which labels should be copies of the current label. For 
example, select Every 2nd label if you want every other label in the file to be a 
copy of the current label. 

5. In the Start at label number field, type the number of the label on which to start 
copying.

6. In the Number of times to repeat field, indicate how many labels the copied label 
should be applied to.

7. (Optional) If you chose Custom list in the Apply to list, fill in the Custom list field. 
Type a list of all label numbers to which the selected label should be copied. 
Separate label numbers with a comma (for example, 2, 5, 9). 

The Summary area indicates on which labels the copied data will be placed.

8. Click OK.
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Copy Objects 
To repeat only parts of a label, use the Copy Objects function of the Command 
Multiplier. The Copy Objects function only duplicates the selected objects or current 
line of text, allowing you to enter different objects on each individual label. For 
example, use this function if you want the same text on all labels, but different images.

To duplicate a specific object or line of text on a label (not the entire label):

1. In Graphics mode, click the object on the label that you want to copy. In Line 
mode, click within the line of text that you want to copy.

2. Choose Edit > Command Multiplier.

3. Select Copy Object(s).

4. In the Apply to list, select which labels should receive the copied data. For 
example, select Every 2nd label if you want the copied information on every other 
label in the file.

5. In the Start at label number field, enter the number of the first label on which to 
apply the copied object.

6. In the Number of times to repeat field, enter how many times the object should 
be replicated.

7. Click OK.

Note: Copying specific objects on a label adds those objects to the contents of 
other labels. It does not insert new blank labels to receive the copied object.

If you duplicate the contents of an entire label, you still can customize an individual 
label in the duplicated group by adding a separate object to the label, outside of the 
copied information. For instance, if the label you copied contains only text, that text 
displays on all the labels in the Command Multiplier sequence. You could access one 
of those labels and add a specific graphic. Because the graphic object is outside the 
copied label object (text), it will display only on the label to which it was added. 

On the other hand, if you edit an object that is part of the copied information, the 
editing changes take effect on all the labels to which the information was copied. 
(Objects are linked when you use the Command Multiplier. To break the link of an 
object so that you can edit it separately, double-click the object. For more information 
see Linked Objects starting on page 77.)
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Insert a New Label
(Line and Graphics modes) You can insert a new, blank label in front of another label. 
When you insert a new label, the selected label and all following labels are pushed to 
the right and down the string of labels.

To insert a new label:

1. Select the label that is to the right of where the new label will be placed. (The new 
label will precede the selected label.)

2. Choose Insert > Insert Label.

You can repeat the above procedure for as many new, blank labels as desired.

Insert a Test Label
Insert a test label when you want to determine whether your labels will line up 
correctly. A test label displays the boundary of the printable area (called registration) 
for that label part, as well as some sample centered text. 

To add a test label:

1. Click the label before which you want to add a test label.

2. Choose Insert > Insert test label.

The test label displays with a registration border and a text object in the middle. Add, 
delete, or edit objects on the test label.

To display the test label on other labels, repeat Steps 1 and 2 above. To display the 
test label on all labels, use Command Multiplier.
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To remove the registration border on the labels:

1. Select the border to display handles.

Note: If you cannot select the registration border, it may be in the background. 
Select other items on the label and use Send to Back. Then try selecting the border 
again.

2. Choose Edit > Delete or click Delete. 

Properties Panels
The Properties panels contain formatting functions and other properties for the label 
objects on which you are working. The property options available depend on the object, 
file, or job you are working on. 

Figure 8 • Properties panels

 Click arrow to display or hide a specific property panel.
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 Click to display or hide the properties panels.

 Selected object.

To display the Properties panels if they are not visible:

1. Click the arrow on the left side of the workspace window. (The arrow changes 
directions depending on whether you are displaying or hiding the properties 
panels.) This arrow is marked with a 2 in Figure 8 on page 44. 

2. To display a particular property panel, click the arrow next to the panel name. (The 
arrow points down when the panel is open and to the right when the panel is 
closed. This arrow is marked with a 1 in Figure 8.)

3. Edit the properties as desired. Edits take effect immediately.

Text Objects
(Graphics mode) Text objects contain user-defined text and characters, allowing direct 
data entry on the label. Only alphanumeric characters can be used in a text object. 
Text objects can be single or multi-line, however the text object does not “wrap” text 
(that is, automatically start a new line when the label boundary has been reached). 
For a multi-line text entry, press the Enter key to start a new line.

Adding Text
To add text to a label in Graphics Mode:

1. Click the Text button on the Action toolbar.  The pointer becomes an I-

beam, indicating that text can be entered.

2. Click on the label at the point where the text should be placed.

3. Enter the text. A border displays around the text as it is being entered. This 
indicates the text line.

4. To add another line of text, press [Enter].

5. When finished entering text, click anywhere on the screen to remove the typing 
line borders.

Note: When clicking outside the text box with the text tool, another text line 
border displays. To remove the display of this blank line text border, click the 
Select tool. This takes you out of text mode.
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Edit Text
(Graphics Mode) Clicking a text object one time displays handles for manipulating the 
object. When the handles are displayed, you can move the text object to another 
position on the label or you can apply formatting changes. Double-clicking the text 
object opens it for editing. 

To add or delete text from the text object:

1. Double-click the text object to open it for editing.

2. Click in the text string where the text should be added.

3. Type the text.

Cursor Movement in Text Strings
Once you have clicked inside the text string, you can use keystrokes to move the 
cursor to different areas of the text. The following table indicates cursor movement in 
text strings using the keyboard.

Key Action

In a multi-line text string, moves up one line at a time from the 
position of the cursor.

In a multi-line text string, moves down one line at a time from 
the position of the cursor.

Moves the cursor to the right, one character at a time.

Moves the cursor to the left, one character at a time.
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Delete Text
Remove characters from the text string with the Delete key or the Backspace key. The 
Delete key deletes characters one at a time from the position of the cursor to the right; 
the Backspace key deletes characters one at a time from the position of the cursor to 
the left.

To delete characters using the Delete key or Backspace key:

1. Double-click the text object to open it for editing. 

2. Click the mouse to the left or right of what you want to delete.

3. Press the [Delete] key to delete characters to the right of the cursor; press 
[Backspace] to delete characters to the left of the cursor.

Moves the cursor to the beginning of a line of text.

Moves the cursor to the end of a line of text.

In a multi-line text string, moves the cursor to the top line of 
text.

In a multi-line text string, moves the cursor to the last line of 
text.

Moves the cursor to the right, one word at a time.

Moves the cursor to the left, one word at a time.

Selects all text in the text object.
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Select Multiple Characters
You can delete or edit multiple characters at a time by first highlighting the characters 
you want to edit. The following table indicates highlighting techniques once you have 
opened the text string for editing.

Once text is highlighted, you can delete all the highlighted characters by pressing 
either the Delete key or the Backspace key. You can also type new text directly over 
the highlighted characters, thereby deleting text and adding new text at the same 
time. With multiple characters highlighted, you can also apply different attributes, such 
as bold and underline, or change the font and font size on all the selected characters 
at one time.

Find/Replace 
To search for specific text on a label in a multi-label file, use the Find/Replace function 
of LabelMark. The system can search for characters, words, or text strings. 

Find

To search for text in a label file:

1. Display Properties panels (if not already displayed). (See Properties Panels on 
page 44.)

Action Procedure

Drag Holding the left mouse button, drag across the characters to 
highlight.

Double-click To highlight a word, double-click the left mouse button on the 
word to select.

Triple Click To highlight an entire line, triple click the left mouse button on 
the line to select.

Shift + Cursor 
Movement Key

Hold the Shift while pressing any of the cursor movement 
keys to highlight that amount of text. (E.g., Shift + Home key 
highlights text from the position of the cursor to the beginning 
of the line. Shift + right arrow key highlights characters to the 
right of the cursor, one character at a time.)
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2. Open the Find/Replace properties panel. 

3. In the Find what field, type the text for which you are searching. If the data you 
are searching for occurs in upper or lower case exclusively, enter the search 
string in the exact case you want to match, then:

4. (Optional) Select the Match case check box if capitalization matters in the search. 

5. Select Up to search backwards in the label file or Down to search forwards. 

6. Click Find Next to begin searching. LabelMark moves to the first occurrence of 
the text in the direction you specified, selecting the label and highlighting the text. 

7. To find the next occurrence, click Find Next again.

You can edit the highlighted text string, then click Find Next to move to the next 
label to edit. 

Replace

To change multiple occurrences of specific data to something else, use the Replace 
feature in the Find/Replace Properties panel. 

To replace text, in the Find/Replace Properties panel:

1. Select Replace.

2. In the Find what field, enter the text to be replaced.

3. In the Replace with field, enter the replacement text.
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Note: When searching for and replacing a small word whose characters could be 
part of another word (such as the word “the” or “an”), in the Find what and Replace 
with fields, enter a space before and after the characters that make up the word. 
That way you will avoid changing parts of a word not meant to be changed. 

4. Select Up to search backwards in the label file or Down to search forwards. 

5. Click Find Next. LabelMark moves to the first occurrence of the text in the 
direction you specified, selecting the label and highlighting the text.

6. Click Replace. 

7. Continue to either find and replace each occurrence individually or all at once. 

• To continue with individual occurrences, click Find Next again, then click 
Replace. Continue until all occurrences have been changed.

• If you are confident that your search string and replacement text are correct, 
you can replace the text on all the labels at one time. After entering the search 
string and replacement text, click Replace all.
All occurrences of the search string on all the labels in the file are changed 
with the replacement text. A message displays the number of occurrences 
that have been changed.
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Text Object Properties
When a text object is selected, the following properties are available in the Label & 
Object properties panel. 

Figure 9 • Label & Object properties for text
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Property To Use

Font Indicates the current font in use. To change the font:
1. In the Font field, click the down arrow.
2. Select a font from the list.

Font size Indicates the current size of the font in use. To change the 
font size:

1. In the Font size field, click the up or down arrows to increase or 
decrease font size.

or
1. Double-click the font size currently in the Font size field.
2. Enter the new point size.

Click the Bold button to format all selected text in bold.

Click the Italics button to format all selected text in italics.

Click the Underline button to underline all selected text.

Click the Superscript button to display all selected text slightly 
above the line of text.

Click the Subscript button to display all selected text slightly 
below the line of text.

Horizontal 
Justification

Horizontal justification aligns the text within the boundaries of 
the text object, not within the boundaries of the label. To 
change the horizontal justification:

1. In the Horizontal Justification field, click the down arrow.
2. Select Left, Center, or Right.
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Expand/Condense Expanding and condensing text affects the spacing between 
characters in a word, giving the appearance of stretching or 
shrinking the word horizontally. Text can be expanded or 
condensed according to predefined increments 
(percentages). To expand or condense a word:

1. In the Expand/Condense (50%-200%) field, double-click the 
number currently filling the field.

2. Enter the percentage to expand or condense.

Note: One hundred percent is normal. The lower the 
percentage, the more condensed the word; the higher the 
percentage, the more expanded the word.

Auto Fit Auto Fit adjusts the font size automatically to fit the object 
size. As the text overflows the object width, the font size 
decreases until it fits the text line. To use Auto Fit:

1. Place a text object on the label and begin entering text.
2. Select the Auto Fit check box. The text object displays handles.
3. Double-click the text object at the place where you want to 

continue adding text.
4. Continue entering text.

The font size automatically decreases as the text string 
approaches the right boundary of the text object, thereby 
allowing you to enter longer text strings.

Underline 6/9 
characters

Select this option if you need to distinguish between the 
number 6 or the number 9 on a label that could be wrapped 
around an object, making the number ambiguous.

Trim Vertical 
Margins

Text inside a text object maintains a small distance between 
the text and the upper and lower sides of the text object 
boundary box. Removing this space enables you to move text 
closer to lines or graphics, or inside rectangles. To remove the 
space:

1. Click the Trim Vertical Margin check box in the Label & 
Object properties panel.

Vertical Input Orients the text field vertically instead of horizontally. 

Property To Use
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Line Spacing Line Spacing is incremented in point size. Normal, readable 
spacing uses an additional 2 points from the font size. For 
instance, when using a 12 point font, the line spacing would 
be 14 pt (12 plus 2). In the Line Spacing field, enter only the 
additional point size desired to vertically stretch the lines of 
text. To change Line Spacing:

1. Double-click the Line Spacing field.

2. Enter the additional point size over and above the font size.

OR, for a fraction of a point size:

3. Click the up or down arrows.

Note: To retain normal line spacing, leave this field blank or 
enter ‘0’.

Locked Select this check box to protect the text string from being 
edited and the text object from being moved or resized.

Printable This check box is selected by default. If you do not want the 
particular text object to print on the label, clear the Printable 
check box. This prevents the text object from printing, 
although other objects on the label still print.

Left Indicates the distance the left edge of the text object is from 
the left edge of the label. To change the distance:

1. Double-click the Left field.
2. Enter the distance the left edge of the text object should be from 

the left edge of the label.
OR

3. Click the up or down arrows to increase or decrease the 
indentation.

The distance you are able to move the left edge of the 
boundary box depends on the width of the label part. The 
incremental distance will vary between the different label 
parts.

Property To Use
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Flip-Flop 
(Graphics mode) The Flip Flop feature works on text objects only. It transposes, or 
reorders, lines of text or the positions of words in a single line of text. The Flip Flop 
feature works vertically on multiple lines of text or horizontally on a single line of text. 

In a vertical flip flop, the multiple text lines are transposed, with the top lines placed at 
the bottom, and vice versa. If you have more than two lines of text, the lines pivot 
around the middle line of text.

Top Indicates the distance the top of the text object boundary box 
is from the top of the label. To change the distance:

1. Double-click the Top field.
2. Enter the distance the top edge of the text object should be from 

the top edge of the label.
OR

3. Click the up or down arrows to increase or decrease the 
distance, fractionally.

The distance you are able to move the top edge of the 
boundary box depends on the length (height) of the label part. 
The incremental distance will vary between the different label 
parts.

Rotation Use this field to rotate a text object between 0° and 360°. To 
rotate the text object:

1. After selecting the text object, double-click the Rotation field in 
the Label & Object properties panel.

2. Enter the degree of rotation.

OR

3. Click the up or down arrows to change the degree of rotation. 
(The up arrow rotates clockwise, the down arrow rotates 
counterclockwise.)

Property To Use
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Figure 10 • Vertical Flip Flop

In a horizontal flip-flop, you transpose one line of text around a flip point. For example 
123|456 would flip-flop to 456|123. You designate the flip point by placing the flip 
character in the line of text. This feature is useful for identifying parts that are 
connected end-to-end. 

The default flip character is the pipe symbol (|). However, you can change which 
character to use for the flip flop function on the Options page. (See Setting Options on 
page 9 for more information.) 

Text in Column 1 is vertically flipped in Column 2, pivoting around the middle line of text 
(456).
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Where you place the flip character in the line of text determines how the data will flip. 
For instance, if you have four words in one line, and the flip character is placed 
between the first and second word, LabelMark places the first word at the end of the 
line and treats words 2, 3, and 4 as one word, placing them at the beginning of the line 
in the same order - 2, 3, 4. You cannot put multiple flip characters in a line of text. The 
Flip feature only acknowledges the first flip character it encounters, ignoring the rest.

Figure 11 • Horizontal Flip Flop

Figure 12 • Multi-word horizontal flip flop

To flip text objects, you only have to select the label you want to flip. The text object 
itself does not have to be selected. All vertical multi-line text objects on the selected 
label, and all horizontal lines containing a flip character, will flip when the Flip Flop 
function is invoked.

To flip lines of a text object:

1. Select the label containing the text object to flip.

2. Choose Format > Flip Flop.

Horizontal flip-flop (with flip character)

Multi-word horizontal flip flop, before flip. Multi-word horizontal flip flop, after flip
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3. Select the type of Flip-Flop, as follows:

For Vertical (multi-lines):

• Top to Bottom. Transposes the first lines of a multi-line text string with the 
last lines.

• Top to Bottom on New Label. Duplicates all objects (graphics and text) on a 
label, inserting them on the label next to the original. However, only the 
vertical, multi-line text objects are flipped on the copy.

• Top to Bottom Selected Object(s). On a label containing multiple text 
objects, transposes only the object(s) selected.

• Top to Bottom Selected Object(s) on New Label. Duplicates all objects 
(graphics and text) on a label, inserting them on the label next to the original. 
However, only those text objects selected on the original are flipped on the 
copy.

Figure 13 • Top to Bottom flip flop options

For Horizontal (single line):

• Left to Right. Transposes text on the left of the flip character to the right, and 
vice versa.

Label 1 with Top to Bottom flip flop (no object selected)

Label 1 with Top to Bottom Selected Object(s) on New Label
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• Left to Right On New Label. Duplicates all objects (graphics and text) on a 
label, inserting them on the label next to the original. However, only those 
horizontal text objects containing the flip character are flipped on the copy

• Left to Right Selected Object(s). On a label containing multiple text objects 
with flip characters, transposes only the object(s) selected.

• Left to Right Selected Object(s) on New Label. Duplicates all objects 
(graphics and text) on a label, inserting them on the label next to the original. 
However, only those horizontal text objects containing the flip character that 
are selected on the original are flipped on the copy.

Figure 14 • Left to Right flip flop options

Remove Flip Character

For horizontal (left to right) flipped objects, after flipping, remove the flip character.

1. Click the flipped line of text to display handles.

2. Choose Format > Flip Flop > Remove Flip Character. The flip character is 
removed.

Label 1 with Left to Right flip flop (no object selected)

Label 1 with Left to Right Selected Objects on new label
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Image Objects
Place graphics on a label with an image object. You can size and position image 
objects anywhere on the label. When resizing the image with the mouse, the original 
aspect ratio is maintained, meaning the length and width increase or decrease by the 
same proportion. However, to change that ratio, increasing the length or width 
separately, use the Label & Object properties panel. 

Note: The color of the handles on the selected graphic indicates whether the 
aspect ratio is maintained. Green handles on the corners only indicate that you can 
only resize diagonally, maintaining the length to width aspect ratio. Green handles 
on the entire image indicate that you can change the length or width separately. To 
get green handles on the entire image, select Allow Stretching in the Label & Object 
properties panel. 

You can change the file from which the graphic is created once the graphic is 
instantiated. The image data is saved in LabelMark. 

Add an Image
To add an image to a label:

1. Click the Image button on the Action toolbar. 

The pointer changes to a cross ().

2. Drag the pointer to draw a frame in which to place the image.

If you click the label rather than drawing a frame, you can still place an image on 
the label. The image, however, will be the standard size set for the label. By 
drawing an image frame, you can indicate how large or small you want the image 
to be. 

3. In the Open dialog box, browse to find the image file that you want to use.

4. In the list of images, click the image you want to use, then click Open. The image 
fills the frame as much as possible while still retaining the original aspect ratio of 
the image. 

Resize Image
Handles around an image indicate that the image is selected and are used to resize 
the image. (If the handles are not shown, click the image to select it.)
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The top and bottom handles resize the image vertically. The left and right handles 
resize the image horizontally. The corner handles resize the image diagonally, 
maintaining the aspect ratio (changing the width and length of the image at the same 
time). To resize:

1. Click the Select button to make it active. When active, it is shaded blue. 

2. Position the pointer on one of the handles.

3. Drag the mouse to enlarge or shrink the image. (Dragging toward the image 
shrinks the image; dragging away from the image enlarges it.)

Move the Image
To move the image to another location:

1. If no handles are visible, click the image to display them.

2. Move the pointer inside the image boundaries (not on a handle). The pointer 
changes to a cross with arrows  when it is in the proper position to move the 
image. 

3. Drag the image to the new location. 

4. To remove the handles from the image, click anywhere on the screen.
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Image Properties
When an image is selected, the following properties are available in the Label & 
Object properties panel. 

Figure 15 • Label & Object properties for images

Property To Use

Locked Click this check box to protect the image object from being 
moved or resized.

Printable This check box is selected by default. If you do not want the 
particular image object to print on the label, clear the 
Printable check box. This prevents the image object from 
printing, although other objects on the label still print.
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Left Indicates the distance the left edge of the image object is 
from the left edge of the label. To change the distance:

1. Double-click the Left field.
2. Enter the distance the left edge of the image object should be 

from the left edge of the label.
OR

3. Click the up or down arrow buttons to increase or decrease the 
indentation.

The distance you are able to move the left edge of the 
boundary box depends on the width of the label part. The 
incremental distance will vary between the different label 
parts.

Top Indicates the distance the top of the image object boundary 
box is from the top of the label. To change the distance:

1. Double-click the Top field.
2. Enter the distance the top edge of the image object should be 

from the top edge of the label.
OR

3. Click the up or down arrow buttons to increase or decrease the 
distance, fractionally.

The distance you are able to move the top edge of the 
boundary box depends on the length (height) of the label part. 
The incremental distance varies between the different label 
parts.

Length Use this field to indicate an exact length (height) of the image. 
This overwrites the aspect ratio maintained by default. 
To change the length:

1. With the image selected, double-click the number currently 
filling the Length field.

2. Enter a new length.

OR
3. Click the up or down arrow buttons to increase or decrease the 

length.

Note: To change the length independent of the width, the 
Allow Stretching check box must be selected. If not, the width 
and length change in the correct proportion to maintain the 
aspect ratio.

Property To Use
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Barcode Objects
Barcodes are generated following industry standard symbology. A typical barcode is 
composed of vertical lines (bars) and spaces of varying thickness, depending on the 
text entered. It can also include “human readable text.” Human readable text is the 
data entered that makes up the barcode. Because you cannot read bars and spaces, 
you can display the actual text that makes up the barcode. 

Barcode objects support vertical resizing (length) only. The width of the barcode is 
based on data and symbology and cannot be changed.

Width Use this field to indicate an exact width of the image. This 
overwrites the aspect ratio maintained by default. 
To change the width:

1. With the image selected, double-click the number currently 
filling the Width field.

2. Enter a new width.
or 

3. Click the up or down arrow buttons to increase or decrease the 
width.

Note: To change the width independent of the length, the 
Allow Stretching check box must be selected. If not, the 
length and width change in the correct proportion to maintain 
the aspect ratio.

Rotation Use this field to rotate an image object between 0° and 360°. 
To rotate the image object:

1. After selecting the image object, double-click the Rotation field 
in the Label & Object properties panel.

2. Enter the degree of rotation.

or

3. Click the up or down arrow buttons to change the degree of 
rotation. (The up arrow rotates clockwise, the down arrow 
rotates counterclockwise.)

Allow Stretching When the Allow Stretching check box is selected, LabelMark 
ignores the aspect ratio and allows separate resizing of the 
width or length. When Allow Stretching is selected, green 
handles display around the entire image, not just the corners. 

Property To Use
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Like any other objects in LabelMark, barcode objects can be positioned, aligned, and 
rotated.

Add a Barcode
To add a barcode to a label:

1. Click the barcode button on the Action toolbar. The pointer cross () for drawing.

2. Drag the mouse over the label that will contain the barcode, drawing a box the 
size of the barcode needed.

When you release the mouse, a preliminary barcode displays with generic data. Use 
the barcode Label & Object properties panel to change the data and the barcode 
parameters. 

Barcode Properties
The following options are displayed in the Label & Object properties panel for 
barcodes:

Note: The barcode properties may vary, depending on the barcode symbology 
(type) used. If a particular symbology does not support certain properties, those 
fields are grayed out.
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Figure 16 • Barcode properties box
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Property To Use

Font Indicates the font for the human readable text. To change the 
font:

1. In the Font field, click the down arrow.
2. Select a font from the list.

Font Size Indicates the size of the selected font for the human readable 
text. To change the font size:

1. In the Font Size field, click the down arrow.
2. Select a size from the drop down list.

OR
3. Double-click the field and enter a point size.

Note: The font type and size affects the height of the barcode. 
The barcode and the human readable text must fit in the zone 
(frame) drawn with the barcode tool. As the size of the human 
readable text increases, it decreases the height of the 
barcode.

Click the Bold button to place the human readable text in bold 

Click the Italics button to place the human readable text in 
italics.

(This button is not available for barcodes.)

(This button is not available for barcodes.)

(This button is not available for barcodes.)
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Locked Select this check box to prevent the barcode object from 
being moved or resized.

Printable This check box is selected by default. If you do not want the 
barcode object to print on the label, clear the Printable check 
box. This prevents the barcode from printing, although other 
objects on the label still print.

Left Indicates the distance the left edge of the barcode object is 
from the left edge of the label. To change the distance:

1. Double-click the Left field.
2. Enter the distance the left edge of the barcode should be from 

the left edge of the label.
or

3. Click the up or down arrow buttons to increase or decrease the 
indentation.

The distance you are able to move the left edge of the 
barcode depends on the width of the label part. The 
incremental distance will vary between the different label 
parts.

Top Indicates the distance the top of the barcode object is from 
the top of the label. To change the distance:

1. Double-click the Top field.
2. Enter the distance the top edge of the barcode should be from 

the top edge of the label.
or

3. Click the up or down arrow buttons to increase or decrease the 
distance.

The distance you are able to move the top edge of the 
barcode depends on the length (height) of the label part. The 
incremental distance varies between the different label parts.

Length Indicates the vertical length of the barcode, from top to bottom. It 
is the same as dragging the top or bottom handle up or down to 
increase or decrease the length. Use this field to indicate an 
exact length of the barcode. To change the length:

1. With the barcode selected, double-click the number currently 
filling the Length field.

2. Enter a new length.
or

3. Click the up or down arrow buttons to increase or decrease length.

Property To Use
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Rotation Use this field to rotate the object between 0° and 360°. To 
rotate the barcode:

1. After selecting the barcode object, double-click the Rotation 
field in the Label & Object properties panel.

2. Enter the degree of rotation.

or

3. Click the up and down arrow buttons to change the degree of 
rotation. (The up arrow rotates clockwise; the down arrow 
rotates counterclockwise.)

Note: Be careful rotating a barcode as it may not fit on the 
printed label. (For example, a 1-inch long barcode may not fit 
rotated on a 3/4-inch high label.) If a rotated barcode will not 
fit on a label, the barcode displays in red.

Value The value is the data used to generate the barcode. Changing 
the data changes the barcode. When placing a barcode on 
the label, a generic value (123) automatically displays. To 
change the value:

1. In the Label & Object properties panel, double-click the Value 
field.

2. Enter the new value. 

Note: You can use the same techniques (highlighting, cursor 
movement, editing) in the Value field as you do in a text 
object. See Select Multiple Characters on page 48 for more 
information.

Density The density refers to the thickness of the bars and spaces 
within a barcode. You can change the density (which in turn 
lengthens or shortens the barcode), but the size of the bars 
and spaces retain the same ratio to each other.
To change the density, with the barcode object selected:

1. In the Label & Object properties panel, click in the Density 
field.

2. Click the up or down arrow buttons to increase or decrease the 
density.

Property To Use
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Line and Rectangle Objects
To place a line or a rectangle on the label:

Barcode Type Barcode types are made up of different symbologies (that is, 
number and thickness of bars and spaces). The type of 
barcode to use depends on industry standards or specific 
need. To change the barcode type:

1. In the Barcode Type field, click the down arrow.
2. Select the appropriate barcode type.

Ratio Indicates the ratio of bar height to symbol length. Not all 
barcode types allow you to change the ratio. If you are using a 
Barcode Type that does not support this option, the Ratio field 
is unavailable. For those that do support it, to change the 
ratio:

1. Click within the Ratio field.
2. Choose a new ratio from the list.

Check Digit A check digit is used for error detection in a barcode. It 
consists of a single digit computed from the other digits in the 
barcode. This field is only available if the selected barcode 
type supports check digits. To change the check digit model to 
use or to remove the check digit:

1. Click in the Check Digit field.
2. Choose the option to use.

Shape Shape is only used with the DataMatrix barcode type. If you 
have chosen DataMatrix in the Barcode Type field, the Shape 
field is available. To change the shape of a DataMatrix 
barcode:

1. Click within the Shape field.
2. Choose the desired shape from the list.

Text Location The Text Location refers to the placement of the human 
readable text relative to the barcode. To change the location, 
or to turn off the human readable text:

1. Click within the Text Location field.
2. Select the option to use.

Property To Use
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1. Click the Line or Rectangle button on the Action toolbar.  

When on the label, the pointer changes to a cross (). 

2. To draw a line, hold the left mouse button and drag the mouse from the starting 
point of the line to the end point.

To draw a square or rectangle, hold the left mouse button and drag diagonally 
from one corner of the rectangle to the opposite corner.

When the mouse is released, the line or rectangle displays with handles. To change 
the properties of the line or rectangle, open the Label objects properties panel (if not 
already displayed).

Resize a Line or Rectangle
To resize a line or rectangle:

1. Click the object to display handles.

2. Position the pointer on one of the handles and drag in the direction that will give 
the desired resizing. 

(Refer to Resize Image on page 60 for more information on resizing graphics.)

Move a Line or Rectangle
To move the line or rectangle to another location:

1. If no handles are visible, click the line or rectangle to display them.

2. With the mouse on the line or inside the rectangle’s boundaries (not on a handle), 
drag the line or rectangle to the new location. The pointer looks like a cross with 
arrows  when it is on the graphic and ready to be moved.

3. To remove the handles from the line or rectangle, click anywhere on the screen.
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Line Properties
The following options are available in the Label & Object properties panel when a line 
is selected. 

Figure 17 • Label & Object properties for lines

Property To Use

Locked Click this check box to protect the line object from being 
moved or resized.

Printable This check box is selected by default. If you do not want the 
particular line object to print on the label, clear the Printable 
check box. This prevents the line object from printing, 
although other objects on the label will still print.
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Rotation Use this field to rotate a line object between 0° and 360°. To 
rotate the line object:

1. After selecting the line, double-click the Rotation field in the 
Label & Object properties panel.

2. Enter the degree of rotation.

or

3. Click the up or down arrow buttons to change the degree of 
rotation. (The up arrow rotates clockwise, the down arrow 
rotates counterclockwise.)

Start Point X Indicates the distance the left edge of horizontal line object 
(handle) is from the left edge of the label. Increasing the size 
of Start Point X is the same as dragging the left handle of the 
line toward the right, thereby shortening the line.
To change Start Point X:

1. Double-click the Start Point X field.
2. Enter the distance the left edge of the line should be from the 

left edge of the label.
or

3. Click the up or down arrow buttons to increase or decrease the 
indentation.

The distance you are able to move the left edge of the line 
depends on the width of the label part. The incremental 
distance will vary between the different label parts.

End Point X Indicates the distance the right edge of the line object 
(handle) is from the right edge of the label. Decreasing the 
size of End Point X is the same as dragging the right handle 
of the line toward the left, thereby shortening the line.
To change End Point X:

1. Double-click the End Point X field.
2. Enter the distance the right edge of the line should be from the 

right edge of the label.
or

3. Click the up or down arrow buttons to increase or decrease the 
distance.

The distance you are able to move the right edge of the line 
depends on the width of the label part. The incremental 
distance will vary between the different label parts.

Property To Use
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Start Point Y Indicates the distance the top edge of a vertical line is from 
the top of the label. Increasing the size of Start Point Y is the 
same as dragging the top handle of the line downward, 
thereby shortening the vertical line.
To change Start Point Y:

1. Double-click the Start Point Y field.
2. Enter the distance the top of the line should be from the top of 

the label.
or 

3. Click the up or down arrow buttons to increase or decrease the 
distance.

The distance you are able to move the top edge of the line 
depends on the length of the label part. The incremental 
distance will vary between the different label parts.

End Point Y Indicates the distance the bottom edge of a vertical line is 
from the bottom of the label. Decreasing the size of End Point 
Y is the same as dragging the bottom handle of the line 
upward, thereby shortening the vertical line. 
To change End Point Y:

1. Double-click the End Point Y field.
2. Enter the distance the bottom of the line should be from the 

bottom of the label.
or 

3. Click the up or down arrow buttons to increase or decrease the 
distance.

The distance you are able to move the bottom of the line 
depends on the length of the label part. The incremental 
distance will vary between the different label parts.

Line Thickness Indicates the weight (thickness) of the line itself. To enter a 
measurement in the Line Thickness field:

1. Double-click the Line Thickness field.

Note: Line thickness is expressed in whole numbers and 
decimals. Highlight (double-click) each portion of the number 
separately in order to change.

2. Enter the desired thickness.
or 

3. Click the up or down arrow buttons to increase or decrease 
thickness.

Property To Use
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Rectangle Properties
The following options are available in the Label & Object properties panel when a 
rectangle is selected.

Figure 18 • Label & Object properties for rectangles

Property To Use

Locked Select this check box to protect the rectangle object from 
being moved or resized.

Printable This check box is selected by default. If you do not want the 
particular rectangle to print on the label, clear the Printable 
check box to remove the checkmark. This prevents the 
rectangle from printing, although other objects on the label 
still print.
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Left Indicates the distance the left edge of the rectangle is from 
the left edge of the label. To change the distance:

1. Double-click the Left field.
2. Enter the distance the left edge of the rectangle should be from 

the left edge of the label.
or

3. Click the up or down arrow buttons to increase or decrease the 
indentation.

The distance you are able to move the left edge of the 
boundary box depends on the width of the label part. The 
incremental distance varies between the different label parts.

Top Indicates the distance the top of the rectangle is from the top 
of the label. To change the distance:

1. Double-click the Top field.
2. Enter the distance the top edge of the rectangle should be from 

the top edge of the label.
or

3. Click the up or down arrow buttons to increase or decrease the 
distance, fractionally.

The distance you are able to move the top edge of the 
rectangle depends on the length (height) of the label part. The 
incremental distance varies between the different label parts.

Length Use this field to indicate an exact length (or height, as 
opposed to width) for the rectangle. To change the length:

1. With the rectangle selected, double-click the number currently 
filling the Length field.

2. Enter a new length.

or
3. Click the up or down arrow buttons to increase or decrease 

length.

Note: To change the length independent of the width, the 
Allow Stretching check box must be selected. If not, the width 
will change automatically in proportion with the changed 
length, maintaining the aspect ratio.

Property To Use
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Linked Objects
Some data (such as serialization, date and time, and data import schemes) and items 
placed on multiple labels using the Command Multiplier are linked to the original data. 
This means that the information is repeated on the other labels maintaining the same 
position and formatting throughout. When you reformat or move the data on one label, 
all labels containing the linked data automatically reflect your changes. If you change 
the data, however, (as opposed to reformatting or moving an object), the link is broken 
for that object. It is no longer linked to the corresponding object on the other labels. 

Width Use this field to indicate an exact width of the rectangle. To 
change the width:

1. With the rectangle selected, double-click the number currently 
filling the Width field.

2. Enter a new width.
or

3. Click the up or down arrow buttons to increase or decrease width.
Note: For a perfect square, the width and length should be the 
same measurement.

Rotation Use this field to rotate a rectangle object between 0° and 
360°. To rotate the rectangle:

1. After selecting the rectangle, double-click the Rotation field in 
the Label & Object properties panel.

2. Enter the degree of rotation.

or

3. Click the up or down arrow buttons to change the degree of 
rotation. (The up arrow rotates clockwise, the down arrow 
rotates counterclockwise.)

Line Thickness To change the thickness of the sides of the rectangle:

1. Double-click the Line Thickness field.
Note: Line thickness is expressed in whole numbers and 
decimals. Highlight (double-click) each portion of the number 
separately in order to change it.

2. Enter the desired thickness.

or

3. Click the up or down arrow buttons to increase or decrease 
thickness.

Property To Use
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Editing Linked Objects
You can change any of the formatting options for a linked object, such as font for a 
text object, or length and width for image objects. You can make the change on any of 
the labels because the changes made to one of the linked objects are applied to all 
labels containing that object. 

To change the properties of linked objects:

1. Select the linked object on one of the labels.

2. In the Label & Object properties panel, make the desired changes. 

Splitting Linked Objects
You can break the link of one or more linked objects on a label thus splitting it off from 
the other labels. When you split the link, it affects only the selected object on the 
individual label. The linked data on the other corresponding labels remains linked and 
continues to move or reformat together.

To split a linked object:

1. Select the object on the specific label that you want to split.

2. Choose Edit > Split Linked Objects, or simply double-click the object to open it 
for editing.

The object split from the other linked objects can now be repositioned or formatted 
individually from its linked counterparts. The linked data objects on the other labels 
are not affected and remain linked to each other. 

Deleting Linked Objects
You can delete specific linked objects on individual labels without affecting the other 
corresponding labels and without splitting the link on the other linked objects. 

To delete linked objects on specific labels:

1. Select the object that you want to delete.

2. Choose Edit > Delete. 

3. A message box opens to determine whether you want to delete all linked objects 
or just that particular object. Do one of the following: 

• To delete all occurrences of the selected linked object on all labels, click Yes.

• To delete only the selected object on the individual label, click No.

• To cancel without deleting any object, click Cancel. 
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Date and Time Object
The date and time object is a combination of a text object with data serialization 
(Chapter 4 Serialization on page 89), where the data is some date or time value. A date 
and time object has all the properties and behavior of a text object, with the exception 
that you cannot edit the date and time by typing. You must use the Date and Time 
Data dialog box to set the date and time.

You can put the date and time on one label or on multiple labels. You can also specify 
if you want to use the computer’s date and time or set a specific date and time. 

Adding the Date and Time
When inserting the date and time, it does not matter which, if any, label is selected. 

To insert the date and time on a label:

1. Choose INSERT > Insert Date/Time data. The Date and Time Data window 
opens. 

2. In the Select format to use section, select or create a format for the date and time.
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• To select an existing format, select Use predefined format. Then click within 
the field to the right and select a format.

• To create your own format:

a. Select Use custom format and then click the Edit button to the right. 
Another window opens for you to set up your custom format.

b. The Format field initially shows the current date in the default format. 
Click Clear All to clear the Format field. As you make your formatting 
choices, the current date and time are displayed here in your customized 
format. Use the Format field to make sure the format is as you expect 
while you are setting it up.
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c. On the Date parts tab, click the buttons that represent the format you want 
for each element of the date. The parts of the date are added in the order 
in which you click them.
Regarding the day of the week, if you select 0-6, the day is represented by 
a number with 0 being Sunday and 6 being Saturday.
To add a character in between components of the date (like the slashes in 
7/12/13), type the character you want to use in the Separator field and 
then click Insert.
To add a space between components, click Space.
At any time if you are not happy with your selection, click Remove Last.

d. On the Time parts tab, click the buttons that represent the format you want 
for each element of the time. The parts of the time are added in the order 
in which you click them. Add separators and spaces in the same manner 
as for the date.

e. When the custom format is complete, click OK. The software returns to 
the first Date and Time Data window.

3. In the Date/Time value section, set the value for the date.

• To use a date value that updates from the computer’s clock, select Use 
computer date/time value. Whenever you want the label to reflect the 
current date and time (such as when printing), select Tools > Refresh > 
Refresh Date/Time data. 

• To set a specific date and time:

a. Select Use this value.

b. In the date box to the right, type the date you want to use or click the 
calendar button to select a date. (See Using the Calendar Icon on page 82 
for instructions.) The day of the week automatically changes according to 
the date entered.

c. In the time box, either click the single down arrow button to select a time 
from a list or edit the time directly in the time display. Click on any part of 
the time (hours, minutes, and so on depending on the time format you 
selected) and either type a new value or use the up and down arrows to 
change the value. 

4. In the Start at label number field, enter the number of the label on which to begin 
using this date and time object.

5. In the Number of times to repeat field, enter the total number of labels on which 
the date and time should be placed. This includes the starting label.
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6. Click in the Apply to field and select an option controlling whether the date and 
time should be placed on every label or if some labels should be skipped. 

The Date/time will be applied to label(s) field lists the labels that will have the 
date and time once your changes are applied. If this is not correct, adjust your 
settings in the Select labels to apply this date/time to section. 

7. When finished, click OK.

The date and time object is placed in the upper left corner of the specified labels. If 
you want the object to display at some other area on the label, select the object on 
one of the labels (it makes no difference which object is selected) and move the object 
to the area where you want it to display. The object is moved to the same location on 
all the labels to which it is applied.

You can add more than one date and time object to a label. Because each new object 
is placed in the upper left, be sure to move the objects to different locations on the 
label.

Two-sided Labels

To display the date and time on both sides of a two-sided label:

1. Choose Edit > Duplicate data on second side. This duplicates all data from side 
one onto side two, not just the date and time. 

Using the Calendar Icon

When setting up a date and time object, you have the option of using a calendar to 
select the date. (See Adding the Date and Time starting on page 79.)

1. In the Use this value field, click the calendar icon (to the right of the date).

2. Click the arrows to the right or left of the month in the title bar to move forward or 
backward through the months.

3. To navigate more quickly, click the calendar title bar twice. The calendar changes 
to show 12 years. 
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4. Select the desired year, using the arrows to scroll if needed. Once the year has 
been selected, the calendar displays all the months in the year. 

5. Click the desired month. The calendar changes to display the days of that month. 
Click the desired day. 

Format a Date and Time Object
To change the look of a date and time object (text size, bold, alignment, and so on):

1. Click the date and time object on one of the labels.

2. In the Label & Object properties panel, make the formatting changes.

The date and time text on all the labels takes on the new formats.

Updating the Date and Time
Date and time objects set to use the computer’s settings can be updated to show the 
current date manually or automatically when the file is opened or printed.

To manually refresh the date and time select Tools > Refresh > Refresh Date/Time 
data. 

To automatically refresh the date and time, open the Options tab (see Setting Options 
on page 9) and click Data refresh. Under Date/Time refresh options, select one of the 
following:

• Refresh when file opened

• Refresh when file printed

Edit a Date and Time Object
To change the date and time format of an existing object (which components to use, 
separators, and so on):

1. Right-click a date and time object and select Edit Date/Time data. 
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2. Change the settings as described in Adding the Date and Time starting on page 79.

Remove a Date and Time Object
To remove a date and time object:

1. Click the date and time on one of the labels.

2. Click the Delete button. 

3. Follow the instructions on the message box to delete one or all of the labels.

Check Label Errors
When designing labels, LabelMark automatically checks for layout errors, allowing 
you to edit the information before printing the labels. Such an error can occur when, 
for example, you import labels from a file with larger labels to a file with smaller labels. 
Some of the existing label contents may be outside the printable area of the label. 
Errors are displayed in the Errors & Information pane, which is always available at the 
bottom of the workspace. 

Errors & Information Pane
To display the Errors & Information pane, click ERRORS & INFORMATION at the 
bottom of the workspace area. Click ERRORS & INFORMATION again to minimize it. 

Figure 19 • Errors and Information pane

Checking the Labels for Errors
To check the labels for errors: 
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1. In the Errors & Information pane click Check Label Errors. (As a shortcut, press 
F7 on the keyboard.)

The LabelMark software determines which labels have errors and lists the errors 
in the Errors & Information pane. 

If the list is too long to fit in the pane, either drag the top of the pane to resize it or 
use the arrows to scroll through the list. 

2. Fix the errors using one or a combination of the following methods:

• Click the Fix Errors button. The software fixes all the errors that it is able to. 

• On any error in the list, click Auto Fit. The software adjusts the object to fit on 
the label. It is a good idea to look at these labels to make sure the adjustments 
are to your liking. 

• On any error in the list, click Go To. The software selects the label on which 
the error occurs. Manually adjust objects to fit on the label (most likely by 
moving or resizing). 

As errors are corrected, they are removed from the list.

Changing Label Parts
You can change the label part (type of label material) after data has already been 
entered. Be aware, though, that some data may not fit the new label part. If this is the 
case, a message indicates that the data objects may need to be fixed on the new label 
part.

To change the label part:

1. Choose Edit > Change Label Part.

2. From the list provided, select the label part to use and then click OK.

3. If the data objects do not fit properly on the new label part, a message alerts you 
and asks if you want to continue. Click Yes. 

4. A message alerts you that the software can check for errors. Click Yes.



Formatting a Label
Wiremark Format

86

LabelMark 6.0 User’s Manual

5. Errors are listed in the Errors & Information pane. For help correcting the errors 
see Checking the Labels for Errors on page 84.

Note: If, after changing a label part, you find the data does not fit on the new label 
even after reformatting the data, click Undo to go back to the previous label part. 
You may have to click Undo a few times to return to the previous label part.

Adjusting Label Length (Height)
If you are using continuous material, you can change the part length (you may think of 
it as height). Exceptions to this are Datacomm and Terminal Blocks labels. These 
labels are created through an app and use a different mechanism for adjusting the 
label dimensions. (For more information on apps, see Chapter 14 Apps on page 167.)

To change the part length:

1. Open the File & Part properties panel. (See Properties Panels on page 44.)

2. Under the Part Properties heading edit the Length field. The changes occur at 
once.

Wiremark Format
Use the wiremark format to repeat text lines down the label, filling the label so that the 
text can be easily read when the label is wrapped around a wire. Wiremark is 
available in line mode (text labels) only. When the wiremark function is turn on, the 
label divides, displaying a blue border around the original text being entered (top line) 
and a red dotted line around the duplicate text. The text duplicates as you enter it. 

If the label is large enough or the font is small enough, you can get multiple rows of 
repeated data. The data is repeated on the label as you enter it. 
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To use wiremark format:

1. Click the gear icon in the upper right to open the Options tab. 

2. Click Format Options.

3. Select Wiremark labels in line mode by default.

4. Click the Save button in the Options tab.

5. Create a new label making sure to select line mode. (See Step 1: Create a Label 
File starting on page 11.)

6. Enter text on the label. If you only get one row of text, decrease the font size. The 
software can only repeat data if there is enough room on the label.

Tip: While working on an existing label, select Format > Wiremark to turn Wiremark 
on for the selected label. Wiremark text duplication is only applied to the selected 
label; it does not affect existing text.

Turn Off Wiremark
To turn off wiremark text duplication within a label file:

1. Select the label where you want the wiremark function turned off. 

2. Select Format > Wiremark. Text duplication is turned off for the selected label 
and for any following blank labels. 
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4 Serialization
Serialization (or sequencing) automatically adds a series of sequential numbers or 
letters to the labels. The labels created in the series are sequentially annotated with 
the next number or letter in the defined sequence.

How Serialization Works
Serialization is an alphanumeric series, with numbers from 0 to 9, and letters A-Z. 
Serialization can be basic (one series) or advanced (multiple series), with no limit on 
the number of sequences per label. 

Note: You can incorporate serialized data into a barcode. See Inserting Basic 
Serialization starting on page 91.

Serialization consists of a Start value, End value, and a Step value. The Start value is 
the number, letter, or combination of numbers and letters that begin the serialization 
sequence. The End value is the termination point of the sequence. 

The Step is the value that is added to the previous number in the sequence to 
produce the next sequence number. (You cannot have an increment value of 0.) For 
instance, a start value of 1, an end value of 25, and a step value of 4 would produce 1, 
5, 9, 13, 17, 21, 25 (that is, 1 + step value 4 = 5; 5 + step value 4 = 9, and so on.)

Examples of Serialization
In a basic serialization, a sequence runs through its full range of numbers or letters (0 
to 9, or A to Z), one number or letter for each label. 

Example: Basic serialization: 
Sequence #1
Start Value: 1
End Value: 10
Increment: 1
Produces: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10

You can combine letters and numbers in a single serialization. When the right-most 
character in the Start Value reaches its maximum value (9 or Z), the character 
immediately to the left is incremented, and the right character cycles back to its 
minimum value (0 or A).  

Example: Alphanumeric serialization: 
Sequence #1



Serialization
How Serialization Works

90

LabelMark 6.0 User’s Manual

Start Value: A1
End Value: D4
Increment:
Produces: A1…A9, AA...AZ, B0...B9, BA...BZ, 
C0...C9, CA...CZ, D0...D4

In an advanced (multi-sequence) serialization, where the second set of values is NOT 
dependent on the first set, (that is, the second set of values is set to Priority = 0), the 
two sequences increment sequentially, independent of each other. (Priority is 
described in more detail in step 10 on page 95.)

Example: Multiple independent serialization (where the second set of 
values is not dependent on the first set of values): 

In an advanced serialization where the second set of values is dependent on the first 
set (that is, the second set of values is set to Priority = 2), the second sequence holds 
its initial value until the first sequence completes, after which it moves to the next 
value. 

Example: Multiple dependent serialization: 

Serialization starts with the selected label in the label file and can be applied to as 
many labels as needed. The serialization number or characters are placed at the top, 
left corner of the label. Once the serialization is completed, you can move the 
serialized numbers and characters anywhere on the label. Because serialized 
sequences are linked objects, as you move the data on one label, it moves to the 
same location on all subsequent labels where it displays. 

You can add more than one serialized sequence to a label but each sequence 
displays in the upper left corner of the label, just like the first. If you have not moved 
the first sequence, the second displays directly over it. Move this sequence to a new 
location on the label. 

Sequence #1 Sequence #2

Start Value: 1 Start Value: A

End Value: 10 End Value:  C

Increment: 1 Increment: 1

Produces: 1A, 2B, 3C, 4A, 5B, 6C, 7A, 8B, 9C, 10A, 1B, 
2C, 3A, 4B, 5C … 

Sequence #1 Sequence #2

Start Value: 1 Start Value: A

End Value: 10 End Value: C

Increment: 1 Increment: 1

Produces: 1A..10A, 1B..10B, 1C..10C
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Inserting Basic Serialization
To add basic serialization to the label:

1. Choose INSERT > Insert serialized data.... The Data Serialization - Basic 
window opens. 

2. Click in the Sequence Type field and select the desired sequence type. 

3. In the Start field, enter the alpha or numeric character with which you want to start 
the serialization. If using a custom sequence, enter the first character of the 
custom text in the Start field. 

Numeric Numbers only

Alphabetic Upper case letters only

Alphanumeric Letters and numbers

Hex Base 16 numbers

Octal Base 8 numbers

Binary Base 2 numbers

Constant Only one value (Start value) is entered on all 

Custom Your own text or string of letters. 
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4. In the End field, enter the value on which the serialization should stop. (If the total 
has not yet been reached, the sequence repeats again.) If using a custom 
sequence, enter the last character of the custom text in the End field.

5. The Total field automatically reflects the number of labels that will be produced 
based on the Start and End values (and the default Step value of 1). If you wish to 
produce more labels (beginning the series again at the Start value), or fewer 
labels (stopping before the End value), enter the desired number of labels in the 
Total field, replacing the calculated total.

6. If Custom is selected as the Sequence Type, in the Custom Text field enter the 
full text that you want to use for the serialization. 

Example: Custom Text = Brady. When serializing, the B would 
display on one label, the r on the next label, the a on the 
next, and so on. The Start value would be B and the End 
value would be y. 

7. In the Step field, enter the number by which the serialization should increment.

Example: A numeric sequence beginning with 1, with a step of 1 
yields: 1, 2, 3, 4, 5, … .
A numeric sequence beginning with 1, with a step of 2 
yields: 1, 3, 5, 7, 9, … .

8. Under Label Object, select Barcode if you want the serialized data to be 
displayed as a barcode, otherwise select Text.

9. If you want to add unchanging text before or after the serialized data, enter the 
text in either the Prefix (for text displaying before the serialized data) or Suffix (for 
text displaying after the serialized data) field. 

10. The Preview field displays the results for the first few members of the series. Use 
this field to determine whether your settings produce the desired results.

11. When finished, click Next. The Data Placement page opens. 

12. In the Repeat Serialized Objects field, enter the number of times to repeat each 
value in the sequence before moving on to the next one. For most purposes this is 
set to 1. One example of when you might use this is when printing to a label part 
that has columns, such as DAT-77 with three columns. Perhaps you want the 
same serialized data on all labels in a row. Set Repeat Serialized Objects to 3 and 
the serialized data will be the same for each of the three labels in a row and will 
increment in the next row. 

13. In the Apply to Labels section, select the appropriate option to indicate on which 
labels to place the serialized data. The example shows the results of your 
selection. 

14. Use the Place Data section if your label part has multiple columns. Select the 
direction you want the serialization applied to the labels: 
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• Over, then down: across each row from top to bottom. 

• Down, then over: down each column from left to right. Further refine this 
method of data placement by setting the number of Vertical labels down to 
go before moving over to the next column. Down, then over with Vertical 
labels down set to 1 is the same as Over, then down. 

15. (Available with two-sided label parts only.) Select Duplicate data on second side 
if you want the serialized data to repeat on the other side of the label.

16. Either finish or save the serialization scheme. 

• To complete the setup and put the serialized data on the labels, click Finish 
and skip to the end of these steps.

• To save the serialization scheme, click Next and continue with the following 
steps.

17. On the Save Scheme Information page, provide the following information. 

• Scheme file name: A default file name is provided. Type a new name if 
desired. Serialization schemes are saved in the default directory designated 
in the File Paths option. (See Setting Options on page 9.)

• Author: The user name of the person logged in to the computer is provided. 
Change this if desired. 

• Comment: Enter any comments if desired.

18. Click Finish.

The serialized data displays in the top left corner of the sequenced labels. Because 
serialized sequences are linked objects, you can move or reformat one value to edit 
all of them. 

Over, then down Down, then over
Vertical labels down = 4

Down, then over
Vertical labels down = 2
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Inserting Advanced Serialization
Advanced serialization involves multiple sequences, with the ability to set how each 
serialization scheme advances the sequencing. To set up an advanced serialization 
scheme:

1. Choose INSERT > Insert serialized data... . The Data Serialization - Basic 
window opens.

2. Set up your first sequence as described in Inserting Basic Serialization starting on 
page 91

3. Select Use Multiple Counter Sequences (Advanced) at the bottom of the 
window. The window changes to the Data Serialization - Advanced window. 

A table displays your first sequence in the composite serialization. To add the next 
component:

4. Click the Add button to the right of the table to add the next sequence. A new row 
is added to the table.

5. Double-click the Sequence Type field in the new row and select the type of 
sequence.

6. If you set the Sequence Type to Custom, click in the Custom Text field and type 
the full text that you want to use for this sequence. 

7. Double-click the Start field and enter the starting value. 
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8. Double-click the End field and enter the ending value. 

9. Double-click the Step field and set the amount to increment each member of the 
sequence.

10. Double-click the Priority field and set the priority for this sequence. Priority 
determines in what order the different sequences increment.

• 0: A sequence assigned the priority of 0 increments independently from other 
sequences.

• 1: A sequence assigned the priority of 1 increments first, progressing through 
the entire sequence before other sequences begin to increment.

• 2: A sequence assigned the priority of 2 does not start incrementing until the 
priority 1 sequence reaches its end value.

• Priority # (Where # represents any other sequential number). A sequence 
assigned this priority does not start incrementing until all sequences with 
lower priorities reach their end values.

11. Repeat step 4 through step 10 above for each sequence you want to add.

12. (Only available on graphic mode labels.) Under Label Object, select Barcode if 
you want the serialized data to be displayed as a barcode, otherwise select Text. 
For a barcode, click the field below and select the type of barcode to create. This 
applies to the composite of all sequences in the serialization scheme, not just the 
sequence row highlighted in the table. 

13. If you want to add unchanging text before or after the serialized data, enter the 
text in either the Prefix (for text displaying before the serialized data) or Suffix (for 
text displaying after the serialized data) field. This applies to the composite of all 
sequences in the serialization scheme, not just the sequence row highlighted in 
the table. 

14. The Total field automatically reflects the number of labels that will be produced 
based on your selections. Change the total if desired.

15. The Preview field displays the results for the first few members of the composite 
series. Use this field to determine whether your settings produce the desired 
results.

16. Click Next. The Data Placement window opens. 

17. Fill in the Data Placement window as described in the instructions for a basic 
serialization, steps 12 through 15 on page 92. 

18. Click Next. The Save Scheme Information window opens. 

19. On the Save Scheme Information page, complete the following. 

• Save scheme after finish: Select this check box to save the scheme for later 
use so you do not have to re-enter the data the next time you want to use this 
serialization. 
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• Scheme file name: A default file name is provided. Type a new name if 
desired. Serialization schemes are saved in the default directory designated 
in the File Paths option. (See Setting Options on page 9.)

• Author: The user name of the person logged in to the computer is provided. 
Change this if desired. 

• Comment: Enter any comments if desired.

20. Click Finish. 

The serialized data displays in the top left corner of the sequenced labels. Because 
serialized sequences are linked objects, you can move or reformat one value to edit 
all of them. 

Edit Components of an Advanced Serialization
You can edit the component sequences (start value, step value, and so on) directly in 
the table. As you edit the sequences, the Preview field displays the changes to the 
serialization. 

To edit components of an existing advanced serialization:

1. Right-click the serialized data object on any label and select Edit serialized data. 
The Data Serialization - Advanced window opens. 

2. Double-click the component field you want to edit.

3. Enter the new value.

Rearrange Components

The serialized data displays in the order in which you set up the components. For 
instance, if the first component is a numeric string and the second component an 
alpha string, the serialized data will display as 1A. To have the data display as A1, 
change the order of the components. To change the order of components:

1. In the table, click the row of the component to move.

2. Depending on where the component is in the table, click Up or Down to move the 
component to the intended position.

The Preview field displays the result of the new order.

Remove Components

To remove a sequence component from the composite serialization:

1. In the table, click the component row to be removed. 
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2. Click Remove.

Remove Serialization
Serialization is a linked object, which means what you do to one of the sequences 
applies to all. Only one sequence must be selected to affect all sequences in the 
serialization. To remove serialization from labels:

1. Click the serialized object on one of the labels.

2. Press the Delete key on the keyboard.

3. A message box opens to determine whether you want to delete all linked objects 
or just that particular object. Do one of the following: 

• To delete all occurrences of the selected linked object on all labels, click Yes.

• To delete only the selected object on the individual label, click No.

• To cancel without deleting any object, click Cancel. 

The serialization is removed.

Moving Serialized Data
To move the serialized characters to some other location on the label:

1. Click the serialized characters on one of the labels to display handles. It makes no 
difference on which label you select the characters.

2. Drag the serialized characters to another location on the label. 

All labels with the serialized characters display the characters at the new location on 
their respective label.

Formatting Serialized Data
With the serialized object selected, use the Label objects properties panel to change 
the format properties. (See Text Object Properties starting on page 51 for details on the 
properties.) 



Serialization
Using a Saved Serialization Scheme

98

LabelMark 6.0 User’s Manual

Using a Saved Serialization Scheme
To use a saved scheme:

1. Click the label where you want the serialization to start.

2. Choose INSERT > Data from saved scheme. A window for selecting the scheme 
opens. 

3. In the list of Data Serialization Schemes, click the scheme to use. The right side of 
the window shows the settings for that scheme so you can verify that you have 
selected the scheme you want. 

4. Click Finish. The serialized data is added to the selected label and to following 
labels as specified by the scheme.

Note: For information about managing saved schemes (to edit, delete, copy, and 
more) see Chapter 12 Manage Saved Data Import and Serialization Schemes 
on page 155.
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5 Job File Management
Job files are only available with LabelMark Professional. 

A job file is a collection of related label files. It provides an efficient use of time when 
printing big or repetitive jobs. The label files in a job file can be directed to different 
printers, allowing you to dedicate printers to use specific label media or ribbon colors. 
This eliminates the need to constantly change parts or run the risk of having the 
wrong media or ribbon installed.

Creating a Job File
To create a new job file:

1. On the Home tab, click the Create tile, and select New Job. 

Adding Label Files
To add label files to the Job file:

1. Click the Add Label Files button. 

2. In the Open dialog box, select the files to add using standard Windows browse 
functions to access different directories. Use Ctrl-Click or Shift-Click to select 
more than one file at a time.
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3. Click Open. The files are added to the job file tab displayed in the Workspace. 

Job File Information
To add job file information:

1. On the Job info tab at the bottom of the LabelMark window, fill in the Author and 
Description fields. This information pertains to the job file, not to the individual 
label files. Your changes are saved when you save the job file. 

To view or edit label file information:

1. In the list of files, click the label file for which you want to view file properties or 
edit the author and description. A preview of the label file is shown in the Preview 
panel. 

2. In the Preview panel, click Open in Editor. The label file opens in another tab. 

3. Click the label file’s tab to go to the label file. 

4. Open the File & Part properties panel. For more information see File and Part 
Properties on page 28. 
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Saving a Job File
To save the job file:

1. On the tab for the job file, click the Save button in the toolbar. 

2. (Optional) Job files are saved by default on the local disk in 
ProgramData\Brady\LabelMark6\Job Files. If you want to save the job file in a 
different location, use the Save As window to navigate to that location. 

Tip: You can change the default job file location in Options in the File paths tab. 
See Setting Options on page 9. 

3. In the File name field, enter a name for the job file.

4. Click Save.

Opening a Job File
Open a job file in much the same way you open a label file.

1. On the Home tab, click the Open tile and select Job. 

2. In the Open dialog box, select the job file to open and click Open.

Removing a Label File
To remove a label file from a job file:

1. Open the job file. 

2. Click the label file you want to remove.

3. Click the Remove button in the job file toolbar. 

Alternatively, to remove all label files from the job file click the down arrow on the 
Remove button and select Remove All.

The label file is immediately removed from the job file.



Job File Management
Printing Labels in a Job File

102

LabelMark 6.0 User’s Manual

Printing Labels in a Job File
From the job file you can print one label file or all label files. Each label file in the job 
file can be sent to a different printer, if desired. To print from the job file, first select a 
printer for each label file. Then set the print options for each, and then print the labels. 

Selecting a Printer
To print everything to the default printer set in Options, select the Use Default Print 
Settings check box. 

To select a different printer for each label file:

1. Clear the Use Default Print Settings check box. The display changes to a table 
showing the printer, label part, and other settings for each label file. 

2. For each label file, click the Select a printer field in the Printer column. Select a 
printer from the list. 

Editing Print Options
If you have selected Use Default Print Settings in the job file tab, skip this section. 

To change the number of copies, the side of the label file to print, or to adjust the 
margins: 

1. Make sure the Use Default Print Settings check box is cleared. 

2. Select the label file for which you want to edit print settings.
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3. Click the Edit Print Option button.  

A window opens with the settings. 

4. In the Copies section, use one of the following methods to select the number of 
copies.

• Select File label copies to print the number of copies specified for each label 
within the label file. See Label Copies on page 16 for more information. You do 
not have to indicate the number of copies on this screen.

• Select Copies to specify the number of copies here. This overrides the 
settings for each label within the label file. 

5. In the Printer Position Adjustment field, adjust the horizontal or vertical print 
position offsets (data alignment on a label). The measurement is in inches or 
millimeters, depending on which unit of measure you have chosen on the 
Options tab under General Options. (See Setting Options on page 9.)

6. In the Side to Print section, choose which side to print, Side 1, Side 2, or Both. 
This section is only available if the label part for this file allows two-sided printing.

7. In the Second Side section, chose the print direction. 

• Select Standard to print side two upside down. This causes the text on both 
sides of a two-sided sleeve to be upright when viewed from either side of the 
sleeve.

• Select Reverse to print side two right-side up. This causes the text on the 
sleeve to be readable if the sleeve is rotated on its horizontal axis to view the 
second side. 

This section is only available if the label part allows two-sided printing and if either 
Side 2 or Both is selected in the Side to Print section. 

8. Click OK.
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Printing from a Job File
You can print one label file at a time, but the real power of the job file is to print 
simultaneously on different printers, possibly with different label parts and colors. 

To print one label file contained in a Job File:

1. Click the label file to print. (You can use Ctrl-Click or Shift-Click to select more 
than one file.)

2. Click the Print button in the toolbar. 

If you want to print all label files in a job file:

1. Click the Print All button above the list of labels. Labels print to the printer or 
printers specified in Selecting a Printer on page 102.

Moving Label Files in a Job File
The order of label files in the job file affects the print order of the files if more than one 
file uses the same printer or if the default printer is used for all files. For more 
information see Selecting a Printer on page 102.

To move a label file up or down in the job file list:

1. Click the label file to move.

2. Click the Move Up or Move Down buttons in the toolbar to move the selected file 
up or down in the list one row at a time. 

Closing a Job File
To close a job file, do one of the following: 

• Click the x next to the file name on the job file tab.

• Right-click the file name in the job file tab and select Close, Close All, or Close 
All But This. 
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Managing Job Files
Use Manage Jobs to display all your job files at one time. 

1. From the Home tab, click the Manage tile and select Jobs. The Jobs tab opens 
with the default location for job files selected. 

2. If you have job files in a different location, use the directory list to navigate to the 
location of your stored job files. 

When you select the directory, all job files in that directory display to the right. 

3. Click a job file to select it.

4. Use the buttons in the Actions column on the right to perform any of the following 
tasks: 

• Create a new job file. Click New Job. The new job file opens in another tab. 

• Edit a job file. Select the job file and then click Edit Job. The file opens in 
another tab. 

• Print all labels in a job file. Select the job file and then click Print. (If one of the 
label files in the job file does not have a printer assigned, a message informs 
you of the situation. If you choose to continue, the software prints the labels 
that have assigned printers and skips the rest.)

• Print all labels in all job files. Click Print All. 

• Add to a list of favorites. Select the job file and then click Add To Favorites. 
See Favorite Job Files on page 106. 

• Delete a job file. Select the job file and click Remove. The job file is deleted 
but the labels files are retained. 

• Delete all job files. Click Remove All. 

• Refresh the list of job files. Click Refresh. 
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Preview Label Files Contained in a Job File
To preview a list of label files contained in a Job file before opening the Job file, hover 
the pointer over a job file. A pop-up displays the names of the label files in the job file. 
If the full list cannot be displayed, the bottom of the pop-up indicates how many label 
files are in the job file. 

Favorite Job Files
If there are a number of job files that you use often, add them to a Favorites list for 
easy access. 

Adding to Favorites

To add job files to Favorites:

1. From the Home tab, click the Manage tile and select Jobs (if the Jobs tab is not 
already open). 

2. Select the job file you want to add to Favorites. You can use Ctrl-Click or Shift-
Click to select multiple job files. 

3. Click Add To Favorites.

Viewing Favorite Job Files

To view the job files placed in Favorites:

1. In the Find Job Files column on the left side of the Jobs tab, click Favorites.
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Searching for Job Files
If you have many job files stored in different directories, it may be difficult to locate all 
of them. Use the Search feature in the Jobs tab to locate the different job files. 

To search for job files:

1. From the Home tab, click the Manage tile and select Jobs (if the Jobs tab is not 
already open). 

2. Under Find Job Files on the left side of the Jobs tab, click Search. The search 
screen opens providing several criteria on which you can search. 

3. In the grey bar at the top of the search area select one of the following: 

• Match all criteria. Choose this if you want the search to find jobs for which all 
of the criteria are true.

• Match any criteria. Choose this if you want to find jobs for which any (but not 
necessarily all) of the criteria are true. 

4. The Search Location area displays the default folder for job files. If you want to 

search elsewhere, click the Browse button to specify a different folder. 

Note: If you are not sure exactly where something is located, select a directory at 
or near the top of the tree hierarchy. With the Search subfolders check box 
selected, the software searches down through the subdirectories to find the file.

5. Select the check box for each search criterion that you want to use: 

• Search by job file name. Use this option if you know the job file name or part 
of it. Type either the full file name or part of the name using wildcard 
characters to represent the missing parts. Use an asterisk (*) to represent 
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multiple characters or a question mark (?) to represent one character. For 
example, searching for ?ire* would find: tire plant and wire markers. 
The ? stands in for the t or w. The * stands in for all the remaining characters. 

• Search by label file in a job file. Use this option if you want to find a job file 
that contains a label file that uses a particular printer, has a particular file 
name, or uses a particular label part. Select either Printer, File Name, or Part 
and then use the adjoining field to provide the information. 

• Search by date created or modified. Use this option if you want to find a job 
file that was created or last updated within a certain time frame. In the From 
and To fields enter the date range you want to search within. You can either 
type the date (in mm/dd/yyyy format) or click the calendar icon to select the 
date. For help using the calendar see Using the Calendar Icon on page 82.

6. When all the desired criteria have been supplied, click the Search button.

The job files matching your specifications display below the Search screen.
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6 Managing Parts
LabelMark software provides three parts lists: Master, Custom, and Favorites. The 
Master list contains all parts. This chapter discusses the Custom and Favorites parts 
lists.

Managing Custom Parts
Custom parts are user-defined label parts. These parts can be based on factory-
created stock parts or completely original, defined by the user. A wrench icon marks 
custom parts in the parts list. 

Creating a Custom Part
To create a custom part:

1. From the Home tab, click the Manage tile and select Custom Parts. The Custom 
parts tab opens. 

2. Click the Add New button. 

3. In the Add New Custom Part window, choose what to start with. Select either 
Select existing part or Create from empty. 

4. If you chose Select existing part, find the part that is closest to what you need and 
click it. For help with the Search and Filter features see Finding a Part in the List on 
page 13.

If you chose Create from empty, go to the next step. 

5. Click OK. The new part is opened in the Custom parts tab. 

6. Use the tabs in the right pane to configure the label part. See the following 
sections. 

• General on page 110

• Measurements on page 111

• Zones on page 112
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General

Use the General tab to name the part, define printer compatibility, set the type of label 
and type of sensor, and provide a description. (For information on how to get to this 
tab, see Creating a Custom Part on page 109.)

1. On the General tab, in the Part Name field, highlight the supplied name, then 
enter a unique name for your custom part. 

2. The Printer Compatibility field select the printers to associate with this custom 
label part. If you started with an existing part, printers associated with that label 
part are already selected. 

3. Click in the Part Family field and select the label type for your custom label.

4. Click in the Sensor Type field and indicate how the printer will determine the top 
of the label, that is, where one label ends and the next begins. 

• Continuous. Use with label stock that is a continuous roll with no 
demarcation where labels begin and end. The printer cannot sense the 
beginning or end of a label because the material is continuous and can be 
used to print items of varying lengths.

• Gap. Use with a die-cut label stock that is opaque. Printers sense the gap 
between the labels to determine the top of each label. 

• Notch. Use with die-cut label stock that is clear or that has a clear portion. 
Printers sense a small notch in the label stock to determine the top of the 
label. (Notch can also be used to demarcate a set of opaque labels, although 
this is a much less common use.)

• None.  
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5. (Optional) In the Description field, enter a brief description of the custom label. 

6. Select or clear the Part is double sided check box accordingly.

Measurements

Use the Measurements tab to format linear dimensions such as width and length as 
well as number of columns, margins, and so on. (For information on how to get to this 
tab, see Creating a Custom Part on page 109.)

1. Click the Measurements tab and set the following dimensions. For all numeric 
entries you can either type a value or use the up and down arrows to select a 
value. 

• Width. Sets the width of a label (from left to right).

• Length. Sets the length of a label (from top to bottom).

• Liner Width. Sets the width of the backing material that the labels come on. 
The liner width must be greater than the sum of all widths: Width, Left Margin, 
and Horizontal Gap.

• Left Margin. The distance between the left edge of the label and the printable 
area of the label. 

• Top Margin. The distance between the top edge of the label and the printable 
area of the label. 

• Columns. The printable area can be split into columns. Increase or decrease 
the number of columns. 

• Rows. The printable area can be split into rows. Increase or decrease the 
number of rows.

• Vertical Gap. The space between rows. (For one-row parts, the space 
between labels.)

• Horizontal Gap. The space between columns. (Applies only to multi-column 
parts.)

• Output Orientation. Select Portrait to print the label so that it is taller than it is 
wide. Select Landscape to print the label so it is wider than it is tall. 

• Rotation. Rotates objects on the label the number of degrees specified. 
Rotation is clockwise. You can use negative numbers to indicate 
counterclockwise rotation. For example, -45° is the same as 315°.
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Alternatively, you can use the representation of the label part to provide most of these 
settings. Click on different parts of the image to display green arrows that you can 
drag to change the settings. Use the buttons to add or remove rows. 

Zones

Use the Zones tab to divide a label into sub-regions. Zones are used for two 
purposes:

• To define the label layout.

• To customize the label part by defining additional printable or non-printable areas.

For information on how to get to this tab, see Creating a Custom Part on page 109.

To add a zone to a custom part:

1. Click the Zones tab.

2. Click the Add Zone button. The zone is displayed below the zone settings in the 
representation of the label part. Initially the zone is placed over the whole label. 
Use the green arrows for the Width and Height fields to size the zone. 
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The following image shows two zones one of which is in the shape of a circle and 
is offset from its initial position. 

3. To select a zone to edit, either select it in the Zone Number list or click it in the 
graphic representation of the label. 

4. For each zone you add, configure the following fields. (Measurements are in 
inches or millimeters depending on what you specified in General Options. See 
Setting Options on page 9). 

• Zone Type. Select whether the zone is printable or non-printable. A non-
printable zone could be used where a preprinted item displays on the label to 
prevent printing over it. Also, if data added to the label begins to encroach in 
the non-printable area, the Check Errors feature will indicate that the data 
does not fit.

• Zone Shape. Select Rectangle, Circle, or Rounded rectangle. If you 
choose Rounded rectangle, use the Corner Radius field to adjust the 
roundness of the corners. 

• X Offset. Adjust the position of the zone horizontally. A negative number 
moves the zone left and a positive number moves the zone right. 

• Y Offset. Adjust the position of the zone vertically. A negative number moves 
the zone up and a positive number moves the zone down. 
To set the X and Y Offsets visually, click in the center of a zone in the graphic 
representation and drag the zone where you want to place it.

• Width and Height. Adjust the width and height of the zone. To set the width 
and height visually, drag the green arrows in the graphic representation of the 
label.
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• Corner Radius. Adjust the roundness of the zone’s corners if the shape is set 
to Rounded rectangle. 

5. If zones overlap, you can move them in front or behind each other by clicking 
Move Zone to Front or Send Zone to Back. (See Overlapping Objects on 
page 37.) 

When zones are moved in front or behind each other, the zone order in the Zone 
Number list changes. The zone in front displays at the bottom of the Zone Number 
list. The zone in back displays at the top of the Zone Number list.

6. When finished, click the Save button. This saves all custom parts, not just the one 
you are currently editing. 

Delete a Zone

To remove a zone from a custom part:

1. Click the Zone tab on the Custom Parts screen.

2. Select the zone you want to remove. (Click the zone in either the Zone Number 
field or the graphic representation of the label.)

3. Click Delete Zone.

Export Custom Parts
To share your custom part with others, you must export it. 

To export a custom part:

1. On the Custom Parts screen, select the custom part you want to export.

2. Click the Export button. 

3. Use the Save As window to find your organization’s designated directory for 
shared custom parts. (See Setting Options on page 9.)

4. In the File name field type a file name for the custom part. It will be saved as an 
XML file. Do not change the Save as type setting. 

5. Click Save. 

The Custom part is now available for other users to import.

Import Custom Parts
To use a custom part created by other users, you must import it. 
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To Import a custom part:

1. On the Home tab, click the Manage tile and select Custom Parts.

2. Click the Import button. 

3. Use the Open window to find your organization’s designated directory for custom 
parts. (See Setting Options on page 9.)

4. In the list of custom parts presented, click the desired custom part to import.

5. Click Open. 

The custom part is now available for use. 

Delete Custom Part
To remove a custom part from your custom parts list:

1. On the Home tab, click the Manage tile and select Custom Parts.

2. In the list of custom parts on the left, click the part to remove.

3. Click the Delete selected part button. 

4. Click Yes in the confirmation message.

The custom part is removed from your list only. If the custom part was exported to the 
Custom Parts directory, you can import it again should you need it later on.

Managing Favorite Parts
Mark frequently used parts as favorites to make them easier to find when creating 
labels. 

Adding to Favorites
Add parts to favorites anytime you are using the parts list, such as when creating a 
label or while changing a label part (see Changing Label Parts on page 85). 

To add a part to favorites while using the parts list:
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1. Find the part that you want to mark as a favorite. For instructions see Finding a 
Part in the List on page 13. 

2. Click the symbol in the Type column to mark the part as a favorite. The symbol 
turns yellow to show that it is a favorite. A star symbol indicates a standard part; a 
wrench symbol indicates a custom part. 

Removing from Favorites

Remove a part from favorites in the same fashion. Click the icon in the Type column 
again. It turns grey to indicate that it is no longer a favorite. 

Sorting the Parts List
The parts list is initially sorted by Type, with parts in installed printers at the top, 
followed by favorite parts, and then custom parts. You can sort the parts list by any 
column. 

To sort the parts list:

1. Click a column heading (Part Name, Family, and so on). 

2. Click a second time to change to short direction. 

A triangle to the right of the column heading indicates in which direction (ascending or 
descending) the column has been sorted.
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7 Manage Printer/Part Pairings
You can associate a printer with a label part so whenever you print the specified label, 
by default it prints to its assigned printer. You can also set the corrective offsets for 
that printer. If you have paired a printer with a specific label part, whenever you use 
that label part, the name of the paired printer is reflected in the status bar at the 
bottom of the label editor.

Note: Even if a printer and label part are paired, you can still specify a different 
printer in the Print dialog box.

To pair a part with a printer:

1. On the Home tab, click Manage, then select Printer/Parts Pairing.

2. On the left side of the screen select the desired part. For information on searching 
and filtering the list, see Finding a Part in the List on page 13.

3. Click Add. The part is added to the list on the right side of the screen.

4. In the Printer column on the right, click Select a printer and choose the printer 
you want to use with this label part.

5. Click the Test Print button for this part. You may have to scroll the right pane to 
see the button at the far right. 

Brady test label data is sent to the printer as a means of testing the placement of 
the output. 

Note: LabelMark may not be able to verify that the printer has the correct media to 
support the label design. (For instance, attempting to print continuous data on die-
cut labels.) However, you can still proceed with the test by clicking OK in the 
verification message.

6. If the data was not aligned properly with the label in the test, use the Horizontal 
Adjustment and Vertical Adjustment fields to adjust the printout accordingly. 
For Horizontal Adjustment, a negative value moves the print left and a positive 
value moves the print right. For Vertical Adjustment, a negative value moves the 
print up and a positive value moves it down. 

7. Click Test Print again to check your settings. 

8. Repeat the above steps for as many pairings as needed.
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9. When finished, click the Save button.
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8 Importing Data
You can place data from an external source (external to LabelMark) on your labels. 
This data can exist in a text file, a spreadsheet program, or an external database. 

Adding External Data
To add external data to your labels:

1. Open the label file into which you want to import data.

2. Choose INSERT > External Data. A wizard launches to help you set up the 
import. 
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3. In the left column, select the type of file that contains the data to be imported.

Note: If you select Delimited Text File (the default), the delimiter options become 
available in the right column. Select the character that is used to separate the data in 
the text file into fields.

4. Click Select Source.

5. Use the Open window to locate and select the file to import, then click Open.

6. Click Next. The Select Fields page of the wizard opens. 

If the source file is a spreadsheet or database, there could be more than one data 
table included. In a spreadsheet, for example, each worksheet in the spreadsheet 
is considered a data table. Within the data table are rows and columns of data. 
Each row is a record (for example, one person’s contact information if the 
database is an address book) and each column is one type of data (first name, zip 
code, mobile phone). Each intersection of row and column is a field. So a record is 
made up of fields containing the data for that record. 

7. If applicable, in the Select table to use list, click the worksheet or data table that 
contains the data you want to import.

8. In the Select columns and order list, make sure only those columns that you 
want to import are selected. Clear all others. 
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If you want to change the order in which the data is placed on the labels, select a 
column and use the Up and Down buttons to change the order of the data. 

9. (Optional) If you don’t want to use all records, select one of the following to 
indicate how you want to choose which records to use. 

• Check to sort and filter records or use a custom SQL query. Choose 
records to include either by sorting and filtering the records based on some 
criteria or by using a custom SQL query. 

• Check to select specific records only to import. Manually select which 
records to include. 

10. Click Next. Depending on your selections one of three screens opens. 

• Filter Your Records, skip to step 12.

• Results, skip to step 11.

• Select Visual Element, skip to step 15.

11. The Results screen opens if you chose to select specific records to import. Select 
the records that you want to import using Shift-click and Ctrl-click to select 
multiple records. 

Click Next and skip to step 15.



Importing Data
Adding External Data

122

LabelMark 6.0 User’s Manual

12. The Filter Your Records screen opens if you chose to sort and filter or use a SQL 
query. (If using an existing SQL query click Next and skip to step 14.) 

Use the Filter Your Records screen to create statements that define which records 
you want to use, such as all records for the months of June, July, and August. You 
can add more than one statement. Fill in the boxes described below and then click 
Add to create one statement. Fill in the boxes again and click Add to add a 
second statement. 

• Field. Click in this box and select one of the columns from your spreadsheet 
or database (for example, Month, Color, or Address). 

• Operator. Choose how you want to match the field to the value you will 
specify next. For example, do you want to use fields that equal the value? The 
choices are: 

• Value. Type the value that you want to look for in the field. The value can be 
text or numeric. 

• And/Or. Select how this statement will be joined with the next one. Do you 
want to use the record if statement A and statement B match? Or if either 
statement A or statement B matches? Select None for the last statement. 

Example: To place data on labels only for the months of June, July, and August, 
set up the filter as shown in the following image. Note that OR was used to join the 

Operator Description
= equal

<> not equal

> greater than

< less than

>= greater than or equal to

<= less than or equal to

IN specify values for use with a SQL WHERE statement. This 
feature is intended for experienced SQL database users and is 
beyond the scope of this manual.

LIKE find similar values using the wildcard character % to represent 
unknown characters. For example, setting the value to 
A% Appliance would find AA Appliance, A1 Appliance, and 
Ag Appliance. 



123Importing Data
Adding External Data

LabelMark 6.0 User’s Manual

statements because any one record could have June or July or August as the 
month, but not June and July and August. 

When you are finished setting up your filter, click Next. 

13. The Sort Your Records screen opens. Specify in what order you want the records 
placed on the labels. For example, you might want to place the data on the labels 
in order by the date field or by location or part number. You can leave this screen 
blank if sort order does not matter. 

Click in the Sort first by box and select the first field to sort by. It will sort in 
ascending order (1-9, A-Z) unless you select the Descending check box. 

If desired, specify a second and third field to sort by. For example, you might want 
to print labels first in order by building and then by area. When you are finished, 
click Next. 

14. The SQL Query Review/Edit screen opens. If you want to use an existing SQL 
query saved as text, copy and paste the query in the Query box. If not using a 
SQL query, click Next and go to the next step. 

To write your own custom query, select Use custom query. The Query field fills 
with a sample query that you can edit. (SQL language and syntax are outside the 
scope of this manual.)  

When you are finished, click Next. 
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15. The Select Visual Element screen opens. Use this screen to reposition the field 
elements on the label and indicate if the data should be presented in text format or 
as a barcode. You can also remove some of the field elements from displaying on 
the label. 

Placing data on the label: If the label file is in graphics mode, select either Add 
new item as Text or Add new item as Barcode and then drag the desired 
column (field in the database) onto the preview label. Barcode is not available for 
line mode (text) labels. For graphics labels you can drag the fields on the preview 
label to reposition them; for line mode labels you cannot. Instead, click Remove 
All and then drag each field to the desired position or select a field on the preview 
and click Delete Selected Item. (Deleting a field from the preview label only 
removes it from displaying on the label. The field is still contained in the database 
and can be displayed on another label or in another label file.) 

Managing linked data: Imported data fields are added to labels as linked objects. 
(For more information on linked objects see Chapter 4 Serialization on page 89.) In 
addition to being linked from one label to the next, they maintain some connection 
to the external data file. If the data in the external file changes, you can refresh the 
data in the label file (see Refreshing Data on page 127). If you do not want the data 
for a particular field linked, select the field on the preview label and click Unlink 
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Selected Item. The data is no longer linked between labels and will not update 
from the data file when refreshed. 

Placing data on different labels: Generally all fields are placed on one label. 
However, if your label material has columns of labels (more than one label in a 
row), you can place each field on a different label. To do so:

a. Select the Show all labels in the row check box below the sample label. 
The preview shows one row of labels. Use the zoom and scroll bar to 
adjust the view as needed. 

b. Click Remove All to remove the fields that were automatically placed on 
the first label in the row. 

c. Drag the fields one by one from the left side of the screen to the label you 
want them on. When the data is added to the labels, each row will contain 
one record with each label across the row containing the field data as 
specified here. 

Formatting data (what to do if the field outline is red): A red outline on a field 
indicates that the data does not fit on the label. Either move the data object on the 
label or adjust the font size and other formatting properties to make it fit. Select 
the object and edit the settings in Label & Object properties in the left pane. For 
more information see Chapter 3 Formatting a Label on page 31. 

When you are happy with the arrangement of the data on the label, click Next. 

16. The Data Placement screen opens. 

• In the Repeat Imported Data field, enter the number of times to repeat each 
record before moving on to the next one.

• In the Apply to Labels section, select the appropriate option to indicate on 
which labels to place the imported data. The example shows the results of 
your selection. 

• Use the Place data on labels section if your label part has multiple columns. 
Select the direction you want the imported data applied to the labels: 
Over, then down: across each row from top to bottom. 
Down, then over: down each column from left to right. Further refine this 
method of data placement by setting the number of Vertical labels down to 
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go before moving over to the next column. Down, then over with Vertical 
labels down set to 1 is the same as Over, then down. 

• (Available with two-sided label parts only.) Select Duplicate data on second 
side if you want the imported data to repeat on the other side of the label.

• Click Next. 

17. The Save Scheme Information screen opens. If you want to save the import 
scheme, select Save this configuration as a Data Import Scheme for later 
use. Fill out the remaining fields and click Finish. 

The data is placed on the labels in the file as specified.

Using a Saved Data Import Scheme
To use a saved scheme:

1. Click the label where you want the imported data to begin.

Over, then down Down, then over
Vertical labels down = 4

Down, then over
Vertical labels down = 2
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2. Choose INSERT > Data from saved scheme. A window for selecting the scheme 
opens. 

3. In the list of Data Import Schemes, click the scheme to use. The right side of the 
window shows the settings for that scheme so you can verify that you have 
selected the scheme you want. 

4. Click Finish. The data is added to the selected label and to following labels as 
specified by the scheme.

Refreshing Data
Values in the label file remain as they were when imported even if values in the 
external data file have since been changed. To update values in the label file, refresh 
the imported data. 

1. Open the label file with the imported data. 

2. Choose TOOLS > Refresh > Imported Data.

3. Click Yes. The data on the labels is updated.
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9 Microsoft Visio
You can export Microsoft Visio drawings or text to LabelMark. This data is exported 
from inside the Visio program. The LabelMark software supports Microsoft Visio 2007 
and higher. 

Enabling the Visio Add-in
The ability to export data directly from Microsoft Visio is provided by an add-in. The 
add-in must be enabled to use this feature. 

To enable the Visio add-in:

1. Close Visio.

2. From the Windows Start menu select All Programs > Brady > LabelMark 6 > 
LabelMark AddIn Manager. 

3. Click the Visio add-in tile. Enabled add-ins have a frame around the tile. In the 
image below the AutoCAD add-in is disabled and the Excel and Visio add-ins are 
enabled. 

4. Click the Save button. 

5. Start Visio. 
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Exporting Selected Data from Visio
To export selected data from a Visio drawing into a new label file:

1. Open the Visio drawing containing the items to export.

2. Select the items to be exported.

3. Click the LabelMark 6 tab in the ribbon bar. 

4. Click Create Label. 

5. Click Selected area. The Select Label Part window opens.

6. Select either Template based or Part based. (For information on templates see 
Chapter 13 Templates on page 157.)

7. Click the template or label part that you want to use. (For more information on 
searching for label parts see Finding a Part in the List on page 13.)

8. Click Next. The Region Selection screen opens. 

9. Use the Zoom control to adjust the display so that you can see all the contents.

10. If you want to use the data exactly as is, skip to step 14. If you want to use part of 
the image, continue with the next step. 

11. In the image viewing area, click and drag to select the portion of the image you 
want.

12. If you are unhappy with your selection, simply click elsewhere in the drawing and 
try again. The Deselect button also removes the selection box. 

Note: Use the Label Size, Current Image Size, and Selection Size information 
below the image to size your selection to fit on the label. If the selected area does 
not fit on the label part, the software displays a message to this effect and will scale 
the image to make it fit. If you do not want the image scaled, either make sure the 
selection area fits on the label or click Back and choose a larger label.

13. Once the desired portion of data is selected, click Crop. If you want to start over, 
click Reset to return to the initial drawing. 

14. When ready, click Next.

15. Fill in the following fields on the Import Options screen.

• From label: The first label on which to place the drawing.

• Till label: The last label on which to place the drawing. 
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• Every: Which labels in between to place the drawing on. Set to 1 for every 
label, 2 for every other label, and so on. 

16. Click Next. The Process Data screen opens. 

17. Select one of the following three actions to take with the data:

• Save. Saves the data to the label file specified in the Save path. If desired, 
provide a different file name and path. 

• Save and Edit. Saves the data to the label file specified in the Save path and 
opens the file in the LabelMark software. If desired, provide a different file 
name and path.

• Print. Prints the labels without saving. 

18. Click Finish.

Exported data is linked within the label file. When you format the objects on one label, 
the formatting changes on the other labels as well. For more information about linked 
objects see Chapter 4 Serialization on page 89.

Exporting Text Items
Another option is to export just text. Only the text from the Visio document is exported. 
Shapes and connector lines are not exported. 

To export text:

1. Make sure the Viso add-in is enabled. See Enabling the Visio Add-in on page 129.

2. Open the Visio drawing containing the text to export. 

3. Click the LabelMark 6 tab in the ribbon bar. 

4. Click Create Label. 
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5. Click All text. The Select Data screen opens. 

Use this screen to move text from the Source box on the left to the Selected Fields 
box on the right. All text added to a field in the Selected Fields box is treated as 
one object on the label. To have each text item treated as a different object on the 
label, add a field for each.

6. Click Add Field to add a field on the right. 

Likewise, click Remove Field to remove a field. Any text on the field tab is 
returned to the Source box on the left. 

7. In the Source box, click the triangle to expand the list of text items.

8. Use the arrow buttons between the Source and Selected Fields boxes to move 
the text you want to export to the Selected Fields box. Click the text to export, 
select a field tab on the right, and then click the single right arrow button. 
Alternatively, if you want to export all text on all pages to the selected field, click 
the double right arrow button.

Note: Use Ctrl-Click or Shift-Click to select more than one item at a time.

9. If you wish to change the order of text in one of the fields, select the text to move 
and then click Up or Down to move the text to the desired position in the list.
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10. Once the text is organized as desired select one of the following options at the top 
of the Select Data window. 

• Export to LabelMark format. This places the data in a new label file in the 
LabelMark software. Continue with step 11.

• Export to text file. This sends the data to a text file. Specify the file name and 
path and then click Finish. The data is exported and the Select Data window 
closes. 

11. Click Next. The Select Label Part window opens. 

12. Select either Template based or Part based. (For information on templates see 
Chapter 13 Templates on page 157.)

13. Click the template or label part that you want to use. (For more information on 
searching for label parts see Finding a Part in the List on page 13.)

14. If you want to place some of the text on the labels as a barcode, be sure to select 
the Graphics Mode button above the list of label parts. 

15. Click Next. The Preview and Layout window opens. 

16. Use this screen to reposition the field objects on the label and indicate if the data 
should be presented in text format or as a barcode. 

Placing data on the label: If the label file is in graphics mode, select either Add 
new item as Text or Add new item as Barcode and then drag the desired field 
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onto the preview label. Barcode is not available for line mode (text) labels. For 
graphics labels you can drag the fields on the preview label to reposition them; for 
line mode labels you cannot. Instead, click Remove All and then drag each field 
to the desired position or select a field on the preview and click Delete Selected 
Item. (Deleting a field from the preview label only removes it from displaying on 
the label. The field is still available to be added to the label.) 

Managing linked data: Imported data fields are added to labels as linked objects. 
(For more information on linked objects see Chapter 4 Serialization on page 89.) If 
you do not want the data for a particular field linked, select the field on the preview 
label and click Unlink Selected Item. The data is no longer linked between 
labels. 

Placing data on different labels: Generally all fields are placed on one label. 
However, if your label material has columns of labels (more than one label in a 
row), you can place each field on a different label. To do so:

a. Select the Show all labels in the row check box below the sample label 
(only available if your label material has more than one column in a row). 
The preview shows one row of labels. Use the zoom and scroll bar to 
adjust the view as needed. 

b. Click Remove All to remove the fields that were automatically placed on 
the first label in the row. 

c. Drag the fields one by one from the left side of the screen to the label you 
want them on. When the data is added to the labels, each row will contain 
one record with each label across the row containing the field data as 
specified here. 

Formatting data: If desired adjust the font size and other formatting properties. 
Select the object and edit the settings in Label & Object properties in the left 
pane. For more information see Chapter 3 Formatting a Label on page 31. 

17. When you are happy with the arrangement of the data on the label, click Next. 
The Check Errors window opens. 
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18. Use the Check Errors window to fix any errors that are found. 

Fix the errors using one or a combination of the following methods:

• Click the Fix all errors button. The software fixes all the errors that it is able 
to. 

• On any error in the list, click Auto Fit. The software adjusts the object to fit on 
the label. 

• On any error in the list, click Go To. The software displays the object in error. 
Click the Back button and manually adjust the object to fit on the label (most 
likely by moving or resizing). 

As errors are corrected, they are removed from the list.

19. Click Next. The Process Data screen opens. 

20. Select one of the following three actions to take with the data:

• Save. Saves the data to the label file specified in the Save path. If desired, 
provide a different file name and path. 

• Save and Edit. Saves the data to the label file specified in the Save path and 
opens the file in the LabelMark software. If desired, provide a different file 
name and path.

• Print. Prints the labels without saving. 

21. Click Finish.
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10 Microsoft Excel
Just as you can import data from an Excel spreadsheet while in LabelMark (see 
Chapter 8 Importing Data on page 119), you can also export the spreadsheet data to 
LabelMark from inside the Excel program. The LabelMark software supports Microsoft 
Excel 2007 and higher. 

Enabling the Excel Add-in
The ability to export data directly from Microsoft Excel is provided by an add-in. The 
add-in must be enabled to use this feature. 

To enable the Excel add-in:

1. Close Excel.

2. From the Windows Start menu select All Programs > Brady > LabelMark 6 > 
LabelMark AddIn Manager. 

3. Click the Excel add-in tile. Enabled add-ins have a frame around the tile. In the 
image below the AutoCAD add-in is disabled and the Excel and Visio add-ins are 
enabled. 

4. Click the Save button. 

5. Start Excel. 
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Exporting Data from Microsoft Excel
To export data from Excel:

1. Open the Excel spreadsheet containing the data you want to export.

2. If you only want to export some of the fields and records, select the desired data 
before proceeding.

3. Click the LabelMark 6 tab in the ribbon bar. 

4. Click Create Label. 

5. If you want to include empty spreadsheet cells, select the Include blank space 
check box. This prevents data from shifting if a cell is left empty, thus maintaining 
row and column relationships. 

6. Click either the All data or Selected data tile. The Select Data window opens.

Tip: If you click Selected data, the following window is filled in automatically. 

7. Use the Select Data window to move data from the Source box on the left to the 
Selected Fields box on the right. Each field in the Source box is a column from the 
spreadsheet. All data added to a field in the Selected Fields box is treated as one 
object on the label. To have each data item treated as a different object on the 
label, add a field for each. This is usually the desired configuration, where one 



139Microsoft Excel
Exporting Data from Microsoft Excel

LabelMark 6.0 User’s Manual

column from the spreadsheet (field on the left) corresponds to one object on the 
label (field on the right). 

The image above shows an example in which All data was selected in step 6. If 
Selected data had been chosen instead, the Select Data window would have 
been filled in automatically with everything from Field A on the left in Field 1 on the 
right and everything in Field B on the left in Field 2 on the right. In that case skip to 
step 13.

Each data item on a field tab in the Selected Fields box is placed on a different 
label. Therefore, the number of labels generated reflects the number of data items 
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added to the fields. If multiple fields are used, the field with the largest number of 
data items determines how many labels are generated. 

For instance, if you have three data items in Field #1, two data items in Field #2, 
and four data items in Field #3, you get a total of four labels with data, as 
illustrated in the following diagram. 

Figure 20 • Labels generated from exported Excel data

8. Click Add Field to add a field on the right. 

Likewise, click Remove Field to remove a field. Any data on the field is returned 
to the Source box on the left. 

9. In the Source box, click the triangle to expand the list of data items.

10. Use the arrow buttons between the Source and Selected Fields boxes to move 
the data you want to export to the Selected Fields box. Click the data to export, 
select a field tab on the right, and then click the single right arrow button. 
Alternatively, if you want to export all data in all fields (spreadsheet columns) to 
the selected field (label object), click the double right arrow button.

Note: Use Ctrl-Click or Shift-Click to select more than one item at a time.

11. If you wish to change the order of data in one of the fields on the right, select the 
item to move and then click Up or Down to move it to the desired position in the 
list.

12. Once the data is organized as desired select one of the following options at the 
top of the Select Data window. 

• Export to LabelMark format. This places the data in a new label file in the 
LabelMark software. Continue with step 13.
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• Export to text file. This sends the data to a text file. Specify the file name and 
path and then click Finish. The data is exported and the Select Data window 
closes. 

13. Click Next. The Select Label Part window opens. 

14. Select either Template based or Part based. (For information on templates see 
Chapter 13 Templates on page 157.)

15. Click the template or label part that you want to use. (For more information on 
searching for label parts see Finding a Part in the List on page 13.)

16. Click Next. The Preview and Layout window opens. 

17. Use this screen to reposition the field objects on the label and indicate if the data 
should be presented in text format or as a barcode. 

Placing data on the label: If the label file is in graphics mode, select either Add 
new item as Text or Add new item as Barcode and then drag the desired field 
onto the preview label. Barcode is not available for line mode (text) labels. For 
graphics labels you can drag the fields on the preview label to reposition them; for 
line mode labels you cannot. Instead, click Remove All and then drag each field 
to the desired position or select a field on the preview and click Delete Selected 
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Item. (Deleting a field from the preview label only removes it from displaying on 
the label. The field is still available to be added to the label.) 

Managing linked data: Imported data fields are added to labels as linked objects. 
(For more information on linked objects see Chapter 4 Serialization on page 89.) If 
you do not want the data for a particular field linked, select the field on the preview 
label and click Unlink Selected Item. The data is no longer linked between 
labels. 

Placing data on different labels: Generally all fields are placed on one label. 
However, if your label material has columns of labels (more than one label in a 
row), you can place each field on a different label. To do so:

a. Select the Show all labels in the row check box below the sample label 
(only available if your label material has more than one column in a row). 
The preview shows one row of labels. Use the zoom and scroll bar to 
adjust the view as needed. 

b. Click Remove All to remove the fields that were automatically placed on 
the first label in the row. 

c. Drag the fields one by one from the left side of the screen to the label you 
want them on. When the data is added to the labels, each row will contain 
one record with each label across the row containing the field data as 
specified here. 

Duplicating to side 2: If the label part is two-sided and you want to duplicate the 
data on the second side, select Duplicate side 1 data bound elements to side 
2. A message alerts you that any data already placed on side 2 will be lost. Click 
Yes. Side 2 with the duplicated data is shown in the preview.

Formatting data: If desired adjust the font size and other formatting properties. 
Select the object and edit the settings in Label & Object properties in the left 
pane. For more information see Chapter 3 Formatting a Label on page 31. 

18. When you are happy with the arrangement of the data on the label, click Next. 
The Check Errors window opens.
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19. Use the Check Errors window to fix any errors that are found. 

Fix the errors using one or a combination of the following methods:

• Click the Fix all errors button. The software fixes all the errors that it is able 
to. 

• On any error in the list, click Auto Fit. The software adjusts the object to fit on 
the label. 

• On any error in the list, click Go To. The software displays the object in error. 
Click the Back button and manually adjust the object to fit on the label (most 
likely by moving or resizing). 

As errors are corrected, they are removed from the list.

20. Click Next. The Process Data screen opens. 

21. Select one of the following three actions to take with the data: 

• Save. Saves the data to the label file specified in the Save path. If desired, 
provide a different file name and path. 

• Save and Edit. Saves the data to the label file specified in the Save path and 
opens the file in the LabelMark software. If desired, provide a different file 
name and path.

• Print. Prints the labels without saving. Opens the Print dialog box, see Print 
Dialog Box on page 22. 
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22. Click Finish.
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11 AutoCAD 
You can place AutoCAD drawings on labels in LabelMark by either importing from 
within LabelMark or exporting directly from the AutoCAD software. The LabelMark 
software supports AutoCAD 2010 and higher. 

Importing AutoCAD Drawings
You can import a 2-dimensional AutoCAD drawing from within the LabelMark 
software. 

To import an AutoCAD drawing:

1. Open or create a graphics mode drawing in the LabelMark software. (For help 
with this see Chapter 2 Creating Labels on page 11.)

2. Choose INSERT > AutoCAD Object.

3. Click Open Drawing.

4. Navigate to and select the AutoCAD drawing file that you want to import. Click 
Open. 

5. Click Next. The Region Selection window opens.

6. If you want to use the entire drawing, click Next and go to the next step. If you 
want to use only part of the drawing: 

• Select the part of the image that you want to use. Use the Zoom control to 
resize the drawing to make selection easier. Click and drag to select a portion 
of the drawing. You can drag the resizing handles in the corners of the 
selection area to refine it. Click Crop. 

• Before cropping, if you want to clear the selection area click Deselect.

• After cropping, if the result is not as desired, click Reset. 

7. Click Next. The Import Options window opens. 

8. Fill in the following fields on the Import Options screen.

• From label: The first label on which to place the drawing.

• Till label: The last label on which to place the drawing. 

• Every: Which labels in between to place the drawing on. Set to 1 for every 
label, 2 for every other label, and so on. 

9. Click Finish.
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Imported data is linked. As you format one item, it is formatted the same on other 
labels as well. (See Linked Objects starting on page 77 for more information.)

Exporting Data from AutoCAD
To export data from within the AutoCAD software, you must enable the AutoCAD add-
in for LabelMark. Then you can export either the text from the drawing or a selected 
area of the drawing. 

Enabling the AutoCAD Add-in
The ability to export data directly from AutoCAD is provided by an add-in. The add-in 
must be enabled to use this feature. 

To enable the AutoCAD add-in:

1. Close AutoCAD.

2. From the Windows Start menu select All Programs > Brady > LabelMark 6 > 
LabelMark AddIn Manager. 

3. Click the AutoCAD add-in tile. Enabled add-ins have a frame around the tile. In 
the image below the AutoCAD add-in is disabled and the Excel and Visio add-ins 
are enabled. 

4. Click the Save button. 

5. Start AutoCAD. 
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Exporting a Selected Area
To export selected data from an AutoCAD drawing into a new label file:

1. Open the AutoCAD drawing containing the items to export.

2. Select the drawing objects to be exported.

3. Click the LabelMark tab in the ribbon bar. 

4. Click Create Label. 

5. Click Selected area. The Select Label Part window opens. 

6. Select either Template based or Part based. (For information on templates see 
Chapter 13 Templates on page 157.)

7. Click the template or label part that you want to use. (For more information on 
searching for label parts see Finding a Part in the List on page 13.)

8. Click Next. The Region Selection screen opens. 

9. Use the Zoom control to adjust the display so that you can see all the contents.

10. If you want to use the data exactly as is, skip to step 14. If you want to use part of 
the image, continue with the next step. 

11. In the image viewing area, click and drag to select the portion of the image you 
want.

12. If you are unhappy with your selection, simply click elsewhere in the drawing and 
try again. The Deselect button also removes the selection box. 

Note: Use the Label Size, Current Image Size, and Selection Size information 
below the image to size your selection to fit on the label. If the selected area does 
not fit on the label part, the software displays a message to this effect and will scale 
the image to make it fit. If you do not want the image scaled, either make sure the 
selection area fits on the label or click Back and choose a larger label.

13. Once the desired portion of data is selected, click Crop. If you want to start over, 
click Reset to return to the initial drawing. 

14. When ready, click Next.

15. Fill in the following fields on the Import Options screen.

• From label: The first label on which to place the drawing.

• Till label: The last label on which to place the drawing. 
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• Every: Which labels in between to place the drawing on. Set to 1 for every 
label, 2 for every other label, and so on. 

16. Click Next. The Process Data screen opens. 

17. Select one of the following three actions to take with the data:

• Save. Saves the data to the label file specified in the Save path. If desired, 
provide a different file name and path. 

• Save and Edit. Saves the data to the label file specified in the Save path and 
opens the file in the LabelMark software. If desired, provide a different file 
name and path.

• Print. Prints the labels without saving. 

18. Click Finish.

Exported data is linked within the label file. When you format the objects on one label, 
the formatting changes on the other labels as well. For more information about linked 
objects see Chapter 4 Serialization on page 89.

Exporting Text Items
You can export text from AutoCAD drawings to LabelMark. The AutoCAD add-in must 
be enabled. See Enabling the AutoCAD Add-in on page 146.

To export text:

1. Open the AutoCAD drawing containing the text to export. 

2. If you want to export only some of the text on the drawing, select the text on the 
AutoCAD drawing now. You can select one area of the drawing that contains the 
text that you want to export. 

3. Click the LabelMark tab in the ribbon bar. 

4. Click Create Label. 
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5. Click either All text or Selected text (if you selected some text in the AutoCAD 
drawing in step 2). The Select Data screen opens. 

Use this screen to move text from the Source box on the left to the Selected Fields 
box on the right. All text added to a field in the Selected Fields box is treated as 
one object on the label. To have each text item treated as a different object on the 
label, add a field for each.

6. Click Add Field to add a field on the right. 

Likewise, click Remove Field to remove a field. Any text on the field tab is 
returned to the Source box on the left. 

7. In the Source box, click the triangle to expand the list of text items.

8. Use the arrow buttons between the Source and Selected Fields boxes to move 
the text you want to export to the Selected Fields box. Click the text to export, 
select a field tab on the right, and then click the single right arrow button. 
Alternatively, if you want to export all text to the selected field, click the double 
right arrow button.

Note: Use Ctrl-Click or Shift-Click to select more than one item at a time.

9. If you wish to change the order of text in one of the fields, select the text to move 
and then click Up or Down to move the text to the desired position in the list.
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10. Once the text is organized as desired select one of the following options at the top 
of the Select Data window. 

• Export to LabelMark format. This places the data in a new label file in the 
LabelMark software. Continue with step 11.

• Export to text file. This sends the data to a text file. Specify the file name and 
path and then click Finish. The data is exported and the Select Data window 
closes. 

11. Click Next. The Select Label Part window opens. 

12. Select either Template based or Part based. (For information on templates see 
Chapter 13 Templates on page 157.)

13. Click the template or label part that you want to use. (For more information on 
searching for label parts see Finding a Part in the List on page 13.)

14. If you want to place some of the text on the labels as a barcode, be sure to select 
the Graphics Mode button above the list of label parts. If you want to place some 
of the text on the labels in wire mark format, click the Line Mode button.

15. Click Next. The Preview and Layout window opens. 
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16. Use this screen to reposition the field objects on the label and indicate if the data 
should be presented in text format or as a barcode. 

Placing data on the label: If the label file is in graphics mode, select either Add 
new item as Text or Add new item as Barcode and then drag the desired field 
onto the preview label. Barcode is not available for line mode (text) labels. For 
graphics labels you can drag the fields on the preview label to reposition them; for 
line mode labels you cannot. Instead, click Remove All and then drag each field 
to the desired position or select a field on the preview and click Delete Selected 
Item. (Deleting a field from the preview label only removes it from displaying on 
the label. The field is still available to be added to the label.) 

Managing linked data: Imported data fields are added to labels as linked objects. 
(For more information on linked objects see Chapter 4 Serialization on page 89.) If 
you do not want the data for a particular field linked, select the field on the preview 
label and click Unlink Selected Item. The data is no longer linked between 
labels. 

Placing data on different labels: Generally all fields are placed on one label. 
However, if your label material has columns of labels (more than one label in a 
row), you can place each field on a different label. To do so:

a. Select the Show all labels in the row check box below the sample label 
(only available if your label material has more than one column in a row). 
The preview shows one row of labels. Use the zoom and scroll bar to 
adjust the view as needed. 
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b. Click Remove All to remove the fields that were automatically placed on 
the first label in the row. 

c. Drag the fields one by one from the left side of the screen to the label you 
want them on. When the data is added to the labels, each row will contain 
one record with each label across the row containing the field data as 
specified here. 

Formatting data: If desired adjust the font size and other formatting properties. 
Select the object and edit the settings in Label & Object properties in the left 
pane. For more information see Chapter 3 Formatting a Label on page 31. 

Applying wiremark format: (Line mode only.) If the labels are for a wire marking 
application, apply the wiremark format. First select any field on the label. Then in 
the left pane click Label & Object properties. Finally, scroll through the list of 
properties and select the Wiremark check box. The fields repeat down the length 
of the label as many times as they fit. 

17. When you are happy with the arrangement of the data on the label, click Next. 
The Check Errors window opens. 

18. Use the Check Errors window to fix any errors that are found. 

Fix the errors using one or a combination of the following methods:

• Click the Fix all errors button. The software fixes all the errors that it is able 
to. 
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• On any error in the list, click Auto Fit. The software adjusts the object to fit on 
the label. 

• On any error in the list, click Go To. The software displays the object in error. 
Click the Back button and manually adjust the object to fit on the label (most 
likely by moving or resizing). 

As errors are corrected, they are removed from the list.

19. Click Next. The Process Data screen opens. 

20. Select one of the following three actions to take with the data:

• Save. Saves the data to the label file specified in the Save path. If desired, 
provide a different file name and path. 

• Save and Edit. Saves the data to the label file specified in the Save path and 
opens the file in the LabelMark software. If desired, provide a different file 
name and path.

• Print. Prints the labels without saving. 

21. Click Finish.
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12 Manage Saved Data Import and 
Serialization Schemes

Once you have saved data import and serialization schemes, you need a way to 
manage them: to edit a scheme, to copy a scheme and then edit it to create a new 
scheme, to delete a scheme that is no longer needed, and so on. 

For details on serialization and on data import, see Chapter 4 Serialization on page 89 
and Chapter 8 Importing Data on page 119.

Managing Saved Schemes
To manage saved schemes: 

1. On the Home page, click the Manage tile and select either Data Import Schemes 
or Data Serialization Schemes.

Use the toolbar buttons to perform the functions described in the following table. 

Button Description
Create new. 
Data Import: Opens the External Data Import wizard. Follow the 
instructions in Adding External Data starting on page 119 to fill out the 
pages of the wizard and create a data import scheme.
Serialization: Opens the Data Serialization wizard. Follow the 
instruction in Inserting Basic Serialization on page 91 or Inserting 
Advanced Serialization on page 94.

Delete. Deletes the selected scheme.

Import. Import a scheme from another location. 

Export. Export the selected scheme to another location.

Copy. Copy the selected scheme. Then edit the copied scheme to 
create a new scheme similar to the original. 

Edit. Opens the External Data Import wizard or the Data Serialization 
wizard. Use the wizard to change the scheme. 
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Using a Saved Scheme to Add Data to a Label 
File

If you import data to a label file that already contains data, the imported data is placed 
on the label along with the existing data rather than replacing the existing data. 

To use a saved data import or serialization scheme:

1. Open the label file on which you want to apply the scheme or create a new label 
file.

2. On the Home page, click the Manage tile and select Data Import Schemes or 
Data Serialization Schemes.

3. In the list of saved schemes on the left, click the scheme to use.

4. Click the Apply to label file button in the toolbar. (The Apply to label file button is 
only available if a label file is open.)

5. In the list of open label files, click the file into which you want to import data using 
the selected scheme. 

6. In the Start label column, enter the label number on which to start placing the 
imported data. 

7. If the labels are two sided, select which side to place the data on. 

8. Click Apply scheme.

Rename. Enter a new name for the selected scheme.

Apply to label file. Use the selected scheme to import data to a label 
file. See Using a Saved Scheme to Add Data to a Label File on page 156.

Button Description
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13 Templates
A template provides a pattern, or starting point, for designing labels. Use it to provide the 
standard data objects you want included in labels such as company name, graphics, 
and hazard words and symbols. 

Creating a Template
Creating a template is similar to creating a label. The difference being that the items 
placed on a label in the template will be repeated on all labels in the label file and can 
be locked into place so that they cannot be removed or edited when using the 
template to create a label file. 

To create a template:

1. On the Home tab, click the Create tile and select New Template.

2. Click a Part Name to use for the template. For help locating the part see Finding a 
Part in the List on page 13.

Note: Choose Graphics Mode if you want to add images and barcodes. Choose 
Line Mode if you want to add only text.

3. Click Create. The label editor opens. 

By default, you are presented with the Single Label layout. This helps to focus on 
the template design, understanding that everything placed on this single label is 
duplicated on all labels in the label file using the template. 

4. Optional. If you want multiple label designs in one template (different labels 
displaying different items), choose VIEW > Multiple label layout.

5. Add data objects to the label (or labels). See Chapter 3 Formatting a Label on page 
31 for information about adding data objects and formatting the label. 

6. Set properties for the template. See Template Properties on page 158. 
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7. When finished, click the Save button.

8. Enter a name for the template and click Save. The template is saved to the default 
directory on your computer, C:\ProgramData\Brady\LabelMark6\TemplateFiles.

Creating a Template from a Recent Part
If the part you want to use for your template is in the RECENT PARTS list on the 
Home tab, you can quickly create a new template from the part. 

1. On the Home tab, in the RECENT PARTS list, click the label part to use. 

2. Choose Graphics Mode if you want to add images and barcodes. Choose Line 
Mode if you want to add only text.

3. Click Create Template. 

A blank template file opens using the selected label part. 

Template Properties
Set properties for templates in the same way as for labels using the Label & Object 
properties and File & Part properties panels. For more information on using the 
properties panels see Properties Panels on page 44.

Label & Object Properties
When adding objects to a template file, there are additional properties available which 
govern layout of objects on a label file created from the specific template. These 
properties are set on and stored with the template. They are not available in regular 
label files or on label files created from the template. 
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The additional properties available only for objects placed on a template are:

• Can Move

• Can Select

If the Can Move option is selected on the template, when creating a label file from the 
template, you will be able to move objects to different areas of the label. If the option 
is NOT selected when the template is created, the objects will remain fixed (cannot 
move them) on the label file created from that template.

If the Can Select option is selected on the template, when creating a label file from the 
template, you will be able to select the object, resize it, and move it to different areas 
of the label (even if the Can Move options was NOT selected). For Text objects, if the 
Can Select option is checked on the template, when creating a label file from that 
template, the Text objects display as text boxes, with no data. This allows you to enter 
different data in those text objects. The text objects remain stationary (cannot be 
moved) even if Can Move IS selected.

When adding text that must always stay on the labels (such as a logo), make sure 
when designing the template that the Can Select option is unchecked for that 
particular text object.

File & Part properties
In addition to the Can Move and Can Select properties of a template, you can also 
control the ability to edit a label file created from a template in the File & Part 
properties panel. The Allow users to modify label design option is selected by 
default. If you do not want a user to be able to modify the layout of a label created 
from a template, de-select the option. 

When you create a new label based on this template, you will only be able to enter 
data in any visible text boxes or change the text in a barcode object. You will not be 
able to add any other elements, move or resize objects already on the label, change 
fonts or sizes, etc. When creating a label file from a template with "Allow users to 
modify label design" option unchecked, the options in the Label Objects Properties 
box are grayed out. All elements in the Action toolbar are also grayed out, indicating 
you cannot use them.

Turning off "Allow users to modify label design" takes precedence over Can Select 
and Can Move. If you want to be able to modify some aspects of the label created 
from the template, leave "Allow users to modify label design" turned ON (i.e., place a 
checkmark in the option box) but UNCHECK Can Select and/or Can Move. (If Can 
Select is not checked, Can Move is automatically disabled. You cannot move an 
object if you cannot select it.)

Examples

Following are examples of labels produced from templates with the various file 
properties and Label & Object properties turned on (checked) or off (unchecked).
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Scenario 1

The template was created using the following options:

• File property “Allow users to modify label design” - ON.

• Product Name text box object, label objects property “Can Select” - OFF

• Barcode object, label objects property “Can Select” and “Can Move” - ON

On the label file created from this template, the Product Name text box cannot be 
edited, but additional items can be added to the label. In this case, another text object 
was added (“cutting blade” text box). In addition, the barcode data was edited and the 
barcode was moved to display under the added text box. 

Scenario 2

The template was created using the following options:

• File property “Allow users to modify label design” - ON.

• Brady logo image object, label objects property “Can Select” - OFF

• Product Name text object, label objects property “Can Select” - OFF

• SKU # text object, label objects property “Can Select” - OFF

• Miscellaneous text objects, label objects property “Can Select” and “Can Move” - 
ON
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On the label file created from this template, the Logo image object, Product Name, 
and SKU text boxes cannot be edited, moved, or deleted. However, data can be 
added to the miscellaneous text boxes. The miscellaneous text boxes can also be re-
aligned and the font and attributes can be changed. Additional text or graphic 
elements can be added to the labels. 

Scenario 3

The template was created using the following options:

• File property “Allow users to modify label design” - OFF.

• Brady logo image object, label objects property “Can Select” - OFF

• Product Name text object, label objects property “Can Select” - OFF

• SKU # text object, label objects property “Can Select” - OFF

• Miscellaneous text objects, label objects property “Can Select” - ON
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On the label file created from this template, the Logo image object, Product Name and 
SKU text boxes cannot be edited, moved, or deleted. Data can be added to the 
miscellaneous text boxes, but you cannot change the font or attributes. When printed 
out, the label would look like this:

Scenario 4

The template was created using the following options:

• File property “Allow users to modify label design” - OFF.

• Brady logo image object, label objects property “Can Select” - OFF

• Product Name text object, label objects property “Can Select” - OFF, “Printable” - 
OFF

• SKU # text object, label objects property “Can Select” - OFF, “Printable” - OFF
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• Miscellaneous text objects, label objects property “Can Select” - ON

On the label file created from this template, the Logo image object, Product Name and 
SKU text boxes cannot be edited, moved, or deleted. Data can be added to the 
miscellaneous text boxes, but you cannot change the font or attributes. When printed, 
the Product Name and SKU # text boxes will not print, leaving only the Logo and 
Miscellaneous text boxes on the label. When printed out, the label would look like this:

Using a Template
To use a template to create labels:

1. On the Home page click the Create tile and select New Label Using Template. 

2. In the list of templates displayed, click the template to use.

3. Click Next. The New Labels from Template tab opens. 

4. Click one of the following tiles to choose how you want to add data to the label. 
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• Edit Label: Enter data using the label editor. 

a. Click Finish.

b. The label editor opens. Enter data directly on the fields on the label. 

• Data Entry: Enter data using a form. 

a. Click Next. 

b. Fill in the data fields on the left and then click Finish. 

• Saved Data: Obtain data from a previously saved data import or serialization 
scheme. 

a. Click Next.

b. Select the data import or serialization scheme to use and click Finish. 

• External Data: Import data setting up the import in the next step. 

a. Click Next.

b. Follow the instructions in Adding External Data on page 119 to fill in the 
pages of the External Data Import wizard. 

• Serialized Data: Add serialized data setting up the sequential data in the next 
steps. 

a. Click Next.

b. Follow the instructions in Inserting Basic Serialization on page 91 or 
Inserting Advanced Serialization on page 94 to fill in the pages of the Data 
Serialization wizard.

5. Save the label file.

All the labels in the label file have the template data items in place.

Edit a Template
To edit a template or to create another template from an established template:

1. On the Home page click the Open tile and select Template. 

2. Select the template to edit and click Open.

3. Make the desired changes to the template.

4. Save the template. If you want to keep the original template and use these 
changes to create a new template, select FILE > Save as and provide a new 
name for the template. 
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Printing Labels From Templates
Although a template places predefined data elements on all labels in a file using the 
template, when you print the label file, only those labels that have actual new data on 
them will print. If you move the template’s data elements on one of the labels, it is 
considered new data and that label will print. 
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14 Apps
Apps are small software components used to create labels for a very specific 
purpose. LabelMark 6.0 contains the following apps, depending on whether you have 
Standard or Professional:

• Terminal Blocks (formerly called 110-Blocks) (Standard and Professional)

• Control Panel Labels (Professional)

• Datacomm Labels (Professional)

• Text Conversion (Professional)

• Heatex Conversion (Professional)

• Laboratory Labels (Professional)

• ADM Import (Professional)

• Wire Harness Labels (Professional)

To open an app go to the Home page and click the tile for the app. 

Note: If the app tiles are dimmed, purchase an upgrade from LabelMark Standard 
to Professional. Once the Professional version is activated, the app tiles become 
available. 

Terminal Blocks (formerly called 110-Blocks)
The Terminal Blocks label type is based on user-selected wire pair configurations, 
with the length of the label determined by the pair type selected. The number and 
formatting of areas is based on pair configuration and block type selected.

In the Terminal Blocks label, the number of areas created is based on the pair 
configuration selected. Vertical and horizontal separator lines are automatically 
added.

The following example displays the areas based on the wire pairs selected (that is, 2-
pair, 3-pair, 4-pair, 5-pair). 
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Block Type is used to determine how data is serialized. Horizontal increments one 
number per area, based on the start value. 

In Backbone block type, the left-most area on each strip prints with two numbers. The 
first number is left-justified; the second number is right justified. All other areas print 
with one right-justified number. 

Note: A strip is one completed, fully populated label. If multiple strips are added, 
each additional strip continues the numbering sequence from the last number of the 
previous strip. Example: When requesting two strips of a 4-pair configuration, the 
first strip will contain values 1-12, the second strip will contain numbers 13-24.
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To use the Terminal Blocks app:

1. On the Home tab, click the Terminal Blocks tile.

2. (LabelMark Professional only) On the New Job Builder window, enter a name for 
the Terminal Blocks job file, then click OK. (For more information about jobs see 
Chapter 5 Job File Management on page 99.)

A workspace opens for your new job. 

3. (LabelMark Professional only) Click the Add New Label tile in the upper left 
corner of the workspace.

4. The Terminal Blocks app presents three steps to complete for the new label. 
Select the default name, NewLabel, in the upper left and type a new name for the 
label. 

The first step, Label Type is already complete because there is only one kind of 
terminal block. You do not have to enter anything in Step 1.

Note: The presence of the checkmark in the Step # position indicates you do not 
have to select anything - that step is complete.

5. In Step 2 - Part or Template, click one of the following: 
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• Blank Part: if you want to start with a label part.

• Template: if you have a template to start with. 

6. Select either the label part or the template to use. For help finding a label part see 
Finding a Part in the List on page 13. 

7. In Step 3 - Label Data, click the Generate Data button. A window opens for 
editing block information and the sequential (serialized) data to place on the label. 

8. Fill in the fields across the top of the editing window.

• Part Name: This is filled in for you with the part you selected or the part 
associated with the template you selected. 

• Product Width: This is filled in for you with the width of the label part.

• Block Width: Enter the width for a block. This width is applied to all blocks in 
the strip.

• Number of Strips: Enter the number of strips you need. 

9. Fill in the 110 Block serialization panel on the left. 

• Block Type: Click in this field and select either Backbone or Horizontal. 
These are described on page 168. 

• Wire Pairs: Enter the number representing the pair configuration (1-pair, 2-
pair, 3-pair, and so on). This is the number by which the blocks increment. For 
example, if you set it to 3-pair (with a start value of 1), the numbers in the 
blocks will be 1, 3, 6, 9, and so on. 

• Start: Enter the number with which to start the Terminal Blocks sequence. 

Note: An alternative to entering the information in this step is to use a saved 
serialization or import scheme. To do so, use the Data Serialization Schemes or the 
Data Import Schemes panels on the left. These panels list schemes saved in the 
default location. For more information see Chapter 4 Serialization on page 89 and 
Chapter 8 Importing Data on page 119.

10. Click OK. Your changes are applied and the editing screen closes. 

11. Click OK on the screen showing the three steps. The Terminal Blocks workspace 
displays a tile representing the new label. 

Tip: To rename the label, click the name on the label tile, select the current name, 
and type a new one.
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12. If desired, click the Add New Label tile to add more labels to the job, repeating the 
steps above for each label you add. 

When you hover over a label in the Terminal Blocks workspace, buttons for 
changing the label become visible: 

13. When complete, click Finish. If you have LabelMark Professional, a tab for the 
newly created job opens. For information on how to work with job files see Chapter 
5 Job File Management on page 99.

Control Panel Labels
(LabelMark Professional only)

Use the Control Panel app to create labels used on various types of control panels, 
including wire, face plate, push button, and terminal block. To use the Control Panel 
app:

1. On the Home page, click the Control Panel Labels tile.

2. On the New Job Builder window, enter a name for the control panel job file, then 
click OK. (For more information about jobs see Chapter 5 Job File Management on 
page 99.)

A workspace opens for your new job. 

3. Click the Add New Label tile in the upper left corner of the workspace.

The Control Panel Label app presents three steps to complete for the new label.

Edit. Opens the screen with three steps so you can make changes.

Copy. Places a copy of the label in the Terminal Blocks workspace. 
Click Edit on the new label to make changes and to provide a new 
name.

Remove. Deletes the label.
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4. Select the default name, NewLabel, in the upper left and type a new name for the 
label. 

5. In Step 1 - Label Type, click the type of label to add to the control panel job.

6. In Step 2 - Part or Template, click one of the following: 

• Blank Part: if you want to start with a label part.

• Template: if you have a template to start with.

7. Select either the label part or the template to use. For help finding a label part see 
Finding a Part in the List on page 13. 

8. In Step 3 - Label Data, click one of the following: 

• Add Data Now: Displays three choices for how you want to add data now. 
Continue with step 9. 

• Add Data Later: Marks step 3 as complete. Click OK. When you are ready to 
add data, see Adding Data Later on page 173.

Note: As each step is completed, the step number changes to a checkmark to 
indicate that you have completed that step.

9. Select one of the following: 
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• Serialized data: Opens the Data Serialization wizard for specifying sequential 
data. For help with the wizard see Inserting Basic Serialization on page 91 or 
Inserting Advanced Serialization on page 94.

• External data: Opens the External Data Import wizard for importing data from 
a delimited text file, Microsoft Excel, Microsoft Access, or from a SQL Server 
Client or Microsoft OLE database. For help with the wizard see Adding 
External Data on page 119. 

• Data from previously saved schemes: Opens a window for you to select a 
saved data import or serialization scheme. Select the scheme you want and 
click OK. For more information see Using a Saved Serialization Scheme on 
page 98 or Using a Saved Data Import Scheme on page 126. 

10. Click OK on the screen showing the three steps. The Control Panel Labels 
workspace displays a tile representing the new label. 

11. If desired, click the Add New Label tile to add more labels to the job, repeating the 
steps above for each label you add. 

When you hover over a label in the workspace, buttons for changing the label 
become visible: 

12. When complete, click Finish. A tab for the newly created job opens. For 
information on how to work with job files see Chapter 5 Job File Management on 
page 99. Once you click Finish in the workspace you cannot return to the 
workspace. Future changes must be made via the job file. 

Adding Data Later
Once the three-step screen is closed for an app, you cannot reopen it. (See image in 
step 4 on page 172.) Instead, open the saved job file to make changes. 

To add data to a label file that was created using the Control Panel Labels app: 

1. On the Home page click the Open tile and select Job. 

2. Select the job file with the control panel labels and click Open. 

3. The left side of the page for the job file lists the label files within that job. Click on 
the label file that you want to edit. 

Edit. Opens the three-step screen so you can make changes.

Copy. Places a copy of the label in the workspace. Click Edit on the 
new label to make changes and to provide a new name.

Remove. Deletes the label.
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4. On the right side of the page click Open in Editor. 

5. Add data to the label as you would with any label file. Add: 

• Individual items manually. See Adding and Editing Objects on page 31.

• Sequential information. See Chapter 4 Serialization on page 89. 

• Imported data. See Adding External Data on page 119.

• Data using a saved serialization or data import scheme. See Using a Saved 
Serialization Scheme on page 98 or Using a Saved Data Import Scheme on 
page 126. 

6. Click the Save button. 

Datacomm Labels
(LabelMark Professional only)

Use the Datacomm app for labels designed to fit certain manufacturers' data 
communication panels. Depending on the manufacturer's panel that you select, this 
app automatically sets the dimensions and parameters of the label to fit that particular 
panel. If the desired manufacturer or product is not listed, you can define your own 
data and save it as a custom product. 

To use the Datacomm app:

1. On the Home page, click the Datacomm Labels tile.

2. On the New Job Builder window, enter a name for the datacomm job file, then 
click OK. (For more information about jobs see Chapter 5 Job File Management on 
page 99.)

A workspace opens for your new job. 

3. Click the Add New Label tile in the upper left corner of the workspace.

The Datacomm Labels app presents three steps to complete for the new label.
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4. Select the default name, NewLabel, in the upper left and type a new name for the 
label. 

5. In Step 1 - Label Type, click the type of component that this label file is for. (When 
this label file is complete you can add more label files to the datacomm job for 
other types of components.)

6. In Step 2 - Part or Product, click one of the following: 

• Product: if you want to create labels with certain parameters already set up 
for a particular product. 

a. On the right side of the window click a product to select it. 
To find the product more easily in a long list, use the fields in the left pane 
to search or filter the list. To search for a product, type the name in the By 
Product Name field. As you type, the list narrows to show matching 
products. To filter the list, select a manufacturer in the By Manufacturer 
field. 

b. On the right side of the window click in the Printer type field and select a 
printer. The label part for the selected product and printer is filled in below 
the Selected part heading. 

c. Click OK. 

• Blank Part: if you want to start with a label part.

a. Select the label part to use. For help finding a label part see Finding a Part 
in the List on page 13. 

b. Click OK. 
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7. In Step 3 - Label Data, click DataComm parameters. A window opens for editing 
block information and the sequential (serialized) data to place on the label. 

8. If created from a blank part, fill in the fields across the top of the editing window. If 
created from a product, these fields are not displayed because the information 
was determined by selecting the product. 

• Part Name: This is filled in for you with the part you selected. 

• Product Width: This is filled in for you with the width of the label part unless 
you chose a continuous label part.

• Block Width: Enter the width for a block. This width is applied to all blocks in 
the strip. (A block is one section of a label that is divided in to sections. See 
the description of terminal blocks beginning on page 167.)

• Number of Strips: Enter the number of strips (labels) you need. 

9. Fill in the DataComm Serialization panel on the left. 

• Wire Pairs: Enter the number representing the pair configuration (1-pair, 2-
pair, 3-pair, and so on). This is the number by which the blocks increment. For 
example, if you set it to 3-pair (with a start value of 1), the numbers in the 
blocks will be 1, 3, 6, 9, and so on. 

• Start: Enter the number with which to start the Terminal Blocks sequence. 

• Save as custom product. (Optional) Click this button if you want to save 
these settings as a custom product for future use. Provide a product name 
and a manufacturer. 

Note: An alternative to entering the information in this step is to use a saved 
serialization or import scheme. To do so, use the Data Serialization Schemes or the 
Data Import Schemes panels on the left. These panels list schemes saved in the 
default location. For more information see Chapter 4 Serialization on page 89 and 
Chapter 8 Importing Data on page 119.

10. Click OK. Your changes are applied and the editing screen closes. 

11. Click OK on the screen showing the three steps. The Datacomm workspace 
displays a tile representing the new label. 
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12. If desired, click the Add New Label tile to add more labels to the job, repeating the 
steps above for each label you add. 

When you hover over a label in the Datacomm workspace, buttons for changing 
the label become visible: 

13. When complete, click Finish. A tab for the newly created job opens. For 
information on how to work with job files see Chapter 5 Job File Management on 
page 99.

Editing the Datacomm Labels Later
Once the three-step screen is closed for an app, you cannot reopen it. Instead, open 
the saved job file to make changes. 

To edit the data later: 

1. On the Home page click the Open tile and select Job. 

2. Select the job file with the Datacomm labels and click Open. 

3. The left side of the page for the job file lists the label files within that job. Click on 
the label file that you want to edit. 

4. On the right side of the page click Open in Editor. 

5. Use the File & Part properties panel to set the Product Width, Block Width, or to 
Save as custom product. 

6. Edit data on the labels in any of the following ways. 

• Manually change data: Double-click in the block you want to change. Select 
the current number and replace it with the desired number. 

• Add a new label: Click on the label before which you want to add another 
label. Select INSERT > Insert label. 

• Edit the sequential block data: Select EDIT > Edit DataComm Serialization. 
For help using the editing window see steps 8 and 9 on page 176. 

7. Click the Save button. 

Edit. Opens the editor so you can make changes.

Copy. Places a copy of the label in the workspace. Click Edit on the 
new label to make changes and to provide a new name.

Remove. Deletes the label.
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Laboratory Labels
(LabelMark Professional only)

Use the Laboratory Labels app to create labels used on various types of laboratory 
media, including centrifuge tubes, conicals, cryovials, slides, vial tops and well plates. 

To use the Laboratory Labels app:

1. On the Home page, click the Laboratory Labels tile.

2. On the New Job Builder window, enter a name for the job file, then click OK. (For 
more information about jobs see Chapter 5 Job File Management on page 99.)

A workspace opens for your new job. 

3. Click the Add New Label tile in the upper left corner of the workspace.

The Laboratory Labels app presents three steps to complete for the new label.

4. Select the default name, NewLabel, in the upper left and type a new name for the 
label. 

5. In Step 1 - Label Type, click the type of label to add to the job.

6. In Step 2 - Part or Template, click one of the following: 

• Blank Part: if you want to start with a label part.

• Template: if you have a template to start with.
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7. Select either the label part or the template to use. For help finding a label part see 
Finding a Part in the List on page 13. 

8. In Step 3 - Label Data, click one of the following: 

• Add Data Now: Displays three choices for how you want to add data now. 
Continue with step 9. 

• Add Data Later: Marks step 3 as complete. Click OK. Later, when you are 
ready to add data, see Adding Data Later on page 173.

Note: As each step is completed, the step number changes to a checkmark to 
indicate that you have completed that step.

9. Select one of the following: 

• Serialized data: Opens the Data Serialization wizard for specifying sequential 
data. For help with the wizard see Inserting Basic Serialization on page 91 or 
Inserting Advanced Serialization on page 94.

• External data: Opens the External Data Import wizard for importing data from 
a delimited text file, Microsoft Excel, Microsoft Access, or from a SQL Server 
Client or Microsoft OLE database. For help with the wizard see Adding 
External Data on page 119. 

• Data from previously saved schemes: Opens a window for you to select a 
saved data import or serialization scheme. Select the scheme you want and 
click OK. For more information see Using a Saved Serialization Scheme on 
page 98 or Using a Saved Data Import Scheme on page 126. 

10. Click OK on the screen showing the three steps. The Laboratory Labels 
workspace displays a tile representing the new label. 

11. If desired, click the Add New Label tile to add more labels to the job, repeating the 
steps above for each label you add. 

When you hover over a label in the workspace, buttons for changing the label 
become visible: 

12. When complete, click Finish. A tab for the newly created job opens. For 
information on how to work with job files see Chapter 5 Job File Management on 
page 99. Once you click Finish in the workspace you cannot return to the 

Edit. Opens the three-step screen so you can make changes.

Copy. Places a copy of the label in the workspace. Click Edit on the 
new label to make changes and to provide a new name.

Remove. Deletes the label.
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workspace. Future changes must be made via the job file. 

Adding Data Later
Once the three-step screen is closed for an app, you cannot reopen it. Instead, open 
the saved job file to make changes. 

To add data to a label file that was created using the Laboratory Labels app: 

1. On the Home page click the Open tile and select Job. 

2. Select the job file with the laboratory labels and click Open. 

3. The left side of the page for the job file lists the label files within that job. Click on 
the label file that you want to edit. 

4. On the right side of the page click Open in Editor. 

5. Add data to the label as you would with any label file. Add: 

• Individual items manually. See Adding and Editing Objects on page 31.

• Sequential information. See Chapter 4 Serialization on page 89. 

• Imported data. See Adding External Data on page 119.

• Data using a saved serialization or data import scheme. See Using a Saved 
Serialization Scheme on page 98 or Using a Saved Data Import Scheme on 
page 126. 

6. Click the Save button. 

Wire Harness Labels
(LabelMark Professional only)

Use the Wire Harness app to create labels specific for wire harness applications. 

To use the Wire Harness app:

1. On the Home tab, click the Wire Harness Labels tile.

2. On the New Job Builder window, enter a name for the wire harness job file, then 
click OK. (For more information about jobs see Chapter 5 Job File Management on 
page 99.)

A workspace opens for your new job. 

3. Click the Add New Label tile in the upper left corner of the workspace.

The Wire Harness Labels app presents three steps to complete for the new label.
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4. Select the default name, NewLabel, in the upper left and type a new name for the 
label. 

The first step, Label Type is already complete because there is only one kind of 
label. You do not have to enter anything in Step 1.

Note: The presence of the checkmark in the Step # position indicates that the step 
is complete.

5. In Step 2 - Part or Template, click one of the following: 

• Blank Part: if you want to start with a label part.

• Template: if you have a template to start with.

6. Select either the label part or the template to use. For help finding a label part see 
Finding a Part in the List on page 13. 

7. In Step 3 - Label Data, click one of the following: 

• Add Data Now: Displays three choices for how you want to add data now. 
Continue with step 9. 

• Add Data Later: Marks step 3 as complete. Click OK. Later, when you are 
ready to add data, see Adding Data Later on page 173.



Apps
Wire Harness Labels

182

LabelMark 6.0 User’s Manual

Note: As each step is completed, the step number changes to a checkmark to 
indicate that you have completed that step.

8. Select one of the following: 

• Serialized data: Opens the Data Serialization wizard for specifying sequential 
data. For help with the wizard see Inserting Basic Serialization on page 91 or 
Inserting Advanced Serialization on page 94.

• External data: Opens the External Data Import wizard for importing data from 
a delimited text file, Microsoft Excel, Microsoft Access, or from a SQL Server 
Client or Microsoft OLE database. For help with the wizard see Adding 
External Data on page 119. 

• Data from previously saved schemes: Opens a window for you to select a 
saved data import or serialization scheme. Select the scheme you want and 
click OK. For more information see Using a Saved Serialization Scheme on 
page 98 or Using a Saved Data Import Scheme on page 126. 

9. Click OK on the screen showing the three steps. The Wire Harness Labels 
workspace displays a tile representing the new label. 

10. If desired, click the Add New Label tile to add more labels to the job, repeating the 
steps above for each label you add. 

When you hover over a label in the workspace, buttons for changing the label 
become visible: 

11. When complete, click Finish. A tab for the newly created job opens. For 
information on how to work with job files see Chapter 5 Job File Management on 
page 99. Once you click Finish in the workspace you cannot return to the 
workspace. Future changes must be made via the job file. 

Adding Data Later
Once the three-step screen is closed for an app, you cannot reopen it. Instead, open 
the saved job file to make changes. 

To add data to a label file that was created using the Wire Harness Labels app: 

Edit. Opens the three-step screen so you can make changes.

Copy. Places a copy of the label in the workspace. Click Edit on the 
new label to make changes and to provide a new name.

Remove. Deletes the label.
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1. On the Home page click the Open tile and select Job. 

2. Select the job file with the wire harness labels and click Open. 

3. The left side of the page for the job file lists the label files within that job. Click on 
the label file that you want to edit. 

4. On the right side of the page click Open in Editor. 

5. Add data to the label as you would with any label file. Add: 

• Individual items manually. See Adding and Editing Objects on page 31.

• Sequential information. See Chapter 4 Serialization on page 89. 

• Imported data. See Adding External Data on page 119.

• Data using a saved serialization or data import scheme. See Using a Saved 
Serialization Scheme on page 98 or Using a Saved Data Import Scheme on 
page 126. 

6. Click the Save button. 
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